summaryrefslogtreecommitdiff
path: root/user/telegram/rlottie.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-22 19:04:45 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-22 19:04:45 +0000
commit5eedb4d420d89a89a5a926b2276274d13c1a12c6 (patch)
treec26d80528a9e4a518b91d9d722027f5326d5e04a /user/telegram/rlottie.patch
parentca0ba7a6ae14c92c93600d292a94c76474cb6040 (diff)
downloadpackages-5eedb4d420d89a89a5a926b2276274d13c1a12c6.tar.gz
packages-5eedb4d420d89a89a5a926b2276274d13c1a12c6.tar.bz2
packages-5eedb4d420d89a89a5a926b2276274d13c1a12c6.tar.xz
packages-5eedb4d420d89a89a5a926b2276274d13c1a12c6.zip
user/telegram: New package
Diffstat (limited to 'user/telegram/rlottie.patch')
-rw-r--r--user/telegram/rlottie.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/user/telegram/rlottie.patch b/user/telegram/rlottie.patch
new file mode 100644
index 000000000..6bd2ff6c3
--- /dev/null
+++ b/user/telegram/rlottie.patch
@@ -0,0 +1,16 @@
+No CMake config exists for rlottie; use pkgconf instead.
+
+--- a/cmake/external/rlottie/CMakeLists.txt 2020-01-17 18:21:17.000000000 +0100
++++ b/cmake/external/rlottie/CMakeLists.txt 2020-01-18 00:37:40.280438388 +0100
+@@ -8,8 +8,9 @@
+ add_library(external_rlottie INTERFACE IMPORTED GLOBAL)
+ add_library(desktop-app::external_rlottie ALIAS external_rlottie)
+
+- find_package(rlottie REQUIRED)
+- target_link_libraries(external_rlottie INTERFACE rlottie::rlottie)
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(RLOTTIE REQUIRED rlottie)
++ target_link_libraries(external_rlottie INTERFACE ${RLOTTIE_LIBRARIES})
+ else()
+ add_library(external_rlottie OBJECT)
+ add_library(desktop-app::external_rlottie ALIAS external_rlottie)