summaryrefslogtreecommitdiff
path: root/user/thunderbird
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 03:42:30 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 03:42:30 +0000
commit87d19aac7937fe920a4d04f4fa05282b85f417ff (patch)
tree4236f827959d4f8e3eaff03e2d8771d8355ccca1 /user/thunderbird
parent90abce861d9030964445029a98b8cf40705d2704 (diff)
downloadpackages-87d19aac7937fe920a4d04f4fa05282b85f417ff.tar.gz
packages-87d19aac7937fe920a4d04f4fa05282b85f417ff.tar.bz2
packages-87d19aac7937fe920a4d04f4fa05282b85f417ff.tar.xz
packages-87d19aac7937fe920a4d04f4fa05282b85f417ff.zip
user/thunderbird: Bump to 68.4.1
Diffstat (limited to 'user/thunderbird')
-rw-r--r--user/thunderbird/APKBUILD27
-rw-r--r--user/thunderbird/yuv-be.patch48
2 files changed, 8 insertions, 67 deletions
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index 1e9912cfd..72656527c 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=thunderbird
-pkgver=68.0
+pkgver=68.4.1
pkgrel=0
pkgdesc="Email client from Mozilla"
url="https://www.thunderbird.net/"
@@ -14,7 +14,7 @@ depends=""
# actual deps
makedepends="
autoconf2.13 cargo cbindgen clang llvm8-dev node ncurses-dev
- perl rust rust-stdlib cmd:which
+ perl rust cmd:which
ncurses-dev openssl-dev
@@ -27,7 +27,7 @@ makedepends="
startup-notification-dev unzip yasm zip gtk+2.0-dev
"
_py2ver="2.7.16"
-source="https://archive.mozilla.org/pub/thunderbird/candidates/$pkgver-candidates/build2/source/thunderbird-$pkgver.source.tar.xz
+source="https://archive.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
https://www.python.org/ftp/python/$_py2ver/Python-$_py2ver.tar.xz
mozconfig
@@ -40,7 +40,6 @@ source="https://archive.mozilla.org/pub/thunderbird/candidates/$pkgver-candidate
shut-up-warning.patch
stackwalk-x86-ppc.patch
webrtc-broken.patch
- yuv-be.patch
thunderbird.desktop
"
@@ -81,22 +80,20 @@ unpack() {
}
prepare() {
- cd "$builddir"
default_prepare
cp "$srcdir"/mozconfig "$builddir"/mozconfig
echo "ac_add_options --enable-optimize=\"$CFLAGS\"" >> "$builddir"/mozconfig
echo "ac_add_options --host=\"$CHOST\"" >> "$builddir"/mozconfig
echo "ac_add_options --target=\"$CTARGET\"" >> "$builddir"/mozconfig
- # too much memory
- if [ -z "$JOBS" ] || [ $JOBS -ge 16 ]; then
- JOBS=16
- fi
echo "mk_add_options MOZ_MAKE_FLAGS=\"-j$JOBS\"" >> "$builddir"/mozconfig
case "$CARCH" in
pmmx|x86*)
echo "ac_add_options --disable-elf-hack" >> "$builddir"/mozconfig
;;
+ s390x)
+ echo "ac_add_options --disable-startupcache" >> "$builddir"/mozconfig
+ ;;
esac
rm "$builddir"/third_party/python/virtualenv/virtualenv_support/pip*.whl
@@ -106,8 +103,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
export SHELL=/bin/sh
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
@@ -120,9 +115,6 @@ build() {
export UNIXCONFDIR="$srcdir"
- local extra_flags=""
- [ "$CARCH" = "s390x" ] && extra_flags="--disable-startupcache"
-
export PATH="$srcdir/python/bin:$PATH"
./mach build
}
@@ -130,18 +122,16 @@ build() {
run() {
cd "$builddir"/obj-$CHOST/dist/bin
export LD_LIBRARY_PATH=.
- ./firefox -no-remote -profile "$builddir"/obj-$CHOST/tmp/profile-default
+ ./thunderbird -no-remote -profile "$builddir"/obj-$CHOST/tmp/profile-default
}
package() {
- cd "$builddir"
export PATH="$srcdir/python/bin:$PATH"
DESTDIR="$pkgdir" ./mach install
install -m755 -d ${pkgdir}/usr/share/applications
install -m755 -d ${pkgdir}/usr/share/pixmaps
- local png
for png in comm/mail/branding/thunderbird/default*.png; do
local i="${_png%.png}"
i=${i##*/default}
@@ -155,7 +145,7 @@ package() {
${pkgdir}/usr/share/applications/thunderbird.desktop
}
-sha512sums="5177c11e841f6aa704634ce66fa9f1af02703d8c04dfeabf19829551f997cd80b60e8fa32af71ea64cf27af2be3956971bb6b75645dfc68417bb257a41872e3e thunderbird-68.0.source.tar.xz
+sha512sums="16cccbc2313472e6312e842a28079782238cb22e72b324bebaffefa4a2fe68fec9f2173f2c83f1caccc5522ab9145884b2e2a58e97e236f7aefa4c61764e08b7 thunderbird-68.4.1.source.tar.xz
16e814e8dcffc707b595ca2919bd2fa3db0d15794c63d977364652c4a5b92e90e72b8c9e1cc83b5020398bd90a1b397dbdd7cb931c49f1aa4af6ef95414b43e0 Python-2.7.16.tar.xz
5519234df2934ac2f3d76c8cad7e4f0fe15cf83ea4beb32c6489d8b7839b3ebea88bdb342e0d2a9c1c7c95e9455d234b0a5aa0e73446fd8027b520f080a2bb5b mozconfig
ace7492f4fb0523c7340fdc09c831906f74fddad93822aff367135538dacd3f56288b907f5a04f53f94c76e722ba0bab73e28d83ec12d3e672554712e6b08613 bad-google-code.patch
@@ -167,5 +157,4 @@ e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb1
39ddb15d1453a8412275c36fc8db3befc69dffd4a362e932d280fb7fd1190db595a2af9b468ee49e0714f5e9df6e48eb5794122a64fa9f30d689de8693acbb15 shut-up-warning.patch
452b47b825294779f98ed46bc1065dad76b79ff453521ef049934a120f349c84a1c863b16af1828fe053059823da9690ec917c055ae02dcc5c80c54cad732448 stackwalk-x86-ppc.patch
be68f1387aa6677875a67106e2d6a9db470c934c943056d3b53391a63034235108e41945c53957db427d9cdc59f0aa2f9e6f2f8cd862e090e512a3ab9cbcc9a8 webrtc-broken.patch
-2dfb986089c9afcd6a895302c8a5a1d299cffa4cc3c73fce784c29d348f362c1e7570109c4f09d328275d8549a96531736dd976411c15956b385d7fb211b8af2 yuv-be.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"
diff --git a/user/thunderbird/yuv-be.patch b/user/thunderbird/yuv-be.patch
deleted file mode 100644
index ccb0c2fd8..000000000
--- a/user/thunderbird/yuv-be.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-# HG changeset patch
-# User A. Wilcox <AWilcox@Wilcox-Tech.com>
-# Date 1543674229 0
-# Sat Dec 01 14:23:49 2018 +0000
-# Node ID 0309ff19e46b126c527e633518d7de8570442114
-# Parent 53107afbc21ec78e7ac46d37af212505f2032d5d
-Bug 1511604 - Swizzle YCbCr->RGB data on big-endian machines
-
-diff -r 53107afbc21e -r 0309ff19e46b gfx/ycbcr/YCbCrUtils.cpp
---- a/gfx/ycbcr/YCbCrUtils.cpp Wed Nov 07 04:50:21 2018 +0000
-+++ b/gfx/ycbcr/YCbCrUtils.cpp Sat Dec 01 14:23:49 2018 +0000
-@@ -3,7 +3,9 @@
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-
-+#include "mozilla/EndianUtils.h"
- #include "gfx2DGlue.h"
-+#include "mozilla/gfx/Swizzle.h"
-
- #include "YCbCrUtils.h"
- #include "yuv_convert.h"
-@@ -236,6 +238,13 @@
- yuvtype,
- srcData.mYUVColorSpace);
- }
-+#if MOZ_BIG_ENDIAN
-+ // libyuv makes endian-correct result, which needs to be swapped to BGRX
-+ if (aDestFormat != SurfaceFormat::R5G6B5_UINT16)
-+ gfx::SwizzleData(aDestBuffer, aStride, gfx::SurfaceFormat::X8R8G8B8,
-+ aDestBuffer, aStride, gfx::SurfaceFormat::B8G8R8X8,
-+ srcData.mPicSize);
-+#endif
- }
-
- void
-@@ -257,6 +266,12 @@
- aSrcStrideYA,
- aSrcStrideUV,
- aDstStrideARGB);
-+#if MOZ_BIG_ENDIAN
-+ // libyuv makes endian-correct result, which needs to be swapped to BGRA
-+ gfx::SwizzleData(aDstARGB, aDstStrideARGB, gfx::SurfaceFormat::A8R8G8B8,
-+ aDstARGB, aDstStrideARGB, gfx::SurfaceFormat::B8G8R8A8,
-+ IntSize(aWidth, aHeight));
-+#endif
- }
-
- } // namespace gfx