summaryrefslogtreecommitdiff
path: root/user/tinyfugue
diff options
context:
space:
mode:
authorSheila Aman <sheila@vulpine.house>2021-08-04 23:13:23 +0000
committerSheila Aman <sheila@vulpine.house>2021-08-04 23:14:02 +0000
commit1e5f0c623264165ed85bea37c81ea01400512899 (patch)
treec76da9cc943487116de65194d7c7cec331df8193 /user/tinyfugue
parent29c9bc40a8f18ed162c7e6790a4e77ff78530c31 (diff)
downloadpackages-1e5f0c623264165ed85bea37c81ea01400512899.tar.gz
packages-1e5f0c623264165ed85bea37c81ea01400512899.tar.bz2
packages-1e5f0c623264165ed85bea37c81ea01400512899.tar.xz
packages-1e5f0c623264165ed85bea37c81ea01400512899.zip
user/tinyfugue: move from tf, upgrade to 5.1.1
Diffstat (limited to 'user/tinyfugue')
-rw-r--r--user/tinyfugue/0001-Add-DESTDIR-support.patch143
-rw-r--r--user/tinyfugue/0003-Minor-man-page-fixes.patch112
-rw-r--r--user/tinyfugue/0006-Fix-library-install-path.patch38
-rw-r--r--user/tinyfugue/0007-Fix-spelling-errors.patch59
-rw-r--r--user/tinyfugue/APKBUILD42
5 files changed, 394 insertions, 0 deletions
diff --git a/user/tinyfugue/0001-Add-DESTDIR-support.patch b/user/tinyfugue/0001-Add-DESTDIR-support.patch
new file mode 100644
index 000000000..5495a82f2
--- /dev/null
+++ b/user/tinyfugue/0001-Add-DESTDIR-support.patch
@@ -0,0 +1,143 @@
+--- tinyfugue-5.1.0/unix/unix.mak
++++ tinyfugue-5.1.0.new/unix/unix.mak
+@@ -81,62 +81,71 @@
+ -test -z "$(STRIP)" || $(STRIP) tf$(X) || true
+
+ PREFIXDIRS:
+- test -d "$(bindir)" || mkdir $(bindir)
+- test -d "$(datadir)" || mkdir $(datadir)
+
+ install_TF $(TF): tf$(X) $(BUILDERS)
+- -@rm -f $(TF)
+- cp tf$(X) $(TF)
+- chmod $(MODE) $(TF)
++ install -Dm755 tf${X} ${DESTDIR}${bindir}/tf
+
+ SYMLINK $(SYMLINK): $(TF)
+- test -z "$(SYMLINK)" || { rm -f $(SYMLINK) && ln -s $(TF) $(SYMLINK); }
+
+ LIBRARY $(TF_LIBDIR): ../lib/tf/tf-help ../lib/tf/tf-help.idx
+- @echo '## Creating library directory...'
+-# @# Overly simplified shell commands, to avoid problems on ultrix
+- -@test -n "$(TF_LIBDIR)" || echo "TF_LIBDIR is undefined."
+- test -n "$(TF_LIBDIR)"
+- test -d "$(TF_LIBDIR)" || mkdir $(TF_LIBDIR)
+- -@test -d "$(TF_LIBDIR)" || echo "Can't make $(TF_LIBDIR) directory. See if"
+- -@test -d "$(TF_LIBDIR)" || echo "there is already a file with that name."
+- test -d "$(TF_LIBDIR)"
+-#
+-# @#rm -f $(TF_LIBDIR)/*; # wrong: this would remove local.tf, etc.
+- @echo '## Copying library files...'
+- cd ../lib/tf; \
+- for f in *; do test -f $$f && files="$$files $$f"; done; \
+- ( cd $(TF_LIBDIR); rm -f $$files tf.help tf.help.index; ); \
+- cp $$files $(TF_LIBDIR); \
+- cd ../../lib/py; \
+- for f in *; do test -f $$f && pyfiles="$$pyfiles $$f"; done; \
+- ( cd $(TF_LIBDIR); rm -f $$pyfiles tf.help tf.help.index; ); \
+- cp $$pyfiles $(TF_LIBDIR); \
+- cd $(TF_LIBDIR); \
+- chmod $(MODE) $$files; chmod ugo-wx $$files ;\
+- chmod $(MODE) $$pyfiles; chmod ugo-wx $$pyfiles
+- -rm -f $(TF_LIBDIR)/CHANGES
+- cp ../CHANGES $(TF_LIBDIR)
+- chmod $(MODE) $(TF_LIBDIR)/CHANGES; chmod ugo-wx $(TF_LIBDIR)/CHANGES
+- chmod $(MODE) $(TF_LIBDIR)
+- -@cd $(TF_LIBDIR); old=`ls replace.tf 2>/dev/null`; \
+- if [ -n "$$old" ]; then \
+- echo "## WARNING: Obsolete files found in $(TF_LIBDIR): $$old"; \
+- fi
+- @echo '## Creating links so old library names still work...'
+-# @# note: ln -sf isn't portable.
+- @cd $(TF_LIBDIR); \
+- rm -f bind-bash.tf; ln -s kb-bash.tf bind-bash.tf; \
+- rm -f bind-emacs.tf; ln -s kb-emacs.tf bind-emacs.tf; \
+- rm -f completion.tf; ln -s complete.tf completion.tf; \
+- rm -f factorial.tf; ln -s factoral.tf factorial.tf; \
+- rm -f file-xfer.tf; ln -s filexfer.tf file-xfer.tf; \
+- rm -f local.tf.sample; ln -s local-eg.tf local.tf.sample; \
+- rm -f pref-shell.tf; ln -s psh.tf pref-shell.tf; \
+- rm -f space_page.tf; ln -s spc-page.tf space_page.tf; \
+- rm -f speedwalk.tf; ln -s spedwalk.tf speedwalk.tf; \
+- rm -f stack_queue.tf; ln -s stack-q.tf stack_queue.tf; \
+- rm -f worldqueue.tf; ln -s world-q.tf worldqueue.tf;
++ install -Dm644 ../lib/tf/lisp.tf ${DESTDIR}${datadir}/tf-lib/lisp.tf
++ install -Dm644 ../lib/tf/hanoi.tf ${DESTDIR}${datadir}/tf-lib/hanoi.tf
++ install -Dm644 ../lib/tf/spell.tf ${DESTDIR}${datadir}/tf-lib/spell.tf
++ install -Dm644 ../lib/tf/spedwalk.tf ${DESTDIR}${datadir}/tf-lib/spedwalk.tf
++ install -Dm644 ../lib/tf/kb-emacs.tf ${DESTDIR}${datadir}/tf-lib/kb-emacs.tf
++ install -Dm644 ../lib/tf/tf-help.idx ${DESTDIR}${datadir}/tf-lib/tf-help.idx
++ install -Dm644 ../lib/tf/tools.tf ${DESTDIR}${datadir}/tf-lib/tools.tf
++ install -Dm644 ../lib/tf/watch.tf ${DESTDIR}${datadir}/tf-lib/watch.tf
++ install -Dm644 ../lib/tf/kb_badterm.tf ${DESTDIR}${datadir}/tf-lib/kb_badterm.tf
++ install -Dm644 ../lib/tf/world-q.tf ${DESTDIR}${datadir}/tf-lib/world-q.tf
++ install -Dm644 ../lib/tf/changes.tf ${DESTDIR}${datadir}/tf-lib/changes.tf
++ install -Dm644 ../lib/tf/stack-q.tf ${DESTDIR}${datadir}/tf-lib/stack-q.tf
++ install -Dm644 ../lib/tf/factoral.tf ${DESTDIR}${datadir}/tf-lib/factoral.tf
++ install -Dm644 ../lib/tf/cylon.tf ${DESTDIR}${datadir}/tf-lib/cylon.tf
++ install -Dm644 ../lib/tf/quoter.tf ${DESTDIR}${datadir}/tf-lib/quoter.tf
++ install -Dm644 ../lib/tf/psh.tf ${DESTDIR}${datadir}/tf-lib/psh.tf
++ install -Dm644 ../lib/tf/textutil.tf ${DESTDIR}${datadir}/tf-lib/textutil.tf
++ install -Dm644 ../lib/tf/finger.tf ${DESTDIR}${datadir}/tf-lib/finger.tf
++ install -Dm644 ../lib/tf/savehist.tf ${DESTDIR}${datadir}/tf-lib/savehist.tf
++ install -Dm644 ../lib/tf/textencode.tf ${DESTDIR}${datadir}/tf-lib/textencode.tf
++ install -Dm644 ../lib/tf/spc-page.tf ${DESTDIR}${datadir}/tf-lib/spc-page.tf
++ install -Dm644 ../lib/tf/teraterm.keyboard.cnf ${DESTDIR}${datadir}/tf-lib/teraterm.keyboard.cnf
++ install -Dm644 ../lib/tf/testcolor.tf ${DESTDIR}${datadir}/tf-lib/testcolor.tf
++ install -Dm644 ../lib/tf/tintin.tf ${DESTDIR}${datadir}/tf-lib/tintin.tf
++ install -Dm644 ../lib/tf/grep.tf ${DESTDIR}${datadir}/tf-lib/grep.tf
++ install -Dm644 ../lib/tf/tfrc ${DESTDIR}${datadir}/tf-lib/tfrc
++ install -Dm644 ../lib/tf/rwho.tf ${DESTDIR}${datadir}/tf-lib/rwho.tf
++ install -Dm644 ../lib/tf/alias.tf ${DESTDIR}${datadir}/tf-lib/alias.tf
++ install -Dm644 ../lib/tf/kbbind.tf ${DESTDIR}${datadir}/tf-lib/kbbind.tf
++ install -Dm644 ../lib/tf/complete.tf ${DESTDIR}${datadir}/tf-lib/complete.tf
++ install -Dm644 ../lib/tf/kbregion.tf ${DESTDIR}${datadir}/tf-lib/kbregion.tf
++ install -Dm644 ../lib/tf/color.tf ${DESTDIR}${datadir}/tf-lib/color.tf
++ install -Dm644 ../lib/tf/kb-bash.tf ${DESTDIR}${datadir}/tf-lib/kb-bash.tf
++ install -Dm644 ../lib/tf/kbstack.tf ${DESTDIR}${datadir}/tf-lib/kbstack.tf
++ install -Dm644 ../lib/tf/filexfer.tf ${DESTDIR}${datadir}/tf-lib/filexfer.tf
++ install -Dm644 ../lib/tf/activity_status.tf ${DESTDIR}${datadir}/tf-lib/activity_status.tf
++ install -Dm644 ../lib/tf/tfstatus.tf ${DESTDIR}${datadir}/tf-lib/tfstatus.tf
++ install -Dm644 ../lib/tf/relog.tf ${DESTDIR}${datadir}/tf-lib/relog.tf
++ install -Dm644 ../lib/tf/local-eg.tf ${DESTDIR}${datadir}/tf-lib/local-eg.tf
++ install -Dm644 ../lib/tf/stdlib.tf ${DESTDIR}${datadir}/tf-lib/stdlib.tf
++ install -Dm644 ../lib/tf/at.tf ${DESTDIR}${datadir}/tf-lib/at.tf
++ install -Dm644 ../lib/tf/tick.tf ${DESTDIR}${datadir}/tf-lib/tick.tf
++ install -Dm644 ../lib/tf/kb-os2.tf ${DESTDIR}${datadir}/tf-lib/kb-os2.tf
++ install -Dm644 ../lib/tf/kbfunc.tf ${DESTDIR}${datadir}/tf-lib/kbfunc.tf
++ install -Dm644 ../lib/tf/pcmd.tf ${DESTDIR}${datadir}/tf-lib/pcmd.tf
++ install -Dm644 ../lib/tf/map.tf ${DESTDIR}${datadir}/tf-lib/map.tf
++ install -Dm644 ../lib/tf/activity_status2.tf ${DESTDIR}${datadir}/tf-lib/activity_status2.tf
++ install -Dm644 ../lib/tf/kb-old.tf ${DESTDIR}${datadir}/tf-lib/kb-old.tf
++ install -Dm644 ../lib/tf/tr.tf ${DESTDIR}${datadir}/tf-lib/tr.tf
++ install -Dm644 ../CHANGES ${DESTDIR}${datadir}/tf-lib/CHANGES
++ install -Dm644 ../README.md ${DESTDIR}${datadir}/tf-lib/README
++ install -Dm644 ../lib/tf/examples.old ${DESTDIR}${datadir}/tf-lib/examples.old
++ install -Dm644 ../lib/py/config.py ${DESTDIR}${datadir}/tf-lib/config.py
++ install -Dm644 ../lib/py/diffedit.py ${DESTDIR}${datadir}/tf-lib/diffedit.py
++ install -Dm644 ../lib/py/tf.py ${DESTDIR}${datadir}/tf-lib/tf.py
++ install -Dm644 ../lib/py/tf4.py ${DESTDIR}${datadir}/tf-lib/tf4.py
++ install -Dm644 ../lib/py/tfutil.py ${DESTDIR}${datadir}/tf-lib/tfutil.py
++ install -Dm644 ../lib/py/urlwatch.py ${DESTDIR}${datadir}/tf-lib/urlwatch.py
+
+ makehelp: makehelp.c
+ $(CC) $(CFLAGS) -o makehelp makehelp.c
+--- tinyfugue-5.1.0/unix/vars.mak.in
++++ tinyfugue-5.1.0.new/unix/vars.mak.in
+@@ -12,11 +12,11 @@
+
+ # @configure_input@
+
+-prefix = ${DESTDIR}@prefix@
+-exec_prefix= ${DESTDIR}@exec_prefix@
+-bindir = ${DESTDIR}@bindir@
+-datadir = ${DESTDIR}@datadir@
+-mandir = ${DESTDIR}@mandir@
++prefix = @prefix@
++exec_prefix= @exec_prefix@
++bindir = @bindir@
++datadir = @datadir@
++mandir = @mandir@
+
+ TFVERSION = @TFVERSION@
+ X = @EXEEXT@
diff --git a/user/tinyfugue/0003-Minor-man-page-fixes.patch b/user/tinyfugue/0003-Minor-man-page-fixes.patch
new file mode 100644
index 000000000..9611744a5
--- /dev/null
+++ b/user/tinyfugue/0003-Minor-man-page-fixes.patch
@@ -0,0 +1,112 @@
+From: Russ Allbery <rra@debian.org>
+Date: Sun, 17 Feb 2008 22:17:59 -0800
+Subject: Minor man page fixes
+
+Escape hyphens properly, add a better man page header, fix the
+placement of punctuation around font changes, and fix a spelling
+error.
+---
+ src/tf.1.nroffman | 34 +++++++++++++++++-----------------
+ 1 file changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/src/tf.1.nroffman b/src/tf.1.nroffman
+index e8daaca..90691db 100644
+--- a/src/tf.1.nroffman
++++ b/src/tf.1.nroffman
+@@ -1,11 +1,11 @@
+ .\" $Id: tf.1.nroffman,v 34000.8 2007/01/13 23:12:39 kkeys Exp $
+-.TH TF 1 LOCAL
++.TH TF 1 "2007-01-13" "TinyFugue 5.0" "TinyFugue"
+ .SH NAME
+ tf \- TinyFugue, a MUD client
+ .SH SYNOPSIS
+-.B "tf [-f\fIfile\fB] [-lnq] [\fIworld\fB]"
++.B "tf [\-f\fIfile\fB] [\-lnq] [\fIworld\fB]"
+ .br
+-.B "tf [-f\fIfile\fB] \fIhost\fB \fIport\fB"
++.B "tf [\-f\fIfile\fB] \fIhost\fB \fIport\fB"
+ .SH DESCRIPTION
+ \fITinyFugue\fR (also known as "Fugue" or "TF") is a line-based client
+ designed for connecting to MUD servers (note: LP, DIKU, and other servers
+@@ -48,15 +48,15 @@ world and try to connect to it.
+ The \fBhost\fR may be an IP number or regular name format.
+ .PP
+ OPTIONS
+-.IP "-f\fIfile\fR"
++.IP "\-f\fIfile\fR"
+ Load \fIfile\fR instead of $HOME/.tfrc at startup.
+-.IP "-f"
++.IP "\-f"
+ Do not load any personal configuration file. The library will still be loaded.
+-.IP "-l"
++.IP "\-l"
+ Disable automatic login.
+-.IP "-n"
++.IP "\-n"
+ Do not connect to any world at startup.
+-.IP "-q"
++.IP "\-q"
+ Quiet login (overrides %{quiet} flag).
+
+ .SH FEATURES
+@@ -109,7 +109,7 @@ Log a session to a file.
+ .sp
+ Separate LP and Diku style prompts from normal output.
+ .sp
+-Page output using a --More-- prompt.
++Page output using a \-\-More\-\- prompt.
+ .sp
+ Recall previously received text.
+
+@@ -120,14 +120,14 @@ configuration file "stdlib.tf", located in TFLIBDIR.
+ TFLIBDIR is defined when \fITF\fR is installed, and is often
+ /usr/local/lib/tf.lib, or under the home directory of the installer.
+ This library contains many macros
+-and definitions essential to the correct operation of \fITF.\fR
++and definitions essential to the correct operation of \fITF\fR.
+
+ Next, \fITF\fR will attempt to read your personal configuration
+ file, $HOME/.tfrc, in which you can put any \fITF\fR commands you
+ want executed automatically at startup. Two of the most useful
+ commands to use in a \fITF\fR configuration file are /addworld and /load.
+
+-For backward compatability, \fITF\fR will also try
++For backward compatibility, \fITF\fR will also try
+ to read the \fITinyTalk\fR configuration file.
+ Its name defautls to $HOME/.tinytalk, or can be defined by the TINYTALK
+ environment variable.
+@@ -140,19 +140,19 @@ the first Tinyclient with any great number of features, including
+ hiliting and suppression of text, simple triggers, and separating input and
+ output on the screen.
+ Leo Plotkin (Grod) made rather extensive modifications to \fITinytalk\fR
+-to produce \fITinywar,\fR which was plagued with some
++to produce \fITinywar\fR, which was plagued with some
+ serious bugs and was never officially released (the phrase "Tinywar
+ doesn't exist" is often quoted), and is now an unsupported client.
+ \fITF\fR began when Greg Hudson (Explorer_Bob) merged many of the new
+-features of \fITinywar\fR back into \fITinyTalk,\fR
++features of \fITinywar\fR back into \fITinyTalk\fR,
+ and added many new features of his own, most notably the split screen.
+ Some of the code in Greg's releases was contributed by Leo Plotkin.
+-After Greg moved on to \fIVaporTalk,\fR Ken Keys (Hawkeye) took over design
++After Greg moved on to \fIVaporTalk\fR, Ken Keys (Hawkeye) took over design
+ and maintenance of \fITF\fR in July 1991, and continues to make improvements
+ in features and performance.
+ .PP
+ The code size of \fITF\fR has surpassed 300K (unstripped),
+-and is signifigantly larger than \fITinytalk.\fR
++and is signifigantly larger than \fITinytalk\fR.
+ It is, in fact, more than three times the size of a number of existing servers.
+ As of version 3.0, it has 66 builtin commands and 57 library commands,
+ each documented in the helpfile.
+@@ -225,8 +225,8 @@ default macro library.
+ .PP
+ The .tinytalk file may not be supported in the future; use .tfrc instead.
+ .PP
+-The '-' command line option in versions prior to 2.0 is no longer supported,
+-and has been replaced with '-l'.
++The '\-' command line option in versions prior to 2.0 is no longer supported,
++and has been replaced with '\-l'.
+
+ .SH BUGS
+ .PP
diff --git a/user/tinyfugue/0006-Fix-library-install-path.patch b/user/tinyfugue/0006-Fix-library-install-path.patch
new file mode 100644
index 000000000..c43b3873e
--- /dev/null
+++ b/user/tinyfugue/0006-Fix-library-install-path.patch
@@ -0,0 +1,38 @@
+From: Russ Allbery <rra@debian.org>
+Date: Sun, 14 Aug 2016 14:14:47 -0700
+Subject: Fix library install path
+
+The upstream top-level configure script doesn't correctly handle
+--program-suffix without this tweak.
+---
+ configure.ac | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e783564..c938531 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -599,13 +599,13 @@ fi
+ dnl The "right" way of using program_transform_name, program_prefix, and
+ dnl program_suffix expects you to use AC_ARG_PROGRAM here and do transformation
+ dnl in the Makefile, but we want the values now, so we do it ourselves.
+-EXENAME="tf"
++EXENAME="tf" PROGNAME="tf"
+ test "${program_prefix}" != "NONE" && EXENAME="${program_prefix}${EXENAME}"
+ test "${program_suffix}" != "NONE" && EXENAME="${EXENAME}${program_suffix}"
+ if test "${program_transform_name}" != "NONE"; then
+ EXENAME=`echo "${EXENAME}" | sed "${program_transform_name}"`
+ fi
+-LIBNAME="${EXENAME}-lib"
++LIBNAME="${PROGNAME}-lib"
+
+ if test "$enable_symlink" = "no"; then
+ SYMLINK=""
+@@ -616,6 +616,7 @@ else
+ fi
+
+ AC_SUBST(EXENAME)
++AC_SUBST(PROGNAME)
+ AC_SUBST(LIBNAME)
+ AC_SUBST(SYMLINK)
+
diff --git a/user/tinyfugue/0007-Fix-spelling-errors.patch b/user/tinyfugue/0007-Fix-spelling-errors.patch
new file mode 100644
index 000000000..8e78721b7
--- /dev/null
+++ b/user/tinyfugue/0007-Fix-spelling-errors.patch
@@ -0,0 +1,59 @@
+From: Russ Allbery <rra@debian.org>
+Date: Sun, 14 Aug 2016 14:22:52 -0700
+Subject: Fix spelling errors
+
+occured -> occurred everywhere
+---
+ CHANGES | 4 ++--
+ src/command.c | 2 +-
+ src/signals.c | 2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CHANGES b/CHANGES
+index 037c766..dfc5029 100644
+--- a/CHANGES
++++ b/CHANGES
+@@ -316,7 +316,7 @@ Renamed BACKGROUND hook to BGTRIG (but old name still works).
+ Added BGTEXT hook.
+ Fixed activity_status.tf to update for lines generated by /echo -w.
+ Fixed: ACTIVITY and PREACTIVITY hooks didn't run in the world in which the
+- activity occured when caused by /echo -w.
++ activity occurred when caused by /echo -w.
+ Fixed order of /dc message relative to text already queued on socket.
+ Fixed: under certain conditions, a dead socket would not go away and could
+ not be foregrounded.
+@@ -972,7 +972,7 @@ Fixed compilation error involving conditional and hstrerror under some
+ lame compilers (socket.c:788).
+ Fixed output misdirection during a read() inside a command sub.
+ Fixed rare bug causing command line to execute in wrong world when a
+- simultaneous background trigger occured.
++ simultaneous background trigger occurred.
+ Fixed /world with no arguments.
+ Fixed fatal input bug after /histsize -i. (35a21)
+ Fixed bug which disabled history recording after /recall on an empty history.
+diff --git a/src/command.c b/src/command.c
+index 0409787..624d03b 100644
+--- a/src/command.c
++++ b/src/command.c
+@@ -605,7 +605,7 @@ int do_file_load(const char *args, int tinytalk)
+ !user_result->u.ival && !warned)
+ {
+ eprintf("(This line was implicitly treated as an /addworld "
+- "because it occured before the first '/' line and did not "
++ "because it occurred before the first '/' line and did not "
+ "start with a '/', ';', or '#'.)");
+ warned = 1;
+ }
+diff --git a/src/signals.c b/src/signals.c
+index bd96b87..a00c70e 100644
+--- a/src/signals.c
++++ b/src/signals.c
+@@ -410,7 +410,7 @@ static char initial_dir[PATH_MAX+1] = "."; /* default: many users never chdir */
+ static void coremsg(FILE *dumpfile)
+ {
+ fputs("Also describe what you were doing in tf when this\r\n", stderr);
+- fputs("occured, and whether you can repeat it.\r\n\n", stderr);
++ fputs("occurred, and whether you can repeat it.\r\n\n", stderr);
+ fprintf(dumpfile, "> %.512s\r\n", version);
+ if (*sysname) fprintf(dumpfile, "> %.256s\r\n", sysname);
+ fprintf(dumpfile, "> %.256s\r\n", featurestr->data);
diff --git a/user/tinyfugue/APKBUILD b/user/tinyfugue/APKBUILD
new file mode 100644
index 000000000..235308518
--- /dev/null
+++ b/user/tinyfugue/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
+pkgname=tinyfugue
+pkgver=5.1.1
+pkgrel=0
+pkgdesc="Powerful curses-based MUD client"
+url="https://github.com/ingwarsw/tinyfugue"
+arch="all"
+options="!check" # no testsuite
+license="GPL-2.0-or-later"
+makedepends="openssl-dev ncurses-dev pcre-dev icu-dev python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ingwarsw/tinyfugue/archive/refs/tags/$pkgver.tar.gz
+ 0001-Add-DESTDIR-support.patch
+ 0003-Minor-man-page-fixes.patch
+ 0006-Fix-library-install-path.patch
+ 0007-Fix-spelling-errors.patch
+ "
+
+build() {
+ CFLAGS="$CFLAGS -fcommon" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-atcp \
+ --enable-gmcp \
+ --enable-option102 \
+ --enable-python
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9eca9f75781847f39699b0c691b80c181e9cfafc4808b743a9579d608ac84b6ea11903f388128cb946b4bfae7e082739df3a37d6b5704cd3f8d2478e66c20c69 tinyfugue-5.1.1.tar.gz
+60c29831079bb866f48121a5502d0d5aa138dac3cfbd4f5dd5aac8d39183c022d032747868d187e26c51986d0a9b7044cd3d0ef26f0e3b4d6dd667a29efedce1 0001-Add-DESTDIR-support.patch
+1e8f05d2744b60cc78f494283bb5f9ef7a804a6811d16028d5486a7394658a03aed04962adfd5bc60fe1517d3831b41f4ca1c3956a624f09a2a4b14f5ab91608 0003-Minor-man-page-fixes.patch
+13cbf27207a1d59afc74a54c9585d05386bf8860cf87eab39873c978bf1525d2abe3a6fcf1da2a8cd7ee17f09644c25ba156e9a69294216c5439175d55e426b6 0006-Fix-library-install-path.patch
+a84aeaf097eb1ec61f9c86f73795ad9f8c111057837b1a0b127905302372e01b6489f9a19f14a29171cef9a787314d511dc98e1140d0c122dd9af5f526eb4bc0 0007-Fix-spelling-errors.patch"