summaryrefslogtreecommitdiff
path: root/user/tinywl
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2024-08-27 22:35:19 -0700
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-29 04:54:51 -0600
commitced196ec8e0ec451bb8cebfeba4ec12c9a64bb8d (patch)
tree15e3664f1f9ae5d4c4d08b58869c0279b6eae2fc /user/tinywl
parent3e025b47d490eb9b794abda326613d83ce246c5a (diff)
downloadpackages-ced196ec8e0ec451bb8cebfeba4ec12c9a64bb8d.tar.gz
packages-ced196ec8e0ec451bb8cebfeba4ec12c9a64bb8d.tar.bz2
packages-ced196ec8e0ec451bb8cebfeba4ec12c9a64bb8d.tar.xz
packages-ced196ec8e0ec451bb8cebfeba4ec12c9a64bb8d.zip
user/tinywl: new package
Diffstat (limited to 'user/tinywl')
-rw-r--r--user/tinywl/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/tinywl/APKBUILD b/user/tinywl/APKBUILD
new file mode 100644
index 000000000..f3ea5459e
--- /dev/null
+++ b/user/tinywl/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=tinywl
+pkgver=0.18.0
+_pkgver=${pkgver%.*}
+pkgrel=0
+pkgdesc="Minimum-viable wlroots-based Wayland compositor"
+url="https://gitlab.freedesktop.org/wlroots/wlroots"
+arch="all"
+options="!check" # no tests
+license="MIT"
+depends="wlroots-$_pkgver"
+makedepends="wayland-protocols wlroots-$_pkgver-dev"
+subpackages=""
+source="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/$pkgver/downloads/wlroots-$pkgver.tar.gz"
+builddir="$srcdir/wlroots-$pkgver/tinywl"
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ install -m755 tinywl "$pkgdir"/usr/bin/tinywl
+}
+
+sha512sums="2cf848aa67f41089b60cc7d01c3a344ebaf7f5bbced459675fef885cd4b3e6b99d9a49d6b127518314d0ae38e52e9aff7991611592b2add4cba96f15aa0bf1c6 wlroots-0.18.0.tar.gz"