summaryrefslogtreecommitdiff
path: root/user/tmux-bash-completion/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:03:32 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:03:32 +0000
commit4b4b48daeae1f96fb05007102312d38cf9d3ea4a (patch)
tree89a0753d5f2db6bfc3d0254f7df0e4cb0b8f2413 /user/tmux-bash-completion/APKBUILD
parent380485eb6689ca23a1462e4f0a38006b7a41757e (diff)
downloadpackages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.tar.gz
packages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.tar.bz2
packages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.tar.xz
packages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.zip
user/*: Modernise / fix syntax / metadata / deps / code
Diffstat (limited to 'user/tmux-bash-completion/APKBUILD')
-rw-r--r--user/tmux-bash-completion/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/user/tmux-bash-completion/APKBUILD b/user/tmux-bash-completion/APKBUILD
index 8ddbcc875..fe35c7d11 100644
--- a/user/tmux-bash-completion/APKBUILD
+++ b/user/tmux-bash-completion/APKBUILD
@@ -7,17 +7,18 @@ pkgrel=0
pkgdesc="bash-completion files for tmux"
url="https://github.com/imomaliev/tmux-bash-completion"
arch="noarch"
-options="!check" # no tests
+options="!check" # No test suite.
license="GPL-2.0-only"
depends="bash-completion tmux"
makedepends=""
subpackages=""
+install_if="tmux bash-completion"
source="$pkgname-$pkgver.tar.gz::https://github.com/imomaliev/tmux-bash-completion/archive/$_commit.tar.gz"
builddir="$srcdir/$pkgname-$_commit"
package() {
- cd "$builddir"
- install -Dm644 ./completions/tmux "$pkgdir"/usr/share/bash-completion/completions/tmux
+ install -Dm644 "$builddir"/completions/tmux \
+ "$pkgdir"/usr/share/bash-completion/completions/tmux
}
sha512sums="6c4c761aa152d1352a575c91e2c375d3f19ad01263b603b9e0cde4bdd95ce478c93bb55bfcd9fa5332cde12399e1e1e1c062e6be2ed7403b96e808275401effa tmux-bash-completion-1.0.0_git20170805.tar.gz"