summaryrefslogtreecommitdiff
path: root/user/tmux
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-19 19:12:14 -0500
committerMax Rees <maxcrees@me.com>2019-08-19 19:12:14 -0500
commit12dc56030ed99e73bc19efcb627ea4fa1f475ddb (patch)
tree9f01b2a6c52b2b91fb3826b2569baa1a03c85490 /user/tmux
parenta4e9e939954682c18b16d3ddcf9e79bdbc073e64 (diff)
downloadpackages-12dc56030ed99e73bc19efcb627ea4fa1f475ddb.tar.gz
packages-12dc56030ed99e73bc19efcb627ea4fa1f475ddb.tar.bz2
packages-12dc56030ed99e73bc19efcb627ea4fa1f475ddb.tar.xz
packages-12dc56030ed99e73bc19efcb627ea4fa1f475ddb.zip
Actually, fix tmux instead of xterm
Diffstat (limited to 'user/tmux')
-rw-r--r--user/tmux/APKBUILD8
-rw-r--r--user/tmux/xterm-DECLRMM.patch23
2 files changed, 28 insertions, 3 deletions
diff --git a/user/tmux/APKBUILD b/user/tmux/APKBUILD
index 1748375c1..ebd0a38c0 100644
--- a/user/tmux/APKBUILD
+++ b/user/tmux/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=tmux
pkgver=2.7
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://tmux.github.io/"
arch="all"
@@ -10,7 +10,8 @@ license="MIT"
depends="ncurses-terminfo"
makedepends="bsd-compat-headers libevent-dev libutempter-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
+ xterm-DECLRMM.patch"
build() {
./configure \
@@ -37,4 +38,5 @@ package() {
done
}
-sha512sums="7839ef748ea55df8c02c727047f65bd235b5e3b8ab23157246071e1b9954fa269594da9fbd0fabf6a850e3b5dfda962a0a067c1507411c92a84d1db2666ecf37 tmux-2.7.tar.gz"
+sha512sums="7839ef748ea55df8c02c727047f65bd235b5e3b8ab23157246071e1b9954fa269594da9fbd0fabf6a850e3b5dfda962a0a067c1507411c92a84d1db2666ecf37 tmux-2.7.tar.gz
+7fb006f8f24d60614fcaeadace933c2ad6674d2476980736a830f63a40d7110638942478322336849d47707c99ab7de0cb01ff39806a4c9144650daf2f666773 xterm-DECLRMM.patch"
diff --git a/user/tmux/xterm-DECLRMM.patch b/user/tmux/xterm-DECLRMM.patch
new file mode 100644
index 000000000..b9bef3455
--- /dev/null
+++ b/user/tmux/xterm-DECLRMM.patch
@@ -0,0 +1,23 @@
+From 26f274011096b9eacfd2753d8f7afcb63e796ab9 Mon Sep 17 00:00:00 2001
+From: nicm <nicm>
+Date: Thu, 1 Aug 2019 11:45:34 +0000
+Subject: [PATCH] xterm 348 now disables margins when resized, so send DECLRMM
+ again.
+
+---
+ tty.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tty.c b/tty.c
+index ab1da9fd3..024aef271 100644
+--- a/tty.c
++++ b/tty.c
+@@ -1879,6 +1879,8 @@ tty_invalidate(struct tty *tty)
+ tty->rlower = tty->rright = UINT_MAX;
+
+ if (tty->flags & TTY_STARTED) {
++ if (tty_use_margin(tty))
++ tty_puts(tty, "\033[?69h"); /* DECLRMM */
+ tty_putcode(tty, TTYC_SGR0);
+
+ tty->mode = ALL_MODES;