summaryrefslogtreecommitdiff
path: root/user/ttf-carlito
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-08-13 04:58:51 -0400
committerMax Rees <maxcrees@me.com>2018-08-13 04:58:51 -0400
commit92197441722ae423a6acc72e50f318536fe2aef4 (patch)
treeedbeba08ad82f842a2318b6903960051c9084924 /user/ttf-carlito
parent4709c5bb3e7e297871d7f725001367aa3205096f (diff)
downloadpackages-92197441722ae423a6acc72e50f318536fe2aef4.tar.gz
packages-92197441722ae423a6acc72e50f318536fe2aef4.tar.bz2
packages-92197441722ae423a6acc72e50f318536fe2aef4.tar.xz
packages-92197441722ae423a6acc72e50f318536fe2aef4.zip
user/ttf-carlito: new package
Diffstat (limited to 'user/ttf-carlito')
-rw-r--r--user/ttf-carlito/45-carlito.conf12
-rw-r--r--user/ttf-carlito/90-tt-carlito.conf56
-rw-r--r--user/ttf-carlito/APKBUILD37
3 files changed, 105 insertions, 0 deletions
diff --git a/user/ttf-carlito/45-carlito.conf b/user/ttf-carlito/45-carlito.conf
new file mode 100644
index 000000000..dde534f5e
--- /dev/null
+++ b/user/ttf-carlito/45-carlito.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Carlito</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/user/ttf-carlito/90-tt-carlito.conf b/user/ttf-carlito/90-tt-carlito.conf
new file mode 100644
index 000000000..87847acab
--- /dev/null
+++ b/user/ttf-carlito/90-tt-carlito.conf
@@ -0,0 +1,56 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Carlito</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintfull</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Carlito</string>
+ </test>
+ <test name="weight" compare="less">
+ <const>medium</const>
+ </test>
+ <test name="pixelsize" compare="more">
+ <double>21.5</double>
+ </test>
+ <test name="pixelsize" compare="less">
+ <double>22.5</double>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/user/ttf-carlito/APKBUILD b/user/ttf-carlito/APKBUILD
new file mode 100644
index 000000000..f78242041
--- /dev/null
+++ b/user/ttf-carlito/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=ttf-carlito
+pkgver=20130920
+pkgrel=0
+pkgdesc="Google's metric-compatible replacement for Microsoft Calibri"
+url="https://chromium.googlesource.com/chromiumos/overlays/chromiumos-overlay/+/master/media-fonts/crosextrafonts-carlito"
+arch="noarch"
+options="!check" # You can't test fonts. -.-
+license="OFL-1.1 AND MIT"
+depends="fontconfig encodings mkfontdir mkfontscale"
+makedepends="font-util-dev"
+subpackages=""
+# added fontconfig configuration (MIT) from:
+# https://github.com/bohoomil/fontconfig-ultimate/tree/master/fontconfig_patches/fonts-settings
+source="http://commondatastorage.googleapis.com/chromeos-localmirror/distfiles/crosextrafonts-${pkgname#ttf-}-$pkgver.tar.gz
+ 45-carlito.conf
+ 90-tt-carlito.conf"
+builddir="$srcdir/crosextrafonts-${pkgname#ttf-}-$pkgver"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname \
+ "$pkgdir"/etc/fonts/conf.avail \
+ "$pkgdir"/etc/fonts/conf.d
+
+ install -m644 "$builddir"/*.ttf "$pkgdir"/usr/share/fonts/$pkgname
+
+ cd "$pkgdir"/etc/fonts/conf.d
+ for j in "$srcdir"/*.conf; do
+ install -m644 "$j" "$pkgdir"/etc/fonts/conf.avail/
+ ln -sf /etc/fonts/conf.avail/${j##*/}
+ done
+}
+
+sha512sums="eb516060487d30353e06de711921c0d54c5844f2be69b1c1d37edac4b27303e9213a6bb306f309dc5827b2a6a2a37c9cb85b62368164eba6dd397dbaab3e3ba0 crosextrafonts-carlito-20130920.tar.gz
+1eb50a4f3bf1aa6c229059ef25a1344824ac3be179fa819f6613d1457758b4d79ae63e1872a4b54a32bc413d84f7a362c1f9fd9c8cd1265bfcf7abfc3f1b9c27 45-carlito.conf
+b859c5996a4942674979d4353e63ca59a383829e97713512a59910869841dbc923708880af74d9fdebb50ce482e21a2a8c8b1716973a676ee76f6248b3d1521d 90-tt-carlito.conf"