summaryrefslogtreecommitdiff
path: root/user/ttf-noto-cjk
diff options
context:
space:
mode:
authorMax Rees <maxcrees at me.com>2018-08-03 03:19:49 -0400
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-03 09:34:35 +0000
commitd1b0a417e37f464f583aa3081c3cfd0b6fa8cabb (patch)
treeacef6ee0243622551d9f897390bb80ddf31d63cc /user/ttf-noto-cjk
parent51bd041143eb3d3c55f6196832b3f1fcf6a3f667 (diff)
downloadpackages-d1b0a417e37f464f583aa3081c3cfd0b6fa8cabb.tar.gz
packages-d1b0a417e37f464f583aa3081c3cfd0b6fa8cabb.tar.bz2
packages-d1b0a417e37f464f583aa3081c3cfd0b6fa8cabb.tar.xz
packages-d1b0a417e37f464f583aa3081c3cfd0b6fa8cabb.zip
user/ttf-noto-cjk: new package
Diffstat (limited to 'user/ttf-noto-cjk')
-rw-r--r--user/ttf-noto-cjk/90-ttf-noto-cjk.conf263
-rw-r--r--user/ttf-noto-cjk/APKBUILD40
2 files changed, 303 insertions, 0 deletions
diff --git a/user/ttf-noto-cjk/90-ttf-noto-cjk.conf b/user/ttf-noto-cjk/90-ttf-noto-cjk.conf
new file mode 100644
index 000000000..65c4f3bcb
--- /dev/null
+++ b/user/ttf-noto-cjk/90-ttf-noto-cjk.conf
@@ -0,0 +1,263 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <!-- Sans -->
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans CJK SC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans CJK TC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans CJK JP</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans CJK KR</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <!-- Sans Mono -->
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans Mono CJK SC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans Mono CJK TC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans Mono CJK JP</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Sans Mono CJK KR</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <!-- Serif -->
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Serif CJK SC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Serif CJK TC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Serif CJK JP</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font" >
+ <test name="family" >
+ <string>Noto Serif CJK KR</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="globaladvance">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/user/ttf-noto-cjk/APKBUILD b/user/ttf-noto-cjk/APKBUILD
new file mode 100644
index 000000000..cf8b77938
--- /dev/null
+++ b/user/ttf-noto-cjk/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=ttf-noto-cjk
+pkgver=20170601
+pkgrel=0
+pkgdesc="Noto fonts for Chinese, Japanese, and Korean"
+url="https://www.google.com/get/noto/help/cjk/"
+arch="noarch"
+options="!check" # how do you test a font?
+license="OFL-1.1"
+depends="fontconfig"
+makedepends=""
+# * The archive is taken from https://github.com/googlei18n/noto-cjk/releases
+# with only the Noto*CJK-*.ttc files kept. These are the so-called
+# "OpenType/CFF Collection (OTC)" files, which combine the Traditional
+# Chinese, Simplified Chinese, Japanese, and Korean glyphs into single files.
+# There are 7 weight variants of NotoSansCJK (which includes Noto Sans CJK
+# and Noto Sans Mono CJK), and 7 weight variants of NotoSerifCJK, for a total
+# of 14 files.
+# * Adapted fontconfig configuration from:
+# https://github.com/bohoomil/fontconfig-ultimate/tree/master/fontconfig_patches/fonts-settings
+source="https://dev.sick.bike/$pkgname-$pkgver.tar.xz
+ 90-ttf-noto-cjk.conf
+ "
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/truetype/"$pkgname" \
+ "$pkgdir"/etc/fonts/conf.d \
+ "$pkgdir"/etc/fonts/conf.avail
+
+ cp "$builddir"/*.ttc "$pkgdir"/usr/share/fonts/truetype/"$pkgname"
+
+ cp "$srcdir"/90-ttf-noto-cjk.conf "$pkgdir"/etc/fonts/conf.avail
+ cd "$pkgdir"/etc/fonts/conf.d
+ ln -sf /etc/fonts/conf.avail/90-ttf-noto-cjk.conf
+}
+
+sha512sums="5ac6740ef2cc4a4f1f59304c617b2268e220f3d7d72430184506cb1ccd86cebea4c4f5366a7285ebd2993e6a59557a0396badaeb6239f51f15db1c5d28b5ae03 ttf-noto-cjk-20170601.tar.xz
+ea74f9b289b85926b973d15124fe863e0a537bb7ef5cf523f7e960b03bfbd53c86be01ac8062a4d71f77d943ae4695a91a8168c8351b5738081663639ff4982c 90-ttf-noto-cjk.conf"