summaryrefslogtreecommitdiff
path: root/user/userspace-rcu/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-01 07:09:04 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-01 07:09:04 -0600
commiteb48795fd3e33bf496c1466e2e3ed8135dcce29f (patch)
tree848f07c418f3d335fda22b624edc52c96fd68f8e /user/userspace-rcu/APKBUILD
parent65490a3788757ebca8d8c259a2c4a29c875ad765 (diff)
downloadpackages-eb48795fd3e33bf496c1466e2e3ed8135dcce29f.tar.gz
packages-eb48795fd3e33bf496c1466e2e3ed8135dcce29f.tar.bz2
packages-eb48795fd3e33bf496c1466e2e3ed8135dcce29f.tar.xz
packages-eb48795fd3e33bf496c1466e2e3ed8135dcce29f.zip
system/xfsprogs + rdeps: Move to user/
* inih requires Meson, and we don't want to introduce Meson to the system/ ABI, so we need to move it to user/. * This takes xfsprogs with it. This is fine because we still have system/e2fsprogs for a file system on new ports. * As the only dependent of userspace-rcu was xfsprogs, it doesn't need to be present in system/ any more either. Move to user/.
Diffstat (limited to 'user/userspace-rcu/APKBUILD')
-rw-r--r--user/userspace-rcu/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/userspace-rcu/APKBUILD b/user/userspace-rcu/APKBUILD
new file mode 100644
index 000000000..e36f0f6bf
--- /dev/null
+++ b/user/userspace-rcu/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=userspace-rcu
+pkgver=0.14.0
+pkgrel=0
+pkgdesc="Userspace RCU (read-copy-update) library"
+url="https://liburcu.org"
+arch="all"
+license="LGPL-2.1-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://lttng.org/files/urcu/userspace-rcu-$pkgver.tar.bz2
+ endian.patch
+ "
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7297e51012f4c44ee27c0e18ed9d87bf24be34db68a5398394c1e683a045bb561cf74aa913398404c0ed5cb8011af728ea12947717fa5f27627e5ca78e63a40f userspace-rcu-0.14.0.tar.bz2
+07935ed9741554b2cbc343fdd6218172deca4d4167b31b92f2be82623c5d83191472da2b4bee5adcd59e3d4bec3751d3e793cc720b822b6060dc588b8ee58f16 endian.patch"