summaryrefslogtreecommitdiff
path: root/user/volume_key
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 09:11:34 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 09:11:34 -0600
commitae20f2dfbda852fbbba2bd6754071788b1915c12 (patch)
tree929e540ca3bee688bd1e5542349ada3ed669a6f1 /user/volume_key
parentbd8c0686a23dae515c665c5519ee3f86044157df (diff)
downloadpackages-ae20f2dfbda852fbbba2bd6754071788b1915c12.tar.gz
packages-ae20f2dfbda852fbbba2bd6754071788b1915c12.tar.bz2
packages-ae20f2dfbda852fbbba2bd6754071788b1915c12.tar.xz
packages-ae20f2dfbda852fbbba2bd6754071788b1915c12.zip
user/{dmraid,volume_key}: Modernise and fix syntax
Diffstat (limited to 'user/volume_key')
-rw-r--r--user/volume_key/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/volume_key/APKBUILD b/user/volume_key/APKBUILD
index db26d40e2..54fa07ad4 100644
--- a/user/volume_key/APKBUILD
+++ b/user/volume_key/APKBUILD
@@ -9,14 +9,13 @@ arch="all"
options="!check" # well, this is busted.
license="GPL-2.0+"
depends=""
+checkdepends="nss-tools"
makedepends="cryptsetup-dev glib-dev gpgme-dev nss-dev python3-dev
util-linux-dev"
-checkdepends="nss-tools"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py-$pkgname:py"
source="https://releases.pagure.org/volume_key/volume_key-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +27,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}