summaryrefslogtreecommitdiff
path: root/user/vte
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-03-22 17:39:30 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-03-22 17:39:30 -0500
commitc0957e6015cb8ee5b225f5ca2582b570ebd3b8f2 (patch)
tree318a90c02c82ee134f8359e2f33d50b772639e40 /user/vte
parent98ea5397796aca461f81318aa383d2933abf0b23 (diff)
downloadpackages-c0957e6015cb8ee5b225f5ca2582b570ebd3b8f2.tar.gz
packages-c0957e6015cb8ee5b225f5ca2582b570ebd3b8f2.tar.bz2
packages-c0957e6015cb8ee5b225f5ca2582b570ebd3b8f2.tar.xz
packages-c0957e6015cb8ee5b225f5ca2582b570ebd3b8f2.zip
user/vte: upgrade to 0.56.0
Diffstat (limited to 'user/vte')
-rw-r--r--user/vte/APKBUILD12
-rw-r--r--user/vte/vala.patch29
2 files changed, 5 insertions, 36 deletions
diff --git a/user/vte/APKBUILD b/user/vte/APKBUILD
index 0808c026e..b952f4959 100644
--- a/user/vte/APKBUILD
+++ b/user/vte/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vte
-pkgver=0.54.3
-pkgrel=1
+pkgver=0.56.0
+pkgrel=0
pkgdesc="Virtual terminal emulator library for Gnome"
url="https://www.gnome.org"
arch="all"
@@ -10,9 +10,8 @@ license="LGPL-2.1+ AND GPL-3.0+ AND LGPL-3.0+ AND MIT AND LGPL-2.0+"
makedepends="intltool gtk+3.0-dev gnutls-dev zlib-dev pcre2-dev
gobject-introspection-dev vala vala-dev libxml2-utils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/vte/0.54/vte-$pkgver.tar.xz
+source="https://download.gnome.org/sources/vte/${pkgver%.*}/vte-$pkgver.tar.xz
exitcode.patch
- vala.patch
"
build() {
@@ -34,6 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="dd7d2ac361ed9ac0550599bb3164a3bd6ba95535275c9b559c81ce0af1bbf4b3d150a7489f987b2e626b32d4a8adc82d1ff78e8c8640e5b1c036fe4076c5d8ce vte-0.54.3.tar.xz
-4987254439a136f66a7b7be1300f5efbf85db74bdb64fdd8d0c9a555173a172b4fd519174f932e73d58a2618ef37273e82fe681bb129891f2792a414025f6c61 exitcode.patch
-6f699507326dcef82ab2eb1b94eb0a21255e90053d27db24c38e0dd1ec389ed7710b8032b4c12374448b59ff5b73852bbdd5ce0f5e5cdd4c84be290c7203aafc vala.patch"
+sha512sums="f366ed4a28a896ba919184b50a55ee110eae43127847f34c049684bcb9b81327d1b72e9d871b2a5b7f7fa12f3f4aa721ac3d770770b600dca9c433cb2c674915 vte-0.56.0.tar.xz
+4987254439a136f66a7b7be1300f5efbf85db74bdb64fdd8d0c9a555173a172b4fd519174f932e73d58a2618ef37273e82fe681bb129891f2792a414025f6c61 exitcode.patch"
diff --git a/user/vte/vala.patch b/user/vte/vala.patch
deleted file mode 100644
index fe07dbbf0..000000000
--- a/user/vte/vala.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 53690d5cee51bdb7c3f7680d3c22b316b1086f2c Mon Sep 17 00:00:00 2001
-From: Rico Tzschichholz <ricotz@ubuntu.com>
-Date: Sat, 1 Dec 2018 19:04:59 +0100
-Subject: [PATCH] vala: Fix build with vala 0.43+ git master due to empty
- struct definition
-
-This should get a proper refactoring as the FIXME suggests.
-
-See https://gitlab.gnome.org/GNOME/vte/issues/76
----
- bindings/vala/app.vala | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/bindings/vala/app.vala b/bindings/vala/app.vala
-index 8663d63c..a534e76b 100644
---- a/bindings/vala/app.vala
-+++ b/bindings/vala/app.vala
-@@ -819,6 +819,8 @@ class App : Gtk.Application
-
- public struct Options
- {
-+ //FIXME Merge this struct into App class
-+ public int dummy;
- public static bool audible = false;
- public static string? command = null;
- private static string? cjk_ambiguous_width_string = null;
---
-2.18.1
-