summaryrefslogtreecommitdiff
path: root/user/wayland-protocols/tests.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-08 11:44:14 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-29 04:55:31 -0600
commitf50882b80cd5fa85b1c86faa2536d332e7ffb274 (patch)
treedb52460bebea950d42a9a1872fe4c3344ca8d37b /user/wayland-protocols/tests.patch
parente1cf084581af5e73b007221d241ecf2085340f88 (diff)
downloadpackages-f50882b80cd5fa85b1c86faa2536d332e7ffb274.tar.gz
packages-f50882b80cd5fa85b1c86faa2536d332e7ffb274.tar.bz2
packages-f50882b80cd5fa85b1c86faa2536d332e7ffb274.tar.xz
packages-f50882b80cd5fa85b1c86faa2536d332e7ffb274.zip
user/wayland-protocols: Update to 1.38
Also updates the test patch to be applicable to all tests. This patch has been submitted upstream and the upstream URL is included.
Diffstat (limited to 'user/wayland-protocols/tests.patch')
-rw-r--r--user/wayland-protocols/tests.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/user/wayland-protocols/tests.patch b/user/wayland-protocols/tests.patch
new file mode 100644
index 000000000..d8d5dc3ca
--- /dev/null
+++ b/user/wayland-protocols/tests.patch
@@ -0,0 +1,53 @@
+Upstream-URL: https://gitlab.freedesktop.org/wayland/wayland-protocols/-/merge_requests/363
+
+From 8b4c76275fa1b6e0a99a53494151d9a2c907144d Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Fri, 8 Nov 2024 11:27:25 -0600
+Subject: [PATCH] tests: Make build-only tests actually build-only
+
+The goal behind the pedantic compiler tests are to ensure that the code
+that wayland-scanner is generating can be compiled in pedantic mode by
+the system C compiler.
+
+Trying to execute the built tests may fail because of undefined symbols.
+This affects certain platforms more than others; Linux/musl and Darwin
+are examples of platforms that cannot execute binaries with undefined
+symbols. This meant tests needlessly failed on these platforms.
+
+Signed-off-by: A. Wilcox <AWilcox@Wilcox-Tech.com>
+Closes: #48, #228
+---
+ tests/meson.build | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index aa216ec..5a93bb3 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -1,4 +1,5 @@
+ prog_scan_sh = find_program('scan.sh')
++prog_true = find_program('true')
+
+ libwayland = [
+ dependency('wayland-client'),
+@@ -100,7 +101,7 @@ foreach protocol_file : protocol_files
+ test_source,
+ client_header,
+ server_header,
+- code
++ code,
+ ],
+ link_args: extra_linker_flags,
+ dependencies: libwayland,
+@@ -111,7 +112,7 @@ foreach protocol_file : protocol_files
+ '-Werror' ],
+ install: false,
+ )
+- test(test_name, pedantic_test_executable)
++ test(test_name, prog_true, depends : [pedantic_test_executable])
+
+ # Check that the header
+ if not protocol_file.contains('xdg-foreign-unstable-v1')
+--
+2.40.0
+