summaryrefslogtreecommitdiff
path: root/user/weechat
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-05 03:58:15 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-05 03:58:15 +0000
commit0d03f58c5dd381d64a1d8c5c0d56a540c6e860bd (patch)
tree8a388945212d590bcf5a71e28052e1c37cb941b0 /user/weechat
parent28ba57010b089eb7e884185a35d60f7852df8d0b (diff)
downloadpackages-0d03f58c5dd381d64a1d8c5c0d56a540c6e860bd.tar.gz
packages-0d03f58c5dd381d64a1d8c5c0d56a540c6e860bd.tar.bz2
packages-0d03f58c5dd381d64a1d8c5c0d56a540c6e860bd.tar.xz
packages-0d03f58c5dd381d64a1d8c5c0d56a540c6e860bd.zip
user/weechat: bump to 2.6
Diffstat (limited to 'user/weechat')
-rw-r--r--user/weechat/APKBUILD33
-rw-r--r--user/weechat/python.patch86
2 files changed, 11 insertions, 108 deletions
diff --git a/user/weechat/APKBUILD b/user/weechat/APKBUILD
index e5f49da9d..d18e9cf69 100644
--- a/user/weechat/APKBUILD
+++ b/user/weechat/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=weechat
-pkgver=2.5
-pkgrel=1
+pkgver=2.6
+pkgrel=0
pkgdesc="Fast, light, extensible ncurses-based chat client"
url="https://www.weechat.org"
arch="all"
@@ -17,7 +17,6 @@ subpackages="$pkgname-dev $pkgname-spell:_plugin $pkgname-lua:_plugin
$pkgname-perl:_plugin $pkgname-python:_plugin $pkgname-lang"
source="https://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
libintl-fix.patch
- python.patch
"
# secfixes:
@@ -26,22 +25,18 @@ source="https://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
# 1.9.1-r0:
# - CVE-2017-14727
-prepare() {
- cd "$builddir"
- default_prepare
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_MAN=ON -DENABLE_TESTS=ON -DENABLE_PYTHON3=ON -Bbuild .
+ make -C build
}
-build() {
- cd "$builddir"
- mkdir -p build
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_MAN=ON -DENABLE_TESTS=ON -DENABLE_PYTHON3=ON
- make
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" -C build install
}
_plugin() {
@@ -57,11 +52,5 @@ _plugin() {
mv "$pkgdir"/$_dir/${_name}.so "$subpkgdir"/$_dir
}
-check() {
- cd "$builddir"/build
- ctest -V
-}
-
-sha512sums="1bf16c76e63668fc6d4b72d521f71980717b08bd2abc5c7f0825af32e6de9327c5c967067bfb025a0404eee627f54cecdd9f1f2b3618ea7a08798d8510a2487b weechat-2.5.tar.gz
-59841bc343b1d10a542631eb01380789f96cac896380dbb3b159444c4806bd6367952e457b9ffd42fb87c1e19fc77eba78c38fd2178ef202ab9f7f1a543417ca libintl-fix.patch
-b77bd5f31bf4547d1d5505fec5018b867f0b597ed0b6819d4ed0ff6a2b7f664f2308f6c1b094debc381673b4de6208f09ca36da3413eb72f40aca9924464d746 python.patch"
+sha512sums="47698f9b275c4fad68cc786cf0739e6f7355428abf57b94e64df84725b001546783f4e6389d0ed51ff5108c50c48dba344c22da9f43bc6f6f90acedacc3e84a5 weechat-2.6.tar.gz
+59841bc343b1d10a542631eb01380789f96cac896380dbb3b159444c4806bd6367952e457b9ffd42fb87c1e19fc77eba78c38fd2178ef202ab9f7f1a543417ca libintl-fix.patch"
diff --git a/user/weechat/python.patch b/user/weechat/python.patch
deleted file mode 100644
index a6e194719..000000000
--- a/user/weechat/python.patch
+++ /dev/null
@@ -1,86 +0,0 @@
---- weechat-2.5/cmake/FindPython.cmake 2019-06-06 18:43:20.000000000 +0000
-+++ weechat-2.5/cmake/FindPython.cmake 2019-06-24 12:22:10.659972390 +0000
-@@ -25,7 +25,6 @@
- #
- # PYTHON_EXECUTABLE = full path to the python binary
- # PYTHON_INCLUDE_PATH = path to where python.h can be found
--# PYTHON_LIBRARY = path to where libpython.so* can be found
- # PYTHON_LFLAGS = python compiler options for linking
-
- if(PYTHON_FOUND)
-@@ -38,11 +37,19 @@
- NAMES python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python3 python2.7 python2.6 python2.5 python
- PATHS /usr/bin /usr/local/bin /usr/pkg/bin
- )
-+ find_program(PYTHON_CONFIG
-+ NAMES python3-config
-+ PATHS /usr/bin /usr/local/bin /usr/pkg/bin
-+ )
- else()
- find_program(PYTHON_EXECUTABLE
- NAMES python2.7 python2.6 python2.5 python
- PATHS /usr/bin /usr/local/bin /usr/pkg/bin
- )
-+ find_program(PYTHON_CONFIG
-+ NAMES python-config
-+ PATHS /usr/bin /usr/local/bin /usr/pkg/bin
-+ )
- endif()
-
- if(PYTHON_EXECUTABLE)
-@@ -52,32 +59,17 @@
- )
-
- execute_process(
-- COMMAND ${PYTHON_EXECUTABLE} -c "import sys; from distutils.sysconfig import *; sys.stdout.write(get_config_var('LIBPL'))"
-- OUTPUT_VARIABLE PYTHON_POSSIBLE_LIB_PATH
-- )
--
-- execute_process(
-- COMMAND ${PYTHON_EXECUTABLE} -c "import sys; from distutils.sysconfig import *; sys.stdout.write(get_config_var('LIBS') + ' ' + get_config_var('LINKFORSHARED'))"
-+ COMMAND ${PYTHON_CONFIG} --libs
- OUTPUT_VARIABLE PYTHON_LFLAGS
-+ OUTPUT_STRIP_TRAILING_WHITESPACE
- )
-
- find_path(PYTHON_INCLUDE_PATH
- NAMES Python.h
- HINTS ${PYTHON_INC_DIR}
- )
-- if(ENABLE_PYTHON3)
-- find_library(PYTHON_LIBRARY
-- NAMES python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python3 python2.7 python2.6 python2.5 python
-- HINTS ${PYTHON_POSSIBLE_LIB_PATH}
-- )
-- else()
-- find_library(PYTHON_LIBRARY
-- NAMES python2.7 python2.6 python2.5 python
-- HINTS ${PYTHON_POSSIBLE_LIB_PATH}
-- )
-- endif()
-
-- if(PYTHON_LIBRARY AND PYTHON_INCLUDE_PATH)
-+ if(PYTHON_LFLAGS AND PYTHON_INCLUDE_PATH)
- execute_process(
- COMMAND ${PYTHON_EXECUTABLE} -c "import sys; sys.stdout.write(sys.version[:3])"
- OUTPUT_VARIABLE PYTHON_VERSION
-@@ -96,7 +88,6 @@
- mark_as_advanced(
- PYTHON_EXECUTABLE
- PYTHON_INCLUDE_PATH
-- PYTHON_LIBRARY
- PYTHON_LFLAGS
- )
-
---- weechat-2.5/src/plugins/python/CMakeLists.txt 2019-06-06 18:43:20.000000000 +0000
-+++ weechat-2.5/src/plugins/python/CMakeLists.txt 2019-06-24 12:22:16.259972363 +0000
-@@ -24,8 +24,7 @@
-
- if(PYTHON_FOUND)
- include_directories(${PYTHON_INCLUDE_PATH})
-- set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} ${PYTHON_LFLAGS}")
-- target_link_libraries(python ${PYTHON_LIBRARY} weechat_plugins_scripts coverage_config)
-+ target_link_libraries(python ${PYTHON_LFLAGS} weechat_plugins_scripts coverage_config)
- endif()
-
- install(TARGETS python LIBRARY DESTINATION ${WEECHAT_LIBDIR}/plugins)