summaryrefslogtreecommitdiff
path: root/user/wpa_supplicant/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-09-15 17:50:49 -0400
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-16 16:34:42 +0000
commitde8797f10419669525608fe59f181908e94696f5 (patch)
treedc72d7fd490145f95d1756fdcf30ab9e62f1e959 /user/wpa_supplicant/APKBUILD
parent8642108eae6cbb08930c10a883407a7ec2b2be1f (diff)
downloadpackages-de8797f10419669525608fe59f181908e94696f5.tar.gz
packages-de8797f10419669525608fe59f181908e94696f5.tar.bz2
packages-de8797f10419669525608fe59f181908e94696f5.tar.xz
packages-de8797f10419669525608fe59f181908e94696f5.zip
user/wpa_supplicant: add wpa_gui subpackage
Diffstat (limited to 'user/wpa_supplicant/APKBUILD')
-rw-r--r--user/wpa_supplicant/APKBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/user/wpa_supplicant/APKBUILD b/user/wpa_supplicant/APKBUILD
index 095e0320c..0b070dee7 100644
--- a/user/wpa_supplicant/APKBUILD
+++ b/user/wpa_supplicant/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=wpa_supplicant
pkgver=2.6
-pkgrel=8
+pkgrel=9
pkgdesc="Utility providing key negotiation for WPA wireless networks"
url="https://w1.fi/wpa_supplicant/"
arch="all"
license="BSD-3-Clause AND Public-Domain AND (GPL-2.0+ OR BSD-3-Clause)"
-subpackages="$pkgname-doc $pkgname-openrc"
+subpackages="$pkgname-doc $pkgname-openrc wpa_gui"
depends="dbus"
-makedepends="linux-headers openssl-dev dbus-dev libnl3-dev pcsc-lite-dev"
+makedepends="linux-headers openssl-dev dbus-dev libnl3-dev pcsc-lite-dev
+ qt5-qtbase-dev"
source="http://w1.fi/releases/$pkgname-$pkgver.tar.gz
rebased-v2.6-0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch
rebased-v2.6-0002-Prevent-reinstallation-of-an-already-in-use-group-ke.patch
@@ -50,6 +51,10 @@ prepare() {
build() {
cd "$builddir"/wpa_supplicant
make LIBDIR=/lib BINDIR=/sbin
+
+ # wpa_gui
+ qmake -o wpa_gui-qt4/Makefile wpa_gui-qt4/wpa_gui.pro
+ make -C wpa_gui-qt4
}
check() {
@@ -87,6 +92,14 @@ package() {
"$pkgdir"/etc/conf.d/wpa_supplicant
}
+wpa_gui() {
+ pkgdesc="Graphical User Interface for wpa_supplicant"
+ depends="$pkgname"
+
+ cd "$builddir"/wpa_supplicant
+ install -Dm755 wpa_gui-qt4/wpa_gui "$subpkgdir"/usr/bin/wpa_gui
+}
+
sha512sums="46442cddb6ca043b8b08d143908f149954c238e0f3a57a0df73ca4fab9c1acd91b078f3f26375a1d99cd1d65625986328018c735d8705882c8f91e389cad28a6 wpa_supplicant-2.6.tar.gz
f855fa792425f175ccc800eb49df42067b1c1f4b52ba2d24160af4dfbb74dcf8e81661b7e6c8d92fa408938b8a559fc74557d1677913e4a751bfd43706c14bb6 rebased-v2.6-0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch
b4e413aa815572ea0002d33d24b69cd499aebb5efebed8fcaade8b29324bb5853a5db64e8b1dfdf24478e02c66196238b81a6ec777a7a28610435dce4d2c344e rebased-v2.6-0002-Prevent-reinstallation-of-an-already-in-use-group-ke.patch