summaryrefslogtreecommitdiff
path: root/user/wpa_supplicant
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2019-02-20 14:55:02 +0100
committerLuis Ressel <aranea@aixah.de>2019-02-20 15:05:13 +0100
commit06813dcc10647f7c35914559a4271d4f2d27a55d (patch)
tree18e697ba8c7daf83f9b35287058fcd9ee1f5220f /user/wpa_supplicant
parente3c44943864fc5f7bf287f3c749b35d504be9267 (diff)
downloadpackages-06813dcc10647f7c35914559a4271d4f2d27a55d.tar.gz
packages-06813dcc10647f7c35914559a4271d4f2d27a55d.tar.bz2
packages-06813dcc10647f7c35914559a4271d4f2d27a55d.tar.xz
packages-06813dcc10647f7c35914559a4271d4f2d27a55d.zip
user/wpa_supplicant: It makes no sense to make eapol_test in check()
It's just a binary that's installed for testing purposes @ runtime. In fact, we should investigate whether we want to install it at all.
Diffstat (limited to 'user/wpa_supplicant')
-rw-r--r--user/wpa_supplicant/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/user/wpa_supplicant/APKBUILD b/user/wpa_supplicant/APKBUILD
index 0208adaee..6f2b0ef89 100644
--- a/user/wpa_supplicant/APKBUILD
+++ b/user/wpa_supplicant/APKBUILD
@@ -2,11 +2,12 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=wpa_supplicant
pkgver=2.6
-pkgrel=10
+pkgrel=11
pkgdesc="Utility providing key negotiation for WPA wireless networks"
url="https://w1.fi/wpa_supplicant/"
arch="all"
license="BSD-3-Clause AND Public-Domain AND (GPL-2.0+ OR BSD-3-Clause)"
+options="!check" # No test suite
subpackages="$pkgname-doc $pkgname-openrc wpa_gui"
depends="dbus"
makedepends="linux-headers openssl-dev dbus-dev libnl3-dev pcsc-lite-dev
@@ -50,18 +51,13 @@ prepare() {
build() {
cd "$builddir"/wpa_supplicant
- make LIBDIR=/lib BINDIR=/sbin
+ make LIBDIR=/lib BINDIR=/sbin all eapol_test
# wpa_gui
qmake -o wpa_gui-qt4/Makefile wpa_gui-qt4/wpa_gui.pro
make -C wpa_gui-qt4
}
-check() {
- cd "$builddir"/wpa_supplicant
- make eapol_test
-}
-
package() {
cd "$builddir"/wpa_supplicant
make DESTDIR="$pkgdir" LIBDIR=/lib BINDIR=/sbin install