summaryrefslogtreecommitdiff
path: root/user/x265
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-10 10:38:13 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-10 10:38:13 +0000
commitf4dd34aee72def35af070eaa1543685c70786615 (patch)
tree1b4dab3b8fa850e34339023d0ac2c3996dd1b4b6 /user/x265
parentf0db4f2d448b543d14b95958ffcb210dcf9315fe (diff)
downloadpackages-f4dd34aee72def35af070eaa1543685c70786615.tar.gz
packages-f4dd34aee72def35af070eaa1543685c70786615.tar.bz2
packages-f4dd34aee72def35af070eaa1543685c70786615.tar.xz
packages-f4dd34aee72def35af070eaa1543685c70786615.zip
user/x265: bump to 3.0, modernise
Diffstat (limited to 'user/x265')
-rw-r--r--user/x265/APKBUILD8
-rw-r--r--user/x265/build-on-any-non-x86.patch24
2 files changed, 3 insertions, 29 deletions
diff --git a/user/x265/APKBUILD b/user/x265/APKBUILD
index b992a0e6a..5ec4bbffa 100644
--- a/user/x265/APKBUILD
+++ b/user/x265/APKBUILD
@@ -1,17 +1,16 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=x265
-pkgver=2.9
+pkgver=3.0
pkgrel=0
pkgdesc="Open Source H265/HEVC video encoder"
url="http://x265.org"
arch="all"
-options="textrel"
+options="textrels"
license="GPL-2.0-only"
makedepends="cmake yasm" # 2.6+ will use nasm instead of yasm
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/multicoreware/$pkgname/downloads/${pkgname}_${pkgver}.tar.gz
- build-on-any-non-x86.patch
x265-unbreak-my-arm.patch"
builddir="$srcdir/${pkgname}_$pkgver"
@@ -48,6 +47,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="270818c7fd84947fde371e32bef225c1880cfb0bcd95378d95b51f50577a134d7cd585fcdfa43b103a24d76c5ad826b09509a07eb9e208e8f2b56f2f77365cf3 x265-2.9.tar.gz
-453acad171d572fdff283cc8b4cdf3707839ae9f13de610416e1298375b218c77dc9870c7367385f7fefaa3d3e66d8c5db76966e66004fa8dde7c40648b0af45 build-on-any-non-x86.patch
+sha512sums="bb7665194ddd4bccbb91c16337463ad4ef32111a1e7779e4cc16964df0992aa99e578cb74fef0edbf41119105e4085574247f60541b0558cc36730ea12d2c6ba x265-3.0.tar.gz
ac3ecc613fe4da11672de8f397b5541fe2af29b7dd91a48859bfe8824934a5966c41ca30de242564c46f1a0cdd2a0da9331d9f547fc21120066fb3c45347c4c4 x265-unbreak-my-arm.patch"
diff --git a/user/x265/build-on-any-non-x86.patch b/user/x265/build-on-any-non-x86.patch
deleted file mode 100644
index f92395629..000000000
--- a/user/x265/build-on-any-non-x86.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- x265_2.9/source/common/cpu.cpp.orig 2018-10-05 12:14:40.000000000 +0000
-+++ x265_2.9/source/common/cpu.cpp 2018-10-19 02:24:48.780000000 +0000
-@@ -59,6 +59,10 @@
-
- namespace X265_NS {
- static bool enable512 = false;
-+bool detect512()
-+{
-+ return(enable512);
-+}
- const cpu_name_t cpu_names[] =
- {
- #if X265_ARCH_X86
-@@ -123,10 +127,6 @@
- #pragma warning(disable: 4309) // truncation of constant value
- #endif
-
--bool detect512()
--{
-- return(enable512);
--}
- uint32_t cpu_detect(bool benableavx512 )
- {
-