summaryrefslogtreecommitdiff
path: root/user/xfce-desktop
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-07 22:27:44 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-07 22:27:44 -0500
commit2fe10c397e720d575fdd2c013be9bb552198a2a7 (patch)
treeef5ebb3046715ff19c4799f212c45c5580489747 /user/xfce-desktop
parent937dcc91a135c3bc7346600ac0f138074224d6df (diff)
downloadpackages-2fe10c397e720d575fdd2c013be9bb552198a2a7.tar.gz
packages-2fe10c397e720d575fdd2c013be9bb552198a2a7.tar.bz2
packages-2fe10c397e720d575fdd2c013be9bb552198a2a7.tar.xz
packages-2fe10c397e720d575fdd2c013be9bb552198a2a7.zip
user/xfce-desktop: new package
Diffstat (limited to 'user/xfce-desktop')
-rw-r--r--user/xfce-desktop/APKBUILD27
-rw-r--r--user/xfce-desktop/org.adelie-linux.about-xfce.desktop8
2 files changed, 35 insertions, 0 deletions
diff --git a/user/xfce-desktop/APKBUILD b/user/xfce-desktop/APKBUILD
new file mode 100644
index 000000000..1a93697dd
--- /dev/null
+++ b/user/xfce-desktop/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce-desktop
+pkgver=4.13
+pkgrel=0
+arch="noarch"
+pkgdesc="Complete XFCE desktop environment"
+url="https://xfce.org"
+license="NCSA"
+options="!check" # meta package, no tests needed.
+depends="xfburn xfce4-power-manager xfce4-settings xfce4-volumed-pulse
+ xfdesktop xfce4-appfinder xfce4-panel xfce4-screenshooter
+ xfce4-taskmanager xfconf xfce4-dict xfce4-panel-profiles
+ xfce4-session xfdashboard xfmpc xfwm4"
+source="org.adelie-linux.about-xfce.desktop"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$srcdir"
+}
+
+package() {
+ cd "$srcdir"
+ install -D -m644 "$srcdir"/org.adelie-linux.about-xfce.desktop \
+ "$pkgdir"/usr/share/applications/org.adelie-linux.about-xfce.desktop
+}
+sha512sums="362793e478e3fb0c6d7dca1f52f582a641ff4582ad0c0d6d1cbe28f1255fc6cd7918ea6b24a5d905a59275f67c44703bf8c78580642c4e0147b539842a6f372f org.adelie-linux.about-xfce.desktop"
diff --git a/user/xfce-desktop/org.adelie-linux.about-xfce.desktop b/user/xfce-desktop/org.adelie-linux.about-xfce.desktop
new file mode 100644
index 000000000..c848c37eb
--- /dev/null
+++ b/user/xfce-desktop/org.adelie-linux.about-xfce.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=About XFCE
+Comment=Learn about the XFCE desktop
+Icon=dialog-information
+Categories=XFCE
+Exec=xdg-open https://xfce.org