summaryrefslogtreecommitdiff
path: root/user/xfce4-clipman-plugin/APKBUILD
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-08 20:43:07 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-08 22:15:55 -0500
commitf8d80294e09284e1528e7cb14aa5784ebc440067 (patch)
treea6d159ec89ed6a2867249c8a88c02c83c48816b4 /user/xfce4-clipman-plugin/APKBUILD
parent92bd0d433513ca7791f7dbc41cc97f324f4e2b5b (diff)
downloadpackages-f8d80294e09284e1528e7cb14aa5784ebc440067.tar.gz
packages-f8d80294e09284e1528e7cb14aa5784ebc440067.tar.bz2
packages-f8d80294e09284e1528e7cb14aa5784ebc440067.tar.xz
packages-f8d80294e09284e1528e7cb14aa5784ebc440067.zip
user/xfce4-clipman-plugin: new package
Diffstat (limited to 'user/xfce4-clipman-plugin/APKBUILD')
-rw-r--r--user/xfce4-clipman-plugin/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/xfce4-clipman-plugin/APKBUILD b/user/xfce4-clipman-plugin/APKBUILD
new file mode 100644
index 000000000..0b5323314
--- /dev/null
+++ b/user/xfce4-clipman-plugin/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-clipman-plugin
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Clipboard management plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev libqrencode-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-clipman-plugin/1.4/xfce4-clipman-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-libqrencode
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f12d9e3e37a26f9dade5b76e73ac3998030112b53e7ec7b756128f7f1ee28d19a1d7b8d4a26e0ccb69aaba2f0ab2f6c4cd5a435bd1cc7efd81c05b711480eba6 xfce4-clipman-plugin-1.4.2.tar.bz2"