summaryrefslogtreecommitdiff
path: root/user/xfce4-mailwatch-plugin
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2022-06-14 01:43:39 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:34:02 -0500
commit5b0f4a34f222ef80104ba5cfa63449885ce2b634 (patch)
tree93d50cfe95a3ce6f4cbb4b00a8031b5cdc3c5f5a /user/xfce4-mailwatch-plugin
parentfd8953282af85282d26d4dadeb487ce76843a13d (diff)
downloadpackages-5b0f4a34f222ef80104ba5cfa63449885ce2b634.tar.gz
packages-5b0f4a34f222ef80104ba5cfa63449885ce2b634.tar.bz2
packages-5b0f4a34f222ef80104ba5cfa63449885ce2b634.tar.xz
packages-5b0f4a34f222ef80104ba5cfa63449885ce2b634.zip
user/xfce4-mailwatch-plugin: new package
Diffstat (limited to 'user/xfce4-mailwatch-plugin')
-rw-r--r--user/xfce4-mailwatch-plugin/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/xfce4-mailwatch-plugin/APKBUILD b/user/xfce4-mailwatch-plugin/APKBUILD
new file mode 100644
index 000000000..61ed6303c
--- /dev/null
+++ b/user/xfce4-mailwatch-plugin/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=xfce4-mailwatch-plugin
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="XFCE panel plugin for monitoring mailboxes"
+url="https://www.xfce.org"
+arch="all"
+license="GPL-2.0-only AND (GPL-2.0-only OR LGPL-2.0+)"
+depends=""
+makedepends="exo-dev gnutls-dev intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/xfce4-mailwatch-plugin/1.3/xfce4-mailwatch-plugin-$pkgver.tar.bz2"
+
+build() {
+ LIBS="-lintl" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="07d4e4cc2f7d299a142d9e9b307c2797892a5febd8451d5291cb9574be0bd5daba677ee893fea3af49b6a8acbfb827ae0125ba11014df37b6c68a2734ecde11b xfce4-mailwatch-plugin-1.3.0.tar.bz2"