summaryrefslogtreecommitdiff
path: root/user/xfce4-sensors-plugin
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-09 05:52:35 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-09 05:52:35 -0500
commit4399ff856fc6e0b0e1899db89b7d115b92ebde67 (patch)
tree8d1023a7cda77b2b3ed618d9b17fcb6397fbd046 /user/xfce4-sensors-plugin
parentb4413a798739cdefd0e495ff2bf5dff89075f44c (diff)
downloadpackages-4399ff856fc6e0b0e1899db89b7d115b92ebde67.tar.gz
packages-4399ff856fc6e0b0e1899db89b7d115b92ebde67.tar.bz2
packages-4399ff856fc6e0b0e1899db89b7d115b92ebde67.tar.xz
packages-4399ff856fc6e0b0e1899db89b7d115b92ebde67.zip
user/xfce4-sensors-plugin: new package
Diffstat (limited to 'user/xfce4-sensors-plugin')
-rw-r--r--user/xfce4-sensors-plugin/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/xfce4-sensors-plugin/APKBUILD b/user/xfce4-sensors-plugin/APKBUILD
new file mode 100644
index 000000000..376b6786d
--- /dev/null
+++ b/user/xfce4-sensors-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-sensors-plugin
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Hardware sensor monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.3/xfce4-sensors-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="77f6df354c883f9f0b99856738e0976e7bddd5f16c90a8715777c4f4d6debe116cdc21c2e0efbbe9f371d36f9469797d3e631854c33f8561e3ff32291cdef35a xfce4-sensors-plugin-1.3.0.tar.bz2"