summaryrefslogtreecommitdiff
path: root/user/yubico-c
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-08-01 10:45:34 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-08-01 10:45:34 -0500
commitf881531924f86061f7d6be63f0e125a3665959bc (patch)
tree639c7c249f1590e322223125bd3194c28aa3ed63 /user/yubico-c
parentb7d6de6f827f44114983e9fbeb3d4edbfa78eaeb (diff)
downloadpackages-f881531924f86061f7d6be63f0e125a3665959bc.tar.gz
packages-f881531924f86061f7d6be63f0e125a3665959bc.tar.bz2
packages-f881531924f86061f7d6be63f0e125a3665959bc.tar.xz
packages-f881531924f86061f7d6be63f0e125a3665959bc.zip
user/yubico-c: new package
Diffstat (limited to 'user/yubico-c')
-rw-r--r--user/yubico-c/APKBUILD47
-rw-r--r--user/yubico-c/use-asciidoctor.patch12
2 files changed, 59 insertions, 0 deletions
diff --git a/user/yubico-c/APKBUILD b/user/yubico-c/APKBUILD
new file mode 100644
index 000000000..dc4e897e1
--- /dev/null
+++ b/user/yubico-c/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=yubico-c
+pkgver=1.13
+pkgrel=0
+pkgdesc="Low-level C library for interacting with YubiKey devices"
+url="https://developers.yubico.com/yubico-c/"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+depends_dev=""
+makedepends="asciidoctor $depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="yubico-c-libyubikey-$pkgver.tar.gz::https://github.com/Yubico/yubico-c/archive/libyubikey-$pkgver.tar.gz
+ use-asciidoctor.patch"
+builddir="$srcdir/$pkgname-libyubikey-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -vif
+}
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make A2X=asciidoctor
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install
+}
+
+sha512sums="5f172263d67f262003caf5ac3135a05e45a8e443ffe4662855cb427620babe8dda954c93fc57cff1fd711f92660e223acd4e928c0902c949c6523f28e9553d19 yubico-c-libyubikey-1.13.tar.gz
+5786fb422e99acee097521d2f5ac63de844ec268001ff20827fcfa4827117f3a10c2793efb5fbc201ece040676bd8d226e741b8a9f01d0e89c4d165c157f2b4a use-asciidoctor.patch"
diff --git a/user/yubico-c/use-asciidoctor.patch b/user/yubico-c/use-asciidoctor.patch
new file mode 100644
index 000000000..c724c8117
--- /dev/null
+++ b/user/yubico-c/use-asciidoctor.patch
@@ -0,0 +1,12 @@
+diff -Nurd yubico-c-libyubikey-1.13/Makefile.am yubico-c-libyubikey-1.13.new/Makefile.am
+--- yubico-c-libyubikey-1.13/Makefile.am 2015-03-05 05:51:01.000000000 -0600
++++ yubico-c-libyubikey-1.13.new/Makefile.am 2018-08-01 08:40:22.590800618 -0500
+@@ -68,7 +68,7 @@
+
+ SUFFIXES = .1.txt .1
+ .1.txt.1:
+- $(A2X) --format=manpage -a revdate="Version $(VERSION)" $<
++ $(A2X) -b manpage -a revdate="Version $(VERSION)" $<
+
+ MANSOURCES = modhex.1.txt ykparse.1.txt ykgenerate.1.txt
+ EXTRA_DIST = $(MANSOURCES) simple.mk THANKS