summaryrefslogtreecommitdiff
path: root/user/z3/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-06-15 21:54:20 -0500
committerMax Rees <maxcrees@me.com>2020-06-16 15:41:03 -0500
commitbf59364ccef65000e448eaae4791efc630e10a09 (patch)
treeba3edef7d43cffc5577250a8e9f93148e44d8763 /user/z3/APKBUILD
parentb638af19ae2d31c0e9eff1d9c70197cd14180ac8 (diff)
downloadpackages-bf59364ccef65000e448eaae4791efc630e10a09.tar.gz
packages-bf59364ccef65000e448eaae4791efc630e10a09.tar.bz2
packages-bf59364ccef65000e448eaae4791efc630e10a09.tar.xz
packages-bf59364ccef65000e448eaae4791efc630e10a09.zip
user/z3: fix build on 32-bit arches
../src/util/mpz.cpp:57:30: error: definition of ‘uint32_t __builtin_ctz(uint32_t)’ ambiguates built-in declaration ‘int __builtin_ctz(unsigned int)’ #define _trailing_zeros32(X) __builtin_ctz(X) ^~~~~~~~~~~~~ ../src/util/mpz.cpp:76:17: note: in expansion of macro ‘_trailing_zeros32’ inline uint32_t _trailing_zeros32(uint32_t x) { ^~~~~~~~~~~~~~~~~ make: *** [Makefile:216: util/mpz.o] Error 1 make: *** Waiting for unfinished jobs.... make: Leaving directory '/af/build/user/z3/src/z3-z3-4.8.7/build' >>> ERROR: z3: build failed Upstream issues: https://github.com/Z3Prover/z3/issues/2727 https://github.com/Z3Prover/z3/issues/2776
Diffstat (limited to 'user/z3/APKBUILD')
-rw-r--r--user/z3/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/user/z3/APKBUILD b/user/z3/APKBUILD
index adac93a71..262a7f530 100644
--- a/user/z3/APKBUILD
+++ b/user/z3/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=z3
pkgver=4.8.7
-pkgrel=0
+pkgrel=1
pkgdesc="Mathematical theorem prover"
url=" "
arch="all"
@@ -10,9 +10,15 @@ license="MIT"
depends=""
makedepends="gmp-dev python3-dev cmd:which"
subpackages="$pkgname-dev py3-$pkgname:py3:noarch"
-source="https://github.com/Z3Prover/z3/archive/z3-$pkgver.tar.gz"
+source="https://github.com/Z3Prover/z3/archive/z3-$pkgver.tar.gz
+ _trailing_zeros32.patch
+ "
builddir="$srcdir/z3-z3-$pkgver"
+case "$CARCH" in
+pmmx) options="$options textrels";;
+esac
+
build() {
PYTHON=python3 ./configure \
--prefix=/usr \
@@ -37,4 +43,5 @@ py3() {
mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
}
-sha512sums="145e2b2f1fa4edd0917107c7e1d54d779c7ed85c48af2ce6def4c90d1c4db05f74c9657e173cedf48770589fbe484c97fa1923295271cd3792523ffc4f67ed0c z3-4.8.7.tar.gz"
+sha512sums="145e2b2f1fa4edd0917107c7e1d54d779c7ed85c48af2ce6def4c90d1c4db05f74c9657e173cedf48770589fbe484c97fa1923295271cd3792523ffc4f67ed0c z3-4.8.7.tar.gz
+6cf6ee35b23f9ef9fe879369a1900c82d38836f245e927f0f80eb6361e3340c32c8b94f00b1cb69eb8cad1626675b8f7b9bdaecffa5072cd5e8b12ecf1e7e3c0 _trailing_zeros32.patch"