summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-18 23:16:08 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-18 23:16:08 +0000
commit39053440b7bc0227ee208c6251cc4a140fb37350 (patch)
treefbcef5c64841a60955840b9ebe630dbcabfc1461 /user
parent5d070da1a2fe35cc976508c90797eb5105227b06 (diff)
downloadpackages-39053440b7bc0227ee208c6251cc4a140fb37350.tar.gz
packages-39053440b7bc0227ee208c6251cc4a140fb37350.tar.bz2
packages-39053440b7bc0227ee208c6251cc4a140fb37350.tar.xz
packages-39053440b7bc0227ee208c6251cc4a140fb37350.zip
user/ksysguard: fix build under new musl
Diffstat (limited to 'user')
-rw-r--r--user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch31
-rw-r--r--user/ksysguard/APKBUILD4
2 files changed, 34 insertions, 1 deletions
diff --git a/user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch b/user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch
new file mode 100644
index 000000000..8828736f3
--- /dev/null
+++ b/user/ksysguard/0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch
@@ -0,0 +1,31 @@
+From d6fa7c0ab6c3a6b1494ffd12b93ee5cc2e4d3d5c Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Mon, 18 Mar 2019 14:34:26 -0500
+Subject: [PATCH] Linux softraid: define _GNU_SOURCE for pipe2
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In a strict POSIX compilation environment, pipe2 is not defined. Use
+the _GNU_SOURCE FTM to expose it.
+
+Fixes a failure to build ksysguard on Adélie Linux.
+---
+ ksysguardd/Linux/softraid.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ksysguardd/Linux/softraid.c b/ksysguardd/Linux/softraid.c
+index c2123fb7..96eb373e 100644
+--- a/ksysguardd/Linux/softraid.c
++++ b/ksysguardd/Linux/softraid.c
+@@ -27,6 +27,7 @@
+ #include <sys/types.h> /* for open */
+ #include <sys/stat.h> /* for open */
+ #include <fcntl.h> /* for open */
++#define _GNU_SOURCE /* pipe2 */
+ #include <unistd.h> /* for read, close, exec, fork */
+ #include <stdlib.h> /* for exit */
+ #include <sys/wait.h> /* for wait :) */
+--
+2.19.2
+
diff --git a/user/ksysguard/APKBUILD b/user/ksysguard/APKBUILD
index 33810d40e..864e7add2 100644
--- a/user/ksysguard/APKBUILD
+++ b/user/ksysguard/APKBUILD
@@ -15,6 +15,7 @@ makedepends="qt5-qtbase-dev kconfig-dev kcoreaddons-dev kdbusaddons-dev kio-dev
subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/plasma/$pkgver/ksysguard-$pkgver.tar.xz
ksysguard-5.6.5-rindex-header.patch
+ 0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch
"
build() {
@@ -44,4 +45,5 @@ package() {
}
sha512sums="745958c74914d9b21373919b0e54cf7d1dd0621769aa8a480bac924862c494c68c86fa36c019fb13d71d8d86c8d923161290ef9a967b98c1182df88da63bbb35 ksysguard-5.12.7.tar.xz
-13a26451c459cff1d3b00af27c953d10c55e7e8f43ef7a6f0f54dd05dcb612546545c0170089e9499bb041f004cdacf19cb112d247a8ccf8fd4e77fea0d1c8bc ksysguard-5.6.5-rindex-header.patch"
+13a26451c459cff1d3b00af27c953d10c55e7e8f43ef7a6f0f54dd05dcb612546545c0170089e9499bb041f004cdacf19cb112d247a8ccf8fd4e77fea0d1c8bc ksysguard-5.6.5-rindex-header.patch
+0a424bb5e23f283d0cccfe86c0a6c2915f563a82e27a1dc16be8b4dc4b3d90ce116c4eb448dd1d5dc07602225468880206a5eb70c1b66d1e19e9a405fae7aa88 0001-Linux-softraid-define-_GNU_SOURCE-for-pipe2.patch"