summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorSheila Aman <sheila@vulpine.house>2021-11-07 16:52:04 +0000
committerSheila Aman <sheila@vulpine.house>2021-11-07 16:52:04 +0000
commit5cb8eeb287e3777076efee7392a107515f9fcc22 (patch)
tree5092361fdbe265ceb9802f97e2462d29571f3540 /user
parent1d3deb758d3abc846405917b8fa1cc1b1e1594a3 (diff)
downloadpackages-5cb8eeb287e3777076efee7392a107515f9fcc22.tar.gz
packages-5cb8eeb287e3777076efee7392a107515f9fcc22.tar.bz2
packages-5cb8eeb287e3777076efee7392a107515f9fcc22.tar.xz
packages-5cb8eeb287e3777076efee7392a107515f9fcc22.zip
user/{c-ares,libev,nghttp2}: move to system
Diffstat (limited to 'user')
-rw-r--r--user/c-ares/APKBUILD35
-rw-r--r--user/libev/APKBUILD38
-rw-r--r--user/libev/libev-4.11-Add-pkgconfig-support.patch58
-rw-r--r--user/nghttp2/APKBUILD45
4 files changed, 0 insertions, 176 deletions
diff --git a/user/c-ares/APKBUILD b/user/c-ares/APKBUILD
deleted file mode 100644
index 564b70ce9..000000000
--- a/user/c-ares/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=c-ares
-pkgver=1.16.1
-pkgrel=0
-pkgdesc="Asynchronous DNS/name resolver library"
-url="https://c-ares.haxx.se/"
-arch="all"
-options="!checkroot"
-license="MIT"
-depends=""
-makedepends=""
-subpackages="$pkgname-doc $pkgname-dev"
-source="https://c-ares.haxx.se/download/$pkgname-$pkgver.tar.gz"
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-shared
- make
-}
-
-check() {
- make -C test check
-}
-
-package() {
- make -j1 DESTDIR="$pkgdir" install
-}
-
-sha512sums="4ac2a5d5c6da74eb1d6155c4eadc7127ab1b53a8d13caec41bd6172db5417a79f3ab022e77ba37d8b13da6893d7ced5fd8baf5cc3950a4154b4de8743ad31471 c-ares-1.16.1.tar.gz"
diff --git a/user/libev/APKBUILD b/user/libev/APKBUILD
deleted file mode 100644
index ac936cd8f..000000000
--- a/user/libev/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: Síle Ekaterin Liszka <sheila@adelielinux.org>
-pkgname=libev
-pkgver=4.33
-pkgrel=0
-pkgdesc="Event dispatch library"
-url="http://software.schmorp.de/pkg/libev.html"
-arch="all"
-options="!check" # No test suite.
-license="BSD-2-Clause OR GPL-2.0+"
-makedepends="$depends_dev autoconf automake libtool"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://dist.schmorp.de/${pkgname}/Attic/${pkgname}-${pkgver}.tar.gz
- libev-4.11-Add-pkgconfig-support.patch
- "
-
-prepare() {
- default_prepare
- libtoolize --force && aclocal -I m4 && autoheader && autoconf \
- && automake --add-missing
-}
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc
- make
-}
-
-package() {
- make -j1 DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/include/event.h
-}
-
-sha512sums="c662a65360115e0b2598e3e8824cf7b33360c43a96ac9233f6b6ea2873a10102551773cad0e89e738541e75af9fd4f3e3c11cd2f251c5703aa24f193128b896b libev-4.33.tar.gz
-b5bc1b5ed1e605cd45a01adce70c1a97188c0b46a36333f12eccd4407c95d96f18adff90ee8c5733c1783a36b4adc5ef67d6b470104339a1ac5c4539a2a4599e libev-4.11-Add-pkgconfig-support.patch"
diff --git a/user/libev/libev-4.11-Add-pkgconfig-support.patch b/user/libev/libev-4.11-Add-pkgconfig-support.patch
deleted file mode 100644
index 8c478caee..000000000
--- a/user/libev/libev-4.11-Add-pkgconfig-support.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 01d2c386b58afa49567ccc079c963f76dc2e60f3 Mon Sep 17 00:00:00 2001
-From: Mathieu Bridon <bochecha@fedoraproject.org>
-Date: Fri, 8 Feb 2013 15:40:51 +0800
-Subject: [PATCH] Add pkgconfig support
-
----
- Makefile.am | 4 ++++
- configure.ac | 2 +-
- libev.pc.in | 11 +++++++++++
- 3 files changed, 16 insertions(+), 1 deletion(-)
- create mode 100644 libev.pc.in
-
-diff --git a/Makefile.am b/Makefile.am
-index 059305b..9e556c0 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -11,6 +11,10 @@ man_MANS = ev.3
-
- include_HEADERS = ev.h ev++.h event.h
-
-+pkgconfigdir = $(libdir)/pkgconfig
-+
-+pkgconfig_DATA = libev.pc
-+
- lib_LTLIBRARIES = libev.la
-
- libev_la_SOURCES = ev.c event.c
-diff --git a/configure.ac b/configure.ac
-index 31d0a25..1af149a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -21,5 +21,5 @@ AC_PROG_LIBTOOL
-
- m4_include([libev.m4])
-
--AC_CONFIG_FILES([Makefile])
-+AC_CONFIG_FILES([Makefile libev.pc])
- AC_OUTPUT
-diff --git a/libev.pc.in b/libev.pc.in
-new file mode 100644
-index 0000000..3b6c636
---- /dev/null
-+++ b/libev.pc.in
-@@ -0,0 +1,11 @@
-+prefix=@prefix@
-+exec_prefix=@prefix@
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: libev
-+Description: High-performance event loop/event model
-+Version: @VERSION@
-+Libs: -L${libdir} -lev
-+Libs.private:
-+Cflags: -I${includedir}
---
-1.8.1
-
diff --git a/user/nghttp2/APKBUILD b/user/nghttp2/APKBUILD
deleted file mode 100644
index a1f7c74c6..000000000
--- a/user/nghttp2/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Síle Ekaterin Liszka <sheila@adelielinux.org>
-pkgname=nghttp2
-pkgver=1.46.0
-pkgrel=0
-pkgdesc="Experimental HTTP/2 client, server and proxy"
-url="https://nghttp2.org/"
-arch="all"
-options="!check" # Requires cunit, which we don't currently ship
-license="MIT"
-depends=""
-makedepends="c-ares-dev libev-dev libxml2-dev openssl-dev zlib-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
-
-# secfixes:
-# 1.41.0-r0:
-# - CVE-2020-11080
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --disable-static \
- --without-neverbleed \
- --without-jemalloc \
- --disable-python-bindings \
- --enable-app
- make
-}
-
-check() {
- make check
-}
-
-package() {
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="fcf3573bcc421705190c7cf0e3230f6f3028b669cb2976d29cfeb73e706deaae91ce60d0a615472e3f296454049ea5798f1e8defdd260a98895e94fea6a7a16b nghttp2-1.46.0.tar.xz"