summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2020-04-05 03:53:40 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2020-04-05 03:53:40 +0000
commit6ff430527606907f1e02fa9d909924ec90d11d00 (patch)
treed5635e6f8532c71ffbdbaae7ceadf37ddaa4cbb4 /user
parent32c4884ced79362bb0f24585f523ed5ff04daade (diff)
parent1a07b28e06182a622263044deb07e913c380d251 (diff)
downloadpackages-6ff430527606907f1e02fa9d909924ec90d11d00.tar.gz
packages-6ff430527606907f1e02fa9d909924ec90d11d00.tar.bz2
packages-6ff430527606907f1e02fa9d909924ec90d11d00.tar.xz
packages-6ff430527606907f1e02fa9d909924ec90d11d00.zip
Merge branch 'sysv.nft' into 'master'
Bump netfilter packages See merge request adelie/packages!420
Diffstat (limited to 'user')
-rw-r--r--user/libnftnl/APKBUILD9
-rw-r--r--user/libnftnl/nft-flowtable-test.patch37
-rw-r--r--user/nftables/APKBUILD6
3 files changed, 7 insertions, 45 deletions
diff --git a/user/libnftnl/APKBUILD b/user/libnftnl/APKBUILD
index b634ff0c2..2456f0522 100644
--- a/user/libnftnl/APKBUILD
+++ b/user/libnftnl/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Luis Ressel <aranea@aixah.de>
-# Maintainer:
+# Maintainer: Molly Miller <sysvinit@adelielinux.org>
pkgname=libnftnl
-pkgver=1.1.5
+pkgver=1.1.6
pkgrel=0
pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
url="https://netfilter.org/projects/libnftnl"
@@ -12,7 +12,6 @@ depends=""
makedepends="libmnl-dev"
subpackages="$pkgname-dev"
source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2
- nft-flowtable-test.patch
"
build() {
@@ -34,5 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a0495e1a99ea9efcf3994db48e50943023ff3d8101055887574ff4eb6b0df8600cf7db68a9c91ca02bbbcc1f01099b008649f88321bb956897bcc90eb4167ee7 libnftnl-1.1.5.tar.bz2
-0978037a5dec71a96f5713dbc5a4dc8dc30b7b37d79ec7dd6ec8b201740303785c3625c21a2388f8fd5d9d446f8706ac14d0bf5909a48ed3ef3e7417173dd2c8 nft-flowtable-test.patch"
+sha512sums="3de13cb667060f0942c8dd9e139ee8c7aff1854c544793774a827c01d06e432a4ce05d54846e1062aa620b5e54533da09daa9588467866c82c9119ef4cfbb57d libnftnl-1.1.6.tar.bz2
+"
diff --git a/user/libnftnl/nft-flowtable-test.patch b/user/libnftnl/nft-flowtable-test.patch
deleted file mode 100644
index 719c1f2cf..000000000
--- a/user/libnftnl/nft-flowtable-test.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From b2388765e0c4405442faa13845419f6a35d0134c Mon Sep 17 00:00:00 2001
-From: Phil Sutter <phil@nwl.cc>
-Date: Mon, 2 Dec 2019 18:29:56 +0100
-Subject: tests: flowtable: Don't check NFTNL_FLOWTABLE_SIZE
-
-Marshalling code around that attribute has been dropped by commit
-d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE") so it's value is
-lost during the test.
-
-Assuming that NFTNL_FLOWTABLE_SIZE will receive kernel support at a
-later point, leave the test code in place but just comment it out.
-
-Fixes: d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE")
-Signed-off-by: Phil Sutter <phil@nwl.cc>
-Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>
----
- tests/nft-flowtable-test.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tests/nft-flowtable-test.c b/tests/nft-flowtable-test.c
-index 3edb00d..8ab8d4c 100644
---- a/tests/nft-flowtable-test.c
-+++ b/tests/nft-flowtable-test.c
-@@ -33,9 +33,11 @@ static void cmp_nftnl_flowtable(struct nftnl_flowtable *a, struct nftnl_flowtabl
- if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_USE) !=
- nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_USE))
- print_err("Flowtable use mismatches");
-+#if 0
- if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_SIZE) !=
- nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_SIZE))
- print_err("Flowtable size mismatches");
-+#endif
- if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_FLAGS) !=
- nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_FLAGS))
- print_err("Flowtable flags mismatches");
---
-2.24.1
diff --git a/user/nftables/APKBUILD b/user/nftables/APKBUILD
index 41e356d37..bc96a18f1 100644
--- a/user/nftables/APKBUILD
+++ b/user/nftables/APKBUILD
@@ -2,9 +2,9 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Contributor: Luis Ressel <aranea@aixah.de>
-# Maintainer:
+# Maintainer: Molly Miller <sysvinit@adelielinux.org>
pkgname=nftables
-pkgver=0.9.3
+pkgver=0.9.4
pkgrel=0
pkgdesc="Netfilter tables userspace tools"
url="https://netfilter.org/projects/nftables"
@@ -47,7 +47,7 @@ package() {
install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="d264f6fc75c95510e29fe7d5b82ae418d502f40437b098ba6117ffb1374d9989d70a7296e2e58c5fb25142145a987bb9c160902637899f892589809f9541db43 nftables-0.9.3.tar.bz2
+sha512sums="cef5b5f26f3a2893a3eb1323f1f0ecfd6e2865e0eb040e9b7da5824e5be2274b888e661abe96e828add9e951f47303e30cb7c9238d267a031c0f99b5f3b6e2c0 nftables-0.9.4.tar.bz2
f7b18945f0ab8be2a8725fa902cb2499de0a886076ae4cc337ebd845b3ae08f05a75b1680b428075d42558e7953014a227405e748741e6ebc3a7ac84bbf4beaa asciidoctor.patch
4eb1adf003dfcaad65c91af6ca88d91b7904c471aefae67e7d3c2f8e053e1ac196d3437a45d1fed5a855b876a0f1fc58a724e381d2acf1164d9120cadee73eef nftables.confd
58daafb012b7cd0248a7db6e10f6a667e683347aaea7eaa78cb88780272f334e00913cea3fd39a22a4a72acc27fabd101944b40916f4b534ddeb509bd0232017 nftables.initd"