summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-11-20 07:20:16 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-11-20 07:20:16 +0000
commit75c78e3366d98013cc1d0f897db658243cceb6c5 (patch)
tree4d2f44ed02d3718261c1b2de576aa2e9e5bdfc4e /user
parent72a4a82ba17bb99d28b1ede45d9a254971b6a09e (diff)
parentcce38c77ccac12e75ca1829624a9e3d479a5641e (diff)
downloadpackages-75c78e3366d98013cc1d0f897db658243cceb6c5.tar.gz
packages-75c78e3366d98013cc1d0f897db658243cceb6c5.tar.bz2
packages-75c78e3366d98013cc1d0f897db658243cceb6c5.tar.xz
packages-75c78e3366d98013cc1d0f897db658243cceb6c5.zip
Merge branch 'add-keychain' into 'master'
user/keychain: new package Keychain is a set of shell scripts (edited by a Perl script) that automates the handling of OpenSSH, OpenPGP, and other security keys. Given that it's a shell script, I did not include dependencies on OpenSSH or GnuPG since it can be used with one, the other, both, or one of the more exotic options. Its behavior is completely dependent on the user telling it what to use. See merge request !109
Diffstat (limited to 'user')
-rw-r--r--user/keychain/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/keychain/APKBUILD b/user/keychain/APKBUILD
new file mode 100644
index 000000000..10c0ab99d
--- /dev/null
+++ b/user/keychain/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=keychain
+pkgver=2.8.5
+pkgrel=0
+pkgdesc="Agent manager for OpenSSH and GnuPG"
+url="https://funtoo.org/Keychain"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends=""
+makedepends="perl"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/funtoo/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 "./${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "./${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+}
+
+sha512sums="2b98a9937b058267150d62d4f95653c4bbab6117a0774ac266abf95020c41905412b1522a82abf71722f25f6af31ba3498f6d54622009498c845802bf2df6024 keychain-2.8.5.tar.gz"