summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-28 19:44:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-28 19:44:38 -0500
commit863fc054627e3ca3a0813027d03d3b1ca0409aca (patch)
tree73bbbe766fca01bdcca01bd863e32f00d981271c /user
parent2d499007519e94892204189710e2bea22e12fc45 (diff)
downloadpackages-863fc054627e3ca3a0813027d03d3b1ca0409aca.tar.gz
packages-863fc054627e3ca3a0813027d03d3b1ca0409aca.tar.bz2
packages-863fc054627e3ca3a0813027d03d3b1ca0409aca.tar.xz
packages-863fc054627e3ca3a0813027d03d3b1ca0409aca.zip
user/libvpx: move to legacy/, remove from rdeps
Diffstat (limited to 'user')
-rw-r--r--user/ffmpeg/APKBUILD6
-rw-r--r--user/firefox-esr/APKBUILD5
-rw-r--r--user/libvpx/APKBUILD54
-rw-r--r--user/libvpx/libm-pc.patch11
-rw-r--r--user/thunderbird/APKBUILD4
-rw-r--r--user/thunderbird/mozconfig1
-rw-r--r--user/vlc/APKBUILD6
7 files changed, 10 insertions, 77 deletions
diff --git a/user/ffmpeg/APKBUILD b/user/ffmpeg/APKBUILD
index 58225f191..39f8d043c 100644
--- a/user/ffmpeg/APKBUILD
+++ b/user/ffmpeg/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ffmpeg
pkgver=4.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Record, convert, and stream audio and video"
url="https://ffmpeg.org/"
arch="all"
@@ -13,7 +13,7 @@ options="!check textrels" # Test suite requires proper licensing headers on all
# which upstream does not provide.
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
makedepends="gnutls-dev lame-dev libvorbis-dev xvidcore-dev zlib-dev libvdpau-dev
- imlib2-dev libtheora-dev coreutils bzip2-dev perl-dev libvpx-dev x264-dev
+ imlib2-dev libtheora-dev coreutils bzip2-dev perl-dev x264-dev
pulseaudio-dev sdl2-dev libxfixes-dev libva-dev alsa-lib-dev rtmpdump-dev
v4l-utils-dev yasm opus-dev x265-dev xz-dev freetype-dev speex-dev
ladspa-dev libcdio-dev libcdio-paranoia-dev wavpack-dev libwebp-dev"
@@ -56,7 +56,7 @@ build() {
--enable-libmp3lame \
--enable-librtmp \
--enable-libvorbis \
- --enable-libvpx \
+ --disable-libvpx \
--enable-libxvid \
--enable-libx264 \
--enable-libx265 \
diff --git a/user/firefox-esr/APKBUILD b/user/firefox-esr/APKBUILD
index 79df86a57..d721164ca 100644
--- a/user/firefox-esr/APKBUILD
+++ b/user/firefox-esr/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox-esr
pkgver=52.9.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="https://www.mozilla.org/en-US/firefox/organizations/faq/"
arch="all"
@@ -14,7 +14,7 @@ depends=""
depends_dev="alsa-lib-dev bzip2-dev dbus-glib-dev gconf-dev gtk+2.0-dev
gtk+3.0-dev hunspell-dev icu-dev libevent-dev libidl-dev
libjpeg-turbo-dev libnotify-dev libogg-dev libtheora-dev libvorbis-dev
- libvpx-dev libxt-dev libxcomposite-dev mesa-dev nspr-dev nss-dev
+ libxt-dev libxcomposite-dev mesa-dev nspr-dev nss-dev
pulseaudio-dev sqlite-dev startup-notification-dev wireless-tools-dev"
makedepends="$depends_dev autoconf2.13 automake libtool
bsd-compat-headers cmd:which nss-static openssl-dev sed yasm zip"
@@ -148,7 +148,6 @@ build() {
--with-system-icu \
--with-system-jpeg \
--with-system-libevent \
- --with-system-libvpx \
--with-system-nspr \
--with-system-nss \
--with-system-pixman \
diff --git a/user/libvpx/APKBUILD b/user/libvpx/APKBUILD
deleted file mode 100644
index e52733795..000000000
--- a/user/libvpx/APKBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Maintainer:
-pkgname=libvpx
-pkgver=1.7.0
-pkgrel=0
-pkgdesc="Library for the VP8 and VP9 codecs"
-url="https://www.webmproject.org/"
-arch="all"
-options="!check" # Requires at least 2 GB of sample videos...
-license="BSD-3-Clause"
-depends=""
-makedepends="bash coreutils perl yasm cmd:which"
-subpackages="$pkgname-dev $pkgname-utils"
-source="https://github.com/webmproject/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
-
-build() {
- cd "$builddir"
- # fix build for armv7
- case "$CTARGET" in
- armv7-*-*-*eabihf) export CFLAGS="-mfloat-abi=hard";;
- esac
- bash ./configure \
- --extra-cflags="$CFLAGS" \
- --enable-pic \
- --enable-libs \
- --enable-runtime-cpu-detect \
- --enable-vp8 \
- --enable-vp9 \
- --enable-shared \
- --disable-install-srcs \
- --enable-postproc
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DIST_DIR="$pkgdir"/usr install
- chmod 644 "$pkgdir"/usr/include/vpx/*.h \
- "$pkgdir"/usr/lib/pkgconfig/*
- chown root:root -R "$pkgdir"
- chmod 755 "$pkgdir"/usr/lib/*
-}
-
-utils() {
- pkgdesc="VP8 and VP9 vode codec utilities and tools"
- install -d "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
-}
-
-sha512sums="8b3b766b550f8d86907628d7ed88035f9a2612aac21542e0fd5ad35b905eb82cbe1be02a1a24afce7a3bcc4766f62611971f72724761996b392136c40a1e7ff0 libvpx-1.7.0.tar.gz"
diff --git a/user/libvpx/libm-pc.patch b/user/libvpx/libm-pc.patch
deleted file mode 100644
index 87f07a398..000000000
--- a/user/libvpx/libm-pc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libs.mk.orig
-+++ ./libs.mk
-@@ -241,7 +241,7 @@
- $(qexec)echo 'Version: $(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_PATCH)' >> $@
- $(qexec)echo 'Requires:' >> $@
- $(qexec)echo 'Conflicts:' >> $@
-- $(qexec)echo 'Libs: -L$${libdir} -lvpx' >> $@
-+ $(qexec)echo 'Libs: -L$${libdir} -lvpx -lm' >> $@
- $(qexec)echo 'Cflags: -I$${includedir}' >> $@
- INSTALL-LIBS-yes += $(LIBSUBDIR)/pkgconfig/vpx.pc
- INSTALL_MAPS += $(LIBSUBDIR)/pkgconfig/%.pc %.pc
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index 6b5c8b8fd..9463e986c 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=thunderbird
pkgver=52.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="Email client from Mozilla"
url="https://www.mozilla.org/thunderbird/"
arch="all"
@@ -16,7 +16,7 @@ makedepends="
autoconf2.13 ncurses-dev perl cmd:which
alsa-lib-dev bzip2-dev icu-dev libevent-dev libffi-dev libpng-dev
- libjpeg-turbo-dev libvpx-dev nspr-dev nss-dev pulseaudio-dev zlib-dev
+ libjpeg-turbo-dev nspr-dev nss-dev pulseaudio-dev zlib-dev
dbus-glib-dev gconf-dev gtk+2.0-dev gtk+3.0-dev hunspell-dev libsm-dev
libnotify-dev libxcomposite-dev libxdamage-dev libxrender-dev libxt-dev
diff --git a/user/thunderbird/mozconfig b/user/thunderbird/mozconfig
index 8359687c5..623894870 100644
--- a/user/thunderbird/mozconfig
+++ b/user/thunderbird/mozconfig
@@ -26,7 +26,6 @@ ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-libevent
-ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-png
diff --git a/user/vlc/APKBUILD b/user/vlc/APKBUILD
index 5f936cac8..a3876eeed 100644
--- a/user/vlc/APKBUILD
+++ b/user/vlc/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=vlc
pkgver=3.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="Multi-platform MPEG, VCD/DVD, and DivX player"
triggers="vlc-libs.trigger=/usr/lib/vlc/plugins"
pkgusers="vlc"
@@ -55,7 +55,7 @@ makedepends="autoconf automake bison eudev-dev flex libarchive-dev
libcddb-dev libdc1394-dev>=2.1.0 libdca-dev libdvbpsi-dev libdvdnav-dev
libdvdread-dev libmad-dev libmatroska-dev libmpeg2-dev libogg-dev
libraw1394-dev>=2.0.1 librsvg-dev libshout-dev libtheora-dev libva-dev
- libvdpau-dev libvorbis-dev libvpx-dev live-media-dev>=2012.01.26
+ libvdpau-dev libvorbis-dev live-media-dev>=2012.01.26
opus-dev pulseaudio-dev speex-dev speexdsp-dev taglib-dev v4l-utils-dev
x264-dev x265-dev gstreamer-dev gst-plugins-base-dev
"
@@ -97,6 +97,7 @@ build() {
--enable-optimizations \
--enable-optimize-memory \
--disable-rpath \
+ --disable-vpx \
--disable-wayland \
--enable-dbus \
--enable-notify \
@@ -138,7 +139,6 @@ build() {
--enable-vdpau \
--enable-vlm \
--enable-vorbis \
- --enable-vpx \
--enable-wma-fixed \
--enable-x264 \
--enable-x265 \