summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2021-10-06 15:00:25 +0000
committerDan Theisen <djt@hxx.in>2021-10-06 15:00:25 +0000
commit8b3bc661e92a942c18f00feafaae20506fbd57e1 (patch)
tree562dfe3529dd4d82047288ab21d26cc2e7ba12ce /user
parent4b5157d7a0b3453665a8a1005eb17db8513d98a5 (diff)
downloadpackages-8b3bc661e92a942c18f00feafaae20506fbd57e1.tar.gz
packages-8b3bc661e92a942c18f00feafaae20506fbd57e1.tar.bz2
packages-8b3bc661e92a942c18f00feafaae20506fbd57e1.tar.xz
packages-8b3bc661e92a942c18f00feafaae20506fbd57e1.zip
user/libnatpmp: new package
Diffstat (limited to 'user')
-rw-r--r--user/libnatpmp/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/libnatpmp/APKBUILD b/user/libnatpmp/APKBUILD
new file mode 100644
index 000000000..bd2facd27
--- /dev/null
+++ b/user/libnatpmp/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=libnatpmp
+pkgver=20150609
+pkgrel=0
+pkgdesc="A portable and fully compliant implementation of the NAT-PMP protocol"
+url="https://miniupnp.tuxfamily.org/libnatpmp.html"
+arch="all"
+options="!check"
+license="BSD-3-Clause"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="https://miniupnp.tuxfamily.org/files/libnatpmp-$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX="$pkgdir" install
+}
+
+sha512sums="e50b1f68ce9254bb2f068ddc37417a3c417b80f7b3fb3d84e3e9af4a144d89e204ab993b54c01657335e855d0124a8fcbbf96ce78db7b9ae0b03b6eb79de2e09 libnatpmp-20150609.tar.gz"