summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-11-30 12:58:09 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-11-30 12:58:09 +0000
commit8df0325ea49d55655b7a55d7f5a099b420654768 (patch)
tree1ab3eb0297663416d55f438ae7165aca301a4f15 /user
parent101d242c93747c77b050f5db2538d92f7408ac3a (diff)
parent281660494c7c0a009818bfa8bf348099c395041f (diff)
downloadpackages-8df0325ea49d55655b7a55d7f5a099b420654768.tar.gz
packages-8df0325ea49d55655b7a55d7f5a099b420654768.tar.bz2
packages-8df0325ea49d55655b7a55d7f5a099b420654768.tar.xz
packages-8df0325ea49d55655b7a55d7f5a099b420654768.zip
Merge branch 'add-markdownpy' into 'master'
user/py3-markdown: new package Not much to say about this one. It plugs into cgit seamlessly, and Pelican can be configured to generate posts using it. See merge request !119
Diffstat (limited to 'user')
-rw-r--r--user/py3-markdown/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/py3-markdown/APKBUILD b/user/py3-markdown/APKBUILD
new file mode 100644
index 000000000..ef362e1f9
--- /dev/null
+++ b/user/py3-markdown/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-markdown
+_pkgname=Markdown
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="A Python implementation of Markdown"
+url="https://python-markdown.github.io/"
+arch="noarch"
+options="!check" # needs flake8
+license="BSD-3-Clause"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="c648c1b8ecb3c907ff2bd636ec6c08b4b629967fb916913f77db641f6d61b83d16929af2f15f5695c8cdb9614031606110e02a7e0bbb3aab0be38a8e285f12f1 Markdown-3.0.1.tar.gz"