summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-12-10 16:24:04 +0000
committerZach van Rijn <me@zv.io>2024-12-10 16:24:05 +0000
commit95de1594431b2bb9d15e425870907360ac015875 (patch)
tree0fced896229bed10a73cbbd2df799967e97d5966 /user
parent281aa38b87981b0b9bb091f367457bb8a1bbc8ac (diff)
downloadpackages-95de1594431b2bb9d15e425870907360ac015875.tar.gz
packages-95de1594431b2bb9d15e425870907360ac015875.tar.bz2
packages-95de1594431b2bb9d15e425870907360ac015875.tar.xz
packages-95de1594431b2bb9d15e425870907360ac015875.zip
user/gst-plugins-bad: disable failing test. fixes #1295.
The test is disabled upstream, so let's trust them.
Diffstat (limited to 'user')
-rw-r--r--user/gst-plugins-bad/APKBUILD4
-rw-r--r--user/gst-plugins-bad/disable-failing-test.patch59
2 files changed, 62 insertions, 1 deletions
diff --git a/user/gst-plugins-bad/APKBUILD b/user/gst-plugins-bad/APKBUILD
index 25e6b9d62..b148cc811 100644
--- a/user/gst-plugins-bad/APKBUILD
+++ b/user/gst-plugins-bad/APKBUILD
@@ -24,6 +24,7 @@ source="https://gstreamer.freedesktop.org/src/$pkgname/$pkgname-$pkgver.tar.xz
mpegts.patch
fix-arm-test-alignment.patch
fix-arm-parser-alignment.patch
+ disable-failing-test.patch
"
build() {
@@ -49,4 +50,5 @@ sha512sums="3f98973dc07ead745418e0a30f9f6b5c8d328e3d126f54d92c10ab5da04271768a5c
d4bf36560db0e6391cfca84f928d7147bb6b170431c521e78253b29f6bccf122309e1f92e241808855dfa112b9a06e17c1b6ed4363e011a0693f82e1bfe7ea3e curlhttpsrc.patch
d70f409f86b072d689d51b87db6e9fb161c0914a381eccbf66f1ffcd61b9a793f9e4087cdd071e615aaa63687c6ee476f023239920dd1ebd0d3cde346031dc86 mpegts.patch
566fbdc37c9f9fb5b671ecffa2f596a95f6431668ff8dd8b91bc827a280b5fb18a8fac3122a38f060263cb3f2d2138805af1e1c324eb619188f982c8cc575221 fix-arm-test-alignment.patch
-f394b1643a5d0943e8acd7e9ee11702ce3bbfb27242f3eac140b884ce7bb5dea725ab4bb0a28cbf9d435622dcc68ea0ee0bee1c51a520787c382167dd1e43583 fix-arm-parser-alignment.patch"
+f394b1643a5d0943e8acd7e9ee11702ce3bbfb27242f3eac140b884ce7bb5dea725ab4bb0a28cbf9d435622dcc68ea0ee0bee1c51a520787c382167dd1e43583 fix-arm-parser-alignment.patch
+3c900a5cbe3ac129172f36acd4d9ede2610ceab500515c32a380dabd2d3d3f78d26be0c9521db855d13283b5be154c9407cd6bf5ec59524305170fc2db2572cb disable-failing-test.patch"
diff --git a/user/gst-plugins-bad/disable-failing-test.patch b/user/gst-plugins-bad/disable-failing-test.patch
new file mode 100644
index 000000000..b650bf519
--- /dev/null
+++ b/user/gst-plugins-bad/disable-failing-test.patch
@@ -0,0 +1,59 @@
+This patch was modified from upstream in the following way(s):
+
+* Adjust paths so that it applies to this subproject.
+
+From 81e7bde67c7aa4de2f846db1ed619771613259da Mon Sep 17 00:00:00 2001
+From: Edward Hervey <edward@centricular.com>
+Date: Thu, 5 Sep 2024 10:08:17 +0200
+Subject: [PATCH] check: Disable failing test
+
+Test hasn't been properly fixed for several years with modern libsoup, and it
+only for the legacy adaptive demuxer.
+
+Fixes #3783
+
+Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/7454>
+---
+ .../gst-plugins-bad/tests/check/elements/dash_mpd.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/subprojects/gst-plugins-bad/tests/check/elements/dash_mpd.c b/subprojects/gst-plugins-bad/tests/check/elements/dash_mpd.c
+index 1d347b0a54ea..91d6cc505d91 100644
+--- a/tests/check/elements/dash_mpd.c
++++ b/tests/check/elements/dash_mpd.c
+@@ -5999,6 +5999,12 @@ GST_START_TEST (dash_mpdparser_maximum_segment_duration)
+
+ GST_END_TEST;
+
++#if 0
++/*
++ * Test disabled due to failures with recent libsoup
++*/
++
++
+ /*
+ * Test parsing of Perioud using @xlink:href attribute
+ */
+@@ -6103,6 +6109,7 @@ GST_START_TEST (dash_mpdparser_xlink_period)
+
+ GST_END_TEST;
+
++#endif
+
+ /*
+ * Test parsing xsd:datetime with timezoneoffset.
+@@ -6658,8 +6665,11 @@ dash_suite (void)
+ tcase_add_test (tc_simpleMPD, dash_mpdparser_various_duration_formats);
+ tcase_add_test (tc_simpleMPD, dash_mpdparser_default_presentation_delay);
+
++#if 0
++ /* Test disabled due to failure with libsoup */
+ /* tests checking xlink attributes */
+ tcase_add_test (tc_simpleMPD, dash_mpdparser_xlink_period);
++#endif
+
+ /* tests checking the MPD management
+ * (eg. setting active streams, obtaining attributes values)
+--
+GitLab
+