summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-12-09 17:16:40 +0000
committerZach van Rijn <me@zv.io>2024-12-09 17:16:40 +0000
commit9db8e5bbf921318e6b60a0afed6fa0a104db33ea (patch)
tree7255c817f5d317789b8cb280684530e35b9282c1 /user
parent0293f18cc7420518c511b95b4ecaa2026ba7977a (diff)
downloadpackages-9db8e5bbf921318e6b60a0afed6fa0a104db33ea.tar.gz
packages-9db8e5bbf921318e6b60a0afed6fa0a104db33ea.tar.bz2
packages-9db8e5bbf921318e6b60a0afed6fa0a104db33ea.tar.xz
packages-9db8e5bbf921318e6b60a0afed6fa0a104db33ea.zip
user/abiword: add patch for libxml2. fixes #1286.
Diffstat (limited to 'user')
-rw-r--r--user/abiword/APKBUILD6
-rw-r--r--user/abiword/libxml2-2.12.patch29
2 files changed, 33 insertions, 2 deletions
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
index 6d732c535..7da87b633 100644
--- a/user/abiword/APKBUILD
+++ b/user/abiword/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abiword
pkgver=3.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="A fully-featured word processor"
url="https://www.abisource.com"
arch="all"
@@ -25,6 +25,7 @@ _plugins="applix babelfish bmp clarisworks collab docbook eml epub \
# https certificate is expired; integrity provided by checksum
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
fix-bad-cast.patch
+ libxml2-2.12.patch
"
build() {
@@ -43,4 +44,5 @@ package() {
}
sha512sums="a2484268901ff47307c9d1f1928622e364f1006f22ce38257c585144df9411dfe3c2dea28c1f1f50a6e545e8cc579cce34117a89dfa771e20312e3ea1a9989d6 abiword-3.0.5.tar.gz
-89edeed246f937e4f198068ed9861e155662d346fb1534d2ed676cbd782de22a691d2b045989942bd715cbfc3750cf9d7615065816b970695597361ae4a9d55e fix-bad-cast.patch"
+89edeed246f937e4f198068ed9861e155662d346fb1534d2ed676cbd782de22a691d2b045989942bd715cbfc3750cf9d7615065816b970695597361ae4a9d55e fix-bad-cast.patch
+0f98383e160782ccc2160e1bd9f5ba5ca02463dc14c2caeb987f225c06b4484a3618a068ff35806b6e3b6b2748e90a558c71ffb8d44c669f302fdcaebca836d4 libxml2-2.12.patch"
diff --git a/user/abiword/libxml2-2.12.patch b/user/abiword/libxml2-2.12.patch
new file mode 100644
index 000000000..2c3642248
--- /dev/null
+++ b/user/abiword/libxml2-2.12.patch
@@ -0,0 +1,29 @@
+From 2a06be6a10a0718f8a3d8e00c317f5042c99a467 Mon Sep 17 00:00:00 2001
+From: Jan Tojnar <jtojnar@gmail.com>
+Date: Mon, 11 Dec 2023 01:55:53 +0100
+Subject: [PATCH] Fix build with libxml2 2.12
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+libxml 2.12.0 restructured headers so that xmlFree is no longer in the scope.
+Let’s add the correct include.
+---
+ src/af/util/xp/ut_stringbuf.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/af/util/xp/ut_stringbuf.cpp b/src/af/util/xp/ut_stringbuf.cpp
+index f1e8d9078..88488ad67 100644
+--- a/src/af/util/xp/ut_stringbuf.cpp
++++ b/src/af/util/xp/ut_stringbuf.cpp
+@@ -26,6 +26,7 @@
+ #include <algorithm>
+
+ #include <libxml/uri.h>
++#include <libxml/xmlmemory.h>
+
+ #include <glib.h>
+
+--
+GitLab
+