summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-12-07 21:30:15 +0000
committerZach van Rijn <me@zv.io>2024-12-07 21:33:30 +0000
commita969dcc1cb523d61cc3cfd879100b352c8fd0e24 (patch)
tree9bcd636f3a0c987e4f219647ce5234d21b0d3ec0 /user
parent8c7a5883fb0da13f70eba6629a5e073ae39c95cd (diff)
downloadpackages-a969dcc1cb523d61cc3cfd879100b352c8fd0e24.tar.gz
packages-a969dcc1cb523d61cc3cfd879100b352c8fd0e24.tar.bz2
packages-a969dcc1cb523d61cc3cfd879100b352c8fd0e24.tar.xz
packages-a969dcc1cb523d61cc3cfd879100b352c8fd0e24.zip
user/libavc1394: look for different argp symbol. fixes #1271.
Commit e9634624744109ff3ae8228d8a87ce3c31a9a121 changed upstream for 'argp-standalone', a dependency of this package. The 'argp.patch' file looks for the 'argp_usage' symbol in libargp but is apparently not able to find it due to (I believe): https://github.com/ericonr/argp-standalone/commit/e7ff8d9787d2641e55f6ac4afb777da60ef98043 This commit looks for a different symbol instead. Note: -dev is now required and should be investigated.
Diffstat (limited to 'user')
-rw-r--r--user/libavc1394/APKBUILD6
-rw-r--r--user/libavc1394/argp.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/user/libavc1394/APKBUILD b/user/libavc1394/APKBUILD
index a76d47301..100aa176d 100644
--- a/user/libavc1394/APKBUILD
+++ b/user/libavc1394/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer:
pkgname=libavc1394
pkgver=0.5.4
-pkgrel=3
+pkgrel=4
pkgdesc="Audio/Video control library for FireWire devices"
url="https://sourceforge.net/projects/libavc1394/"
arch="all"
license="LGPL-2.1+"
depends=""
-makedepends="libraw1394-dev libtool automake autoconf argp-standalone"
+makedepends="libraw1394-dev libtool automake autoconf argp-standalone-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/libavc1394/libavc1394-$pkgver.tar.gz
automake.patch
@@ -43,4 +43,4 @@ package() {
sha512sums="ef07631cd2de9b79dec9d81247d705be318101e8f8a1fe007b946ffab3dfe7b97f392144614d867ef6b2315b6c0e82d53e915f07855d4e21401645293e18842a libavc1394-0.5.4.tar.gz
8854bed6b9efa4b2bb56762614bcbceadb5cb1cdd393fd676476d40672cc3965962da764543f8628f51567a32ecf5035edb35b883b8963f94bce034ff4793c11 automake.patch
-77bf60530b6b81f6bd3c69a11de7ac015f1182fcd8c2586d0fd9605818c3ccde310c386f30c00166853a405f60c13bf6b2d304327ec181de28609c58b215ab31 argp.patch"
+f71c498aa1ad6889ce66db194ceb94d8559fe9a26739bcffa8d9cb1e910f40b9cb8613db8a71cf46f0bd61c77f2e48dddbdcafb5f7d9483b2200470a1c6cd2ea argp.patch"
diff --git a/user/libavc1394/argp.patch b/user/libavc1394/argp.patch
index 9c86a625e..ec1401976 100644
--- a/user/libavc1394/argp.patch
+++ b/user/libavc1394/argp.patch
@@ -4,7 +4,7 @@
AC_HEADER_STDC
AC_CHECK_HEADERS(sys/time.h sys/types.h unistd.h string.h netinet/in.h stdio.h)
-+AC_SEARCH_LIBS([argp_usage], [argp], [],
++AC_SEARCH_LIBS([argp_help], [argp], [],
+ [AC_MSG_ERROR([argp not found. Consider installing argp-standalone])])
PKG_CHECK_MODULES(LIBRAW1394, libraw1394 >= 1.0.0)