summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-04 17:56:47 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-04 17:58:41 -0600
commitf89e153e53f10018db68c4f52e4c50a4f722502d (patch)
treebeba7ec13ff41eaad26bf16bebcc06a8c7fa275d /user
parent730f0a84f08e1b0dad8cc34e9d260802b7777fc0 (diff)
downloadpackages-f89e153e53f10018db68c4f52e4c50a4f722502d.tar.gz
packages-f89e153e53f10018db68c4f52e4c50a4f722502d.tar.bz2
packages-f89e153e53f10018db68c4f52e4c50a4f722502d.tar.xz
packages-f89e153e53f10018db68c4f52e4c50a4f722502d.zip
user/kwin: Use xwayland instead of xorg-server-
XWayland is now its own package, separate from the X server base package. Use XWayland as the dependency. Not revbump because this package has never escaped into the wild since the libglvnd revbump; if it had, it would have broken deps and been unable to build anyway.
Diffstat (limited to 'user')
-rw-r--r--user/kwin/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/user/kwin/APKBUILD b/user/kwin/APKBUILD
index c48d7b4b6..2be15a607 100644
--- a/user/kwin/APKBUILD
+++ b/user/kwin/APKBUILD
@@ -16,8 +16,7 @@ makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev python3
qt5-qtmultimedia-dev qt5-qtx11extras-dev fontconfig-dev freetype-dev
libdrm-dev libinput-dev libx11-dev libxi-dev libxkbcommon-dev mesa-dev
wayland-dev xcb-util-cursor-dev xcb-util-image-dev xcb-util-wm-dev
- lcms2-dev libcap-dev libqaccessibilityclient-dev xorg-server-xwayland
- libglvnd-dev
+ lcms2-dev libcap-dev libqaccessibilityclient-dev xwayland libglvnd-dev
breeze breeze-dev kactivities-dev kcompletion-dev kconfigwidgets-dev
kcmutils-dev kcrash-dev kdeclarative-dev kdecoration-dev kirigami2-dev
@@ -56,7 +55,7 @@ package() {
wayland() {
pkgdesc="$pkgdesc (Wayland server)"
- depends="$pkgname=$pkgver-r$pkgrel xorg-server-xwayland"
+ depends="$pkgname=$pkgver-r$pkgrel xwayland"
mkdir -p "$subpkgdir"/usr/lib/qt5/plugins
mv "$pkgdir"/usr/lib/qt5/plugins/org.kde.kwin.waylandbackends \