summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/apaste/APKBUILD20
-rw-r--r--user/apaste/apasted.initd5
-rw-r--r--user/apaste/apasted.post-install7
-rw-r--r--user/apaste/apasted.pre-install6
4 files changed, 18 insertions, 20 deletions
diff --git a/user/apaste/APKBUILD b/user/apaste/APKBUILD
index 42c4a0c17..9da6d259a 100644
--- a/user/apaste/APKBUILD
+++ b/user/apaste/APKBUILD
@@ -19,6 +19,8 @@ source="
apasted.confd
apasted.initd
"
+pkggroups="apasted"
+pkgusers="apastedlog apasted"
build() {
./configure \
@@ -34,13 +36,17 @@ build() {
_makeservicedir() {
name="apaste${1}d-${2}"
fn="$subpkgdir/var/lib/apasted/services/$name"
- mkdir -p -m 0755 "$fn/log"
+ mkdir -p "$fn/log"
echo 3 > "$fn/log/notification-fd"
sed -e "s/@S@/${1}/g; s/@V@/${2}/g;" "$srcdir/apasted-log.run" > "$fn/log/run"
chmod 0755 "$fn/log/run"
echo 3 > "$fn/notification-fd"
sed -e "s/@V@/${2}/g;" "$srcdir/apaste${1}d.run" > "$fn/run"
chmod 0755 "$fn/run"
+ fn="$subpkgdir/var/log/$name"
+ mkdir -p "$fn"
+ chown apastedlog:apasted "$fn"
+ chmod 02700 "$fn"
}
package() {
@@ -54,8 +60,8 @@ package() {
server() {
depends="execline s6 s6-networking>=2.7.0.2 apasted-openrc"
pkgdesc="A server for the apaste command-line pastebin"
- install="apasted.pre-install apasted.post-install"
- mkdir -p -m 0755 "$subpkgdir/usr/bin" "$subpkgdir/var/lib/apasted/services"
+ install="apasted.pre-install"
+ mkdir -p "$subpkgdir/usr/bin" "$subpkgdir/var/lib/apasted/services"
mv "$pkgdir/usr/bin/apasted" "$subpkgdir/usr/bin/"
for i in '' s ; do for j in 4 6 ; do
_makeservicedir "$i" "$j"
@@ -63,9 +69,9 @@ server() {
}
apasted_openrc() {
- default_openrc
- pkgdesc="A server for the apaste command-line pastebin (OpenRC init scripts)"
- install_if="openrc apasted=$pkgver-r$pkgrel"
+ depends="apasted"
+ install -D -m 0644 "$srcdir/apasted.confd" "$subpkgdir/etc/conf.d/apasted"
+ install -D -m 0755 "$srcdir/apasted.initd" "$subpkgdir/etc/init.d/apasted"
}
sha512sums="b1550d738801ddee528d0ce62333aa9a8fc9824183a61be295e767fbcdb1ae4d15a5e34295754cc5e8c51c8b410a56972bac28c5812099652fb8bb5140fb4c15 apaste-0.0.2.0.tar.gz
@@ -73,4 +79,4 @@ sha512sums="b1550d738801ddee528d0ce62333aa9a8fc9824183a61be295e767fbcdb1ae4d15a5
8cd74ba6c6579912083f9605056b46ca2887faaf23a0d1981043a5ac4d6e724def51a7c087fb719f2b0189e6b0a0d9469a1e955fcbf04c8ea9f2d818649c122e apastesd.run
9341c1c69c1d45b35052b0042665fffb9cff6583fad558ed37a19af574b53a5e298727c43a6c718fd40936e8f16d1a10e9c229392595ba1e06ddb21d1d8b055b apasted-log.run
3b91225252d95d676097d337ca77ef2bdffb52baa657197efe079b82c663baeaed0882993eeed7f7ce260f051e439159c61368f8a1d4b84d1daa74fe358c39d7 apasted.confd
-da909cfc4aaa6571dda2fa0e4713e61c1b7f18ca35907ce4d0e3aa639596c69d801d6369b43ce67b20aa8d8a4050f46d98823b6158f80170866263b7b7a79e5b apasted.initd"
+f9e6dd5aa6d5efe678f370431e7b58a52f903eed9b698f60b1853d601a4d9c0a53ccb996034d401dfd7ddbe573fc2651cf5c87164de599c42f754ad015b8e302 apasted.initd"
diff --git a/user/apaste/apasted.initd b/user/apaste/apasted.initd
index 106c2b11a..f730f8012 100644
--- a/user/apaste/apasted.initd
+++ b/user/apaste/apasted.initd
@@ -4,13 +4,12 @@ description="Start/stop the apasted services"
depend()
{
- after net
- after localmount
+ after net
+ after localmount
}
_get_services()
{
- . /etc/conf.d/apasted
list=
if test -n "$APASTED_PORT" ; then
if test -n "$APASTED_IPv4" ; then
diff --git a/user/apaste/apasted.post-install b/user/apaste/apasted.post-install
deleted file mode 100644
index aba532a62..000000000
--- a/user/apaste/apasted.post-install
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh -e
-
-mkdir -p -m 0755 /var/log
-list="/var/log/apasted-4 /var/log/apasted-6 /var/log/apastesd-4 /var/log/apastesd-6"
-mkdir -p -m 0755 $list
-chown apastedlog:apasted $list
-chmod 02755 $list
diff --git a/user/apaste/apasted.pre-install b/user/apaste/apasted.pre-install
index 32782d21f..27c1c1880 100644
--- a/user/apaste/apasted.pre-install
+++ b/user/apaste/apasted.pre-install
@@ -1,7 +1,7 @@
#!/bin/sh
-addgroup -S apasted 2>/dev/null
-adduser -S -D -h / -H -s /sbin/nologin -G apasted -g apastedlog apastedlog 2>/dev/null
-adduser -S -D -h / -H -s /sbin/nologin -G apasted -g apasted apasted 2>/dev/null
+groupadd -r -- apasted 2>/dev/null
+useradd -r -d / -M -N -s /sbin/nologin -g apasted -c apastedlog -- apastedlog 2>/dev/null
+useradd -r -d / -M -N -s /sbin/nologin -g apasted -c apasted -- apasted 2>/dev/null
exit 0