summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/livecd-support/APKBUILD10
-rw-r--r--user/livecd-support/horizon-ui8
2 files changed, 15 insertions, 3 deletions
diff --git a/user/livecd-support/APKBUILD b/user/livecd-support/APKBUILD
index ed97cded0..85fca324e 100644
--- a/user/livecd-support/APKBUILD
+++ b/user/livecd-support/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Support files for booting Adélie live media"
url="https://www.adelielinux.org/"
arch="noarch"
-options="!check" # Metapackage
+options="!check suid" # Metapackage
license="NCSA"
subpackages="$pkgname-kde $pkgname-lxqt $pkgname-mate $pkgname-horizon"
depends=""
@@ -14,6 +14,7 @@ install="livecd-support.post-install livecd-support.post-deinstall"
source="kde.sddm.conf
lxqt.sddm.conf
mate.sddm.conf
+ horizon-ui
"
package() {
@@ -24,6 +25,8 @@ horizon() {
pkgdesc="Add the ability to install Adélie from live media"
depends="horizon-qt5 horizon netsurf partitionmanager xterm"
+ install -D -m4755 "$srcdir"/horizon-ui "$subpkgdir"/usr/sbin/horizon-ui
+
mkdir -p "$subpkgdir"/usr/share/applications
cat >"$subpkgdir"/usr/share/applications/horizon.desktop <<DESKTOP
[Desktop Entry]
@@ -32,7 +35,7 @@ Version=1.1
Name=System Installation
Comment=Install Adélie Linux to your computer
Icon=system-software-install
-Exec=/usr/bin/horizon-qt5
+Exec=/usr/sbin/horizon-ui
Categories=System;
DESKTOP
}
@@ -58,4 +61,5 @@ mate() {
sha512sums="eddcc68917b4dc376bb9b7e7ed5e2c06379957c787c7152e654f31adb402f5811463bff69ce2a41a2cb87b0fa83a4aa3718b63d830eb9ee46b7d0d2058663d34 kde.sddm.conf
9a9a61035c0a8c5ee84d235f319ca158216056221d03a0f5a3846982cb6110c569d7b4eadd2e24de66a75a428c18850e0393e20412e0edcfc8ad41c9d4783604 lxqt.sddm.conf
-603d2a5b1fdad0cb0abfefa8a4019c690ee4f5f9ac45057eeeac3bac3207e7871bdb32a564791fb99d965959b39a7de979d575db2694c2d1d88a4a16b68adb25 mate.sddm.conf"
+603d2a5b1fdad0cb0abfefa8a4019c690ee4f5f9ac45057eeeac3bac3207e7871bdb32a564791fb99d965959b39a7de979d575db2694c2d1d88a4a16b68adb25 mate.sddm.conf
+b6d39b2feb0aa400ac7013d6b8c9080ab00ffc1c8b40dbf9489df999fe08b86aebd878c84d968a53ad29bc2a2c30209d8c6ff5daa4171aab03d5b921f966e08d horizon-ui"
diff --git a/user/livecd-support/horizon-ui b/user/livecd-support/horizon-ui
new file mode 100644
index 000000000..e984e9476
--- /dev/null
+++ b/user/livecd-support/horizon-ui
@@ -0,0 +1,8 @@
+#!/bin/sh
+#
+# Welcome to Adélie Linux.
+# This script allows you to run Horizon as the live user.
+#
+
+horizon-qt5
+if [ $? -eq 0 ]; then horizon-run-qt5; fi