summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/libfm/APKBUILD4
-rw-r--r--user/libfreehand/APKBUILD14
-rw-r--r--user/libfreehand/icu.patch11
-rw-r--r--user/pcmanfm/APKBUILD4
-rw-r--r--user/sdl_mixer/APKBUILD10
-rw-r--r--user/thunar-volman/APKBUILD1
-rw-r--r--user/thunar/APKBUILD1
-rw-r--r--user/wpa_supplicant/APKBUILD4
-rw-r--r--user/xfburn/APKBUILD5
-rw-r--r--user/xfce-desktop/APKBUILD10
-rw-r--r--user/xfce4-terminal/APKBUILD3
-rw-r--r--user/xfdesktop/APKBUILD1
12 files changed, 40 insertions, 28 deletions
diff --git a/user/libfm/APKBUILD b/user/libfm/APKBUILD
index bddbf32f2..a32925320 100644
--- a/user/libfm/APKBUILD
+++ b/user/libfm/APKBUILD
@@ -8,6 +8,7 @@ url="https://wiki.lxde.org/en/PCManFM"
arch="all"
license="GPL-2.0+"
depends=""
+depends_dev="libfm-extra-dev"
makedepends="dbus-glib-dev glib-dev gtk+2.0-dev intltool libexif-dev
libfm-extra-dev menu-cache-dev udisks2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -31,6 +32,9 @@ check() {
package() {
make DESTDIR="$pkgdir" install
+ # this symlink breaks installation with -extra-dev,
+ # and extra is always required anyway
+ rm "$pkgdir"/usr/include/libfm
}
sha512sums="f385cf7bf2f4800c11dd6474cd20009cbe1208f1d08570b61954ea8bd84c56cc49880cbf84d4b2aa4b91eb6929d017ebc427649391059b786d7e6fc4535e4f14 libfm-1.3.1.tar.xz
diff --git a/user/libfreehand/APKBUILD b/user/libfreehand/APKBUILD
index b8371ac74..fc9354ab4 100644
--- a/user/libfreehand/APKBUILD
+++ b/user/libfreehand/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libfreehand
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Import filter and tools for Adobe FreeHand documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
arch="all"
license="MPL-2.0 AND Public-Domain"
depends=""
depends_dev="libxml2-dev lcms2-dev icu-dev"
-makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
checkdepends="cppunit-dev"
+makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz
+ icu.patch
+ "
prepare() {
default_prepare
@@ -20,7 +22,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -48,4 +47,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz"
+sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz
+5c72ee92e1b617dd0ece1a17e84c4b063454811aae484a08d2e15a29c6561068d0127222656647bd0ac05afde8c5c2154d382b4289b86e1956bf173ed4694a76 icu.patch"
diff --git a/user/libfreehand/icu.patch b/user/libfreehand/icu.patch
new file mode 100644
index 000000000..22d118cca
--- /dev/null
+++ b/user/libfreehand/icu.patch
@@ -0,0 +1,11 @@
+--- libfreehand-0.1.2/src/lib/libfreehand_utils.cpp.old 2017-09-16 10:28:50.000000000 +0000
++++ libfreehand-0.1.2/src/lib/libfreehand_utils.cpp 2020-01-12 04:40:38.492246789 +0000
+@@ -162,7 +162,7 @@
+ while (j < length)
+ {
+ UChar32 c;
+- U16_NEXT(s, j, length, c)
++ U16_NEXT(s, j, length, c);
+ unsigned char outbuf[U8_MAX_LENGTH+1];
+ int i = 0;
+ U8_APPEND_UNSAFE(&outbuf[0], i, c);
diff --git a/user/pcmanfm/APKBUILD b/user/pcmanfm/APKBUILD
index cd4cc7daf..806d8b65d 100644
--- a/user/pcmanfm/APKBUILD
+++ b/user/pcmanfm/APKBUILD
@@ -7,12 +7,12 @@ pkgdesc="GTK-based file manager"
url="https://sourceforge.net/projects/pcmanfm/"
arch="all"
license="GPL-2.0+"
+depends=""
makedepends="intltool gtk+2.0-dev libfm-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://downloads.sourceforge.net/pcmanfm/pcmanfm-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/sdl_mixer/APKBUILD b/user/sdl_mixer/APKBUILD
index 2cdb8238e..05972034e 100644
--- a/user/sdl_mixer/APKBUILD
+++ b/user/sdl_mixer/APKBUILD
@@ -9,13 +9,13 @@ arch="all"
options="!check" # No test suite.
license="Zlib"
depends=""
-makedepends="flac-dev fluidsynth-dev libvorbis-dev linux-headers sdl-dev"
+makedepends="bash flac-dev fluidsynth-dev libvorbis-dev linux-headers sdl-dev"
subpackages="$pkgname-dev"
source="https://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${pkgver}.tar.gz"
builddir="$srcdir"/SDL_mixer-$pkgver
prepare() {
- cd "$builddir"
+ default_prepare
update_config_sub
sed -e "/CONFIG_FILE_ETC/s/\/etc\/timidity.cfg/\/etc\/timidity++\/timidity.cfg/" \
-e "/DEFAULT_PATH/s/\/etc\/timidity/\/etc\/timidity++/" \
@@ -24,20 +24,18 @@ prepare() {
}
build() {
- cd "$builddir"
- ./configure \
+ bash ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --enable-music-mod
+ --enable-music-mod SHELL=/bin/bash
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/thunar-volman/APKBUILD b/user/thunar-volman/APKBUILD
index 036c50b31..bfbc5a1ce 100644
--- a/user/thunar-volman/APKBUILD
+++ b/user/thunar-volman/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Volume manager for Thunar"
url="https://xfce.org"
arch="all"
license="GPL-2.0+"
+depends=""
makedepends="exo-dev intltool libgudev-dev libnotify-dev libxfce4ui-dev
thunar-dev"
subpackages="$pkgname-lang"
diff --git a/user/thunar/APKBUILD b/user/thunar/APKBUILD
index 014ab3ae8..d958f69da 100644
--- a/user/thunar/APKBUILD
+++ b/user/thunar/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="File manager for the XFCE desktop environment"
url="https://xfce.org"
arch="all"
license="LGPL-2.0+ AND GPL-2.0+"
+depends=""
makedepends="intltool gtk+3.0-dev exo-dev libxfce4ui-dev vala-dev
gobject-introspection-dev libsm-dev libgudev-dev libnotify-dev
libexif-dev"
diff --git a/user/wpa_supplicant/APKBUILD b/user/wpa_supplicant/APKBUILD
index dbd22b8c7..c4ae69a6e 100644
--- a/user/wpa_supplicant/APKBUILD
+++ b/user/wpa_supplicant/APKBUILD
@@ -6,11 +6,11 @@ pkgrel=1
pkgdesc="Utility providing key negotiation for WPA wireless networks"
url="https://w1.fi/wpa_supplicant/"
arch="all"
+options="!check" # No test suite.
license="BSD-3-Clause AND Public-Domain AND (GPL-2.0+ OR BSD-3-Clause)"
-options="!check" # No test suite
-subpackages="$pkgname-dbus::noarch $pkgname-doc $pkgname-openrc wpa_gui"
depends=""
makedepends="linux-headers openssl-dev dbus-dev libnl3-dev qt5-qtbase-dev"
+subpackages="$pkgname-dbus::noarch $pkgname-doc $pkgname-openrc wpa_gui"
source="https://w1.fi/releases/$pkgname-$pkgver.tar.gz
wpa_supplicant.initd
wpa_supplicant.confd
diff --git a/user/xfburn/APKBUILD b/user/xfburn/APKBUILD
index 0dd528edd..66e869a55 100644
--- a/user/xfburn/APKBUILD
+++ b/user/xfburn/APKBUILD
@@ -7,13 +7,14 @@ pkgdesc="CD burning utility for the XFCE desktop environment"
url="https://xfce.org"
arch="all"
license="GPL-2.0+"
-makedepends="intltool libburn-dev libisofs-dev gtk+3.0-dev gtk+2.0-dev
+depends=""
+makedepends="bash intltool libburn-dev libisofs-dev gtk+3.0-dev gtk+2.0-dev
libxfce4ui-dev exo-dev libgudev-dev gstreamer-dev gst-plugins-base-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://archive.xfce.org/src/apps/xfburn/${pkgver%.*}/xfburn-$pkgver.tar.bz2"
build() {
- LIBS="-lintl" ./configure \
+ LIBS="-lintl" bash ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
diff --git a/user/xfce-desktop/APKBUILD b/user/xfce-desktop/APKBUILD
index 122ea66b2..035c79a18 100644
--- a/user/xfce-desktop/APKBUILD
+++ b/user/xfce-desktop/APKBUILD
@@ -6,23 +6,19 @@ pkgrel=0
arch="noarch"
pkgdesc="Complete XFCE desktop environment"
url="https://xfce.org"
+options="!check" # meta package, no tests needed.
license="NCSA"
-options="!check" # meta package, no tests needed.
depends="xfburn xfce4-power-manager xfce4-settings xfce4-volumed-pulse
xfdesktop xfce4-appfinder xfce4-panel xfce4-screenshooter
xfce4-taskmanager xfconf xfce4-dict xfce4-panel-profiles
xfce4-session xfdashboard xfmpc xfwm4 xfce4-terminal
xfce4-notifyd"
+makedepends=""
source="org.adelie-linux.about-xfce.desktop"
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$srcdir"
-}
package() {
- cd "$srcdir"
install -D -m644 "$srcdir"/org.adelie-linux.about-xfce.desktop \
"$pkgdir"/usr/share/applications/org.adelie-linux.about-xfce.desktop
}
+
sha512sums="362793e478e3fb0c6d7dca1f52f582a641ff4582ad0c0d6d1cbe28f1255fc6cd7918ea6b24a5d905a59275f67c44703bf8c78580642c4e0147b539842a6f372f org.adelie-linux.about-xfce.desktop"
diff --git a/user/xfce4-terminal/APKBUILD b/user/xfce4-terminal/APKBUILD
index fb16a6693..809774459 100644
--- a/user/xfce4-terminal/APKBUILD
+++ b/user/xfce4-terminal/APKBUILD
@@ -7,7 +7,8 @@ pkgdesc="Terminal for the XFCE desktop environment"
url="https://xfce.org"
arch="all"
license="GPL-2.0+"
-makedepends="intltool gtk+3.0-dev vte-dev libxfce4ui-dev"
+depends=""
+makedepends="intltool gtk+3.0-dev vte-dev libxfce4ui-dev pcre2-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://archive.xfce.org/src/apps/xfce4-terminal/0.8/xfce4-terminal-$pkgver.tar.bz2"
diff --git a/user/xfdesktop/APKBUILD b/user/xfdesktop/APKBUILD
index 03c23058a..cb4507523 100644
--- a/user/xfdesktop/APKBUILD
+++ b/user/xfdesktop/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Desktop manager for the XFCE desktop environment"
url="https://xfce.org"
arch="all"
license="GPL-2.0+"
+depends=""
makedepends="intltool gtk+3.0-dev libxfce4util-dev libxfce4ui-dev libwnck-dev
exo-dev garcon-dev libnotify-dev thunar-dev"
subpackages="$pkgname-doc $pkgname-lang"