summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/abuild/APKBUILD12
-rw-r--r--system/abuild/inode.patch30
-rw-r--r--system/abuild/libarchive.patch41
-rw-r--r--system/abuild/noarch.patch31
4 files changed, 19 insertions, 95 deletions
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 6c16562e1..e92435f73 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abuild
-pkgver=3.4.2
-pkgrel=3
+pkgver=3.5
+pkgrel=0
pkgdesc="Script to build APK packages"
url="https://git.adelielinux.org/adelie/abuild"
arch="all"
@@ -19,9 +19,7 @@ makedepends="$makedepends_host $makedepends_build"
subpackages="abuild-rootbld:_rootbld:noarch $pkgname-doc"
install="$pkgname.pre-install $pkgname.pre-upgrade"
source="https://distfiles.adelielinux.org/source/abuild-$pkgver.tar.xz
- inode.patch
keyhole.patch
- libarchive.patch
noarch.patch
"
@@ -56,8 +54,6 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="9bdeb31f54879878697b4a5436ec2bc7764e1b9840798e913ba3dd47c344437e362a3067b89440ca8a7940af1efcaa83a24e7c1077187f924bf73fb058f97fbf abuild-3.4.2.tar.xz
-53b0f2c15da767fbdde5a28b6f428943907e8752490ffae580e4a4198fea76fd71fc253a526c81bbbf17311ce3c72a563649a416ea0fda219a35cee50fcd46d1 inode.patch
+sha512sums="50e6ad1dfb033688a4a06bbb313db6bb90c0a2e7c47dbab30c1cd7f30520b782fdfd113babed8796104c415f096071a49feb8ab9e71286889d0ac79bb4acc039 abuild-3.5.tar.xz
757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch
-2452a2b2ecf64bb6bfef1e71c35d39f02be1a5930ebd3e4c139156979b6c2249adcd4437c5c49f4af5b478f2a69529807fcbcd31ca01e6be6430165bcad74353 libarchive.patch
-5ba235c3f3c3c5cf8c8973ea8cc3fdf97364b5bb69c6e60b8738c3f0cf585868bcf77a0b05ff1a49879eec1ad5c37f28f5fe28f883643a44b3ba6c543616bbe7 noarch.patch"
+06542b3baca0a52d0a74c32683738ebe4bfc5c7c3fef867b3cbed5767cd4c5e1517a2174934320bd4184894f3462538a77ae2f4641dff8530c29a6fa0e8184a0 noarch.patch"
diff --git a/system/abuild/inode.patch b/system/abuild/inode.patch
deleted file mode 100644
index a3a7cef09..000000000
--- a/system/abuild/inode.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9969ec002c408b616714a99a6317c7f996965dd4 Mon Sep 17 00:00:00 2001
-From: Samuel Holland <samuel@sholland.org>
-Date: Wed, 19 Jan 2022 02:35:19 -0600
-Subject: [PATCH] abuild: Correctly package files that fit in inode
-
-On filesystems such as XFS, abuild will skip small files and symlinks
-because the file fits in an inode and shows a size of 0.
-
-Signed-off-by: A. Wilcox <AWilcox@Wilcox-Tech.com>
-Acked-by: Zach van Rijn <me@zv.io>
----
- abuild.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/abuild.in b/abuild.in
-index 6bb087a..3e83563 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -927,7 +927,7 @@ prepare_metafiles() {
- sync;;
- esac
-
-- local size="$(du -sk | awk '{print $1 * 1024}')"
-+ local size="$(du -sk --apparent-size | awk '{print $1 * 1024}')"
-
- if [ "$arch" != "$apkbuild_arch" ]; then
- local msg="Split function set arch=\"$arch\" for $name, use subpackages=pkg:split:arch format instead"
---
-2.32.0 (Apple Git-132)
-
diff --git a/system/abuild/libarchive.patch b/system/abuild/libarchive.patch
deleted file mode 100644
index 7f0132971..000000000
--- a/system/abuild/libarchive.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 70943ead0e226e2db81f20867b11144e449b12c6 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sun, 20 Feb 2022 22:38:17 -0600
-Subject: [PATCH] abuild: Fix package building with libarchive >=3.6
-
-Now that we have sparse file support, libarchive wants to use it.
-
-APK doesn't support sparse file entries in tar files, so it fails to
-install any package made in this manner.
----
- abuild.in | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index 3e83563..b0c0f9c 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -1503,7 +1503,9 @@ create_apks() {
- touch .dummy
- set -- .dummy
- fi
-- tar --format pax --xattrs -f - -c "$@" | abuild-tar --hash | $gzip -9 >"$dir"/data.tar.gz
-+ tar --no-read-sparse --format pax --xattrs -f - -c "$@" \
-+ | abuild-tar --hash \
-+ | $gzip -9 >"$dir"/data.tar.gz
-
- msg "Create checksum..."
- # append the hash for data.tar.gz
-@@ -1512,7 +1514,8 @@ create_apks() {
-
- # control.tar.gz
- cd "$dir"
-- tar --format pax -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
-+ tar --no-read-sparse --format pax -f - -c $(cat "$dir"/.metafiles) \
-+ | abuild-tar --cut \
- | $gzip -9 > control.tar.gz
- abuild-sign -q control.tar.gz || exit 1
-
---
-2.32.0 (Apple Git-132)
-
diff --git a/system/abuild/noarch.patch b/system/abuild/noarch.patch
index 8c61d32a6..d6e59d4db 100644
--- a/system/abuild/noarch.patch
+++ b/system/abuild/noarch.patch
@@ -2,7 +2,7 @@ diff --git a/abuild.in b/abuild.in
index b0c0f9c..a6a0fe1 100644
--- a/abuild.in
+++ b/abuild.in
-@@ -516,7 +516,7 @@ cleanpkg() {
+@@ -518,7 +518,7 @@ cleanpkg() {
rm -f "$REPODEST/$repo/src/$pkgname-$pkgver-r$pkgrel.src.tar.gz"
for i in $allpackages; do
subpkg_set "$i"
@@ -11,7 +11,7 @@ index b0c0f9c..a6a0fe1 100644
rm -f "$REPODEST/$repo/$subpkgarch/$subpkgname-$pkgver-r$pkgrel.apk"
done
subpkg_unset
-@@ -931,7 +931,7 @@ prepare_metafiles() {
+@@ -943,7 +943,7 @@ prepare_metafiles() {
if [ "$arch" != "$apkbuild_arch" ]; then
local msg="Split function set arch=\"$arch\" for $name, use subpackages=pkg:split:arch format instead"
@@ -20,7 +20,7 @@ index b0c0f9c..a6a0fe1 100644
warning "$msg"
subpkgarch="$arch"
fi
-@@ -1027,7 +1027,7 @@ prepare_metafiles() {
+@@ -1039,7 +1039,7 @@ prepare_metafiles() {
prepare_trace_rpaths() {
local dir="${subpkgdir:-$pkgdir}"
local etype= soname= file= sover=
@@ -29,7 +29,7 @@ index b0c0f9c..a6a0fe1 100644
options_has "!tracedeps" && return 0
# lets tell all the places we should look for .so files - all rpaths
scanelf --quiet --recursive --rpath "$dir" \
-@@ -1115,10 +1115,10 @@ is_openrc_pkg() {
+@@ -1137,10 +1137,10 @@ is_openrc_pkg() {
archcheck() {
options_has "!archcheck" && return 0
if dir_has_arch_binaries "${subpkgdir:-$pkgdir}"; then
@@ -42,7 +42,7 @@ index b0c0f9c..a6a0fe1 100644
# we dont want -dev package go to noarch
warning "No arch specific binaries found so arch should probably be set to \"noarch\""
fi
-@@ -1317,7 +1317,7 @@ scan_shared_objects() {
+@@ -1339,7 +1339,7 @@ scan_shared_objects() {
local name="$1" controldir="$2" datadir="$3"
local opt= i=
@@ -51,7 +51,7 @@ index b0c0f9c..a6a0fe1 100644
return 0
fi
-@@ -1520,7 +1520,7 @@ create_apks() {
+@@ -1542,7 +1542,7 @@ create_apks() {
abuild-sign -q control.tar.gz || exit 1
msg "Create $apk"
@@ -60,7 +60,7 @@ index b0c0f9c..a6a0fe1 100644
mkdir -p "$REPODEST"/$repo/$subpkgarch
cat control.tar.gz data.tar.gz > "$REPODEST"/$repo/$subpkgarch/$apk
)
-@@ -1562,7 +1562,7 @@ update_abuildrepo_index() {
+@@ -1590,7 +1590,7 @@ update_abuildrepo_index() {
# thinks they are for $CARCH and apk-tools will fetch them from
# correct URL path. Remainder of the script uses ${subpkgarch/noarch/$CARCH}
# when expanding to the target repository path.
@@ -69,7 +69,7 @@ index b0c0f9c..a6a0fe1 100644
list_has "$subpkgarch" "$allarch" || allarch="$allarch $subpkgarch"
done
subpkg_unset
-@@ -1856,7 +1856,7 @@ apk_up2date() {
+@@ -1936,7 +1936,7 @@ apk_up2date() {
local i s
for i in $allpackages; do
subpkg_set "$i"
@@ -78,7 +78,7 @@ index b0c0f9c..a6a0fe1 100644
if [ ! -f "$REPODEST/$repo/$subpkgarch/$subpkgname-$pkgver-r$pkgrel.apk" ]; then
subpkg_unset
return 1
-@@ -1872,7 +1872,7 @@ apk_up2date() {
+@@ -1952,7 +1952,7 @@ apk_up2date() {
else
s="$startdir/${i##*/}"
fi
@@ -87,7 +87,7 @@ index b0c0f9c..a6a0fe1 100644
if [ "$s" -nt "$REPODEST/$repo/$pkgarch/$pkgname-$pkgver-r$pkgrel.apk" ]; then
return 1
fi
-@@ -1886,7 +1886,7 @@ abuildindex_up2date() {
+@@ -1966,7 +1966,7 @@ abuildindex_up2date() {
for i in $allpackages; do
subpkg_set "$i"
@@ -96,7 +96,7 @@ index b0c0f9c..a6a0fe1 100644
local dir="$REPODEST"/$repo/$subpkgarch
local idx="$dir"/APKINDEX.tar.gz
local file="$dir"/$subpkgname-$pkgver-r$pkgrel.apk
-@@ -2253,7 +2253,7 @@ rootbld() {
+@@ -2335,7 +2335,7 @@ rootbld() {
stripbin() {
local bin
@@ -105,12 +105,11 @@ index b0c0f9c..a6a0fe1 100644
return 0
fi
cd "${subpkgdir:-$pkgdir}" || return 1
-@@ -2597,7 +2597,7 @@ fi
- export REPODEST SRCDEST
+@@ -2679,7 +2679,7 @@ fi
+ fi
# add dbg subpackage if its enabled globally
--if [ -n "$DEFAULT_DBG" ] && ! subpackage_types_has "dbg" && ! options_has "!dbg" && [ "$arch" != "noarch" ]; then
-+if [ -n "$DEFAULT_DBG" ] && ! subpackage_types_has "dbg" && ! options_has "!dbg" && ! list_has noarch "$arch"; then
+-if [ -n "$DEFAULT_DBG" ] && ! subpackage_types_has "dbg" && ! options_has "!dbg" && [ "$pkgarch" != "noarch" ]; then
++if [ -n "$DEFAULT_DBG" ] && ! subpackage_types_has "dbg" && ! options_has "!dbg" && ! list_has noarch "$pkgarch"; then
subpackages="$pkgname-dbg $subpackages"
fi
-