summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/binutils/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 06f7c4cb6..f6545f7d0 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -40,7 +40,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
if [ "$CHOST" != "$CTARGET" ]; then
pkgname="$pkgname-$CTARGET_ARCH"
subpackages=""
- options="!check"
+ options="!check textrels !tracedeps"
sonameprefix="$pkgname:"
builddir="$srcdir"/binutils-$pkgver
fi
@@ -75,7 +75,7 @@ build() {
if [ "$CHOST" != "$CTARGET" ]; then
_sysroot="$CBUILDROOT"
- _cross_configure="--disable-install-libiberty"
+ _cross_configure="--disable-install-libiberty --disable-nls --disable-shared"
fi
# -z separate-code is currently causing kernel miscompiles on x86*