summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/gtk-layer-shell/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/gtk-layer-shell/APKBUILD b/user/gtk-layer-shell/APKBUILD
new file mode 100644
index 000000000..73697060b
--- /dev/null
+++ b/user/gtk-layer-shell/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=gtk-layer-shell
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="A library to create panels and other desktop components for Wayland using the Layer Shell protocol"
+url=" "
+arch="all"
+license="LGPL-3.0+ AND MIT"
+depends=""
+makedepends="gobject-introspection-dev gtk+3.0-dev gtk-doc meson python3
+ vala-dev wayland-dev wayland-protocols"
+subpackages="$pkgname-dev $pkgname-doc"
+source="gtk-layer-shell-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ meson setup \
+ -Dprefix=/usr \
+ -Ddocs=true \
+ -Dtests=true \
+ -Dvapi=true \
+ build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+sha512sums="38179dd83a0828740ca8e2cc27fe3708f61107e88246644745da6c300da03ce04b17dd7117087946a68401a43176a599bdb98ed50936602d2b2540449c0e9066 gtk-layer-shell-0.9.0.tar.gz"