summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/libgcrypt/APKBUILD11
-rw-r--r--system/libgcrypt/missing-headers.patch13
2 files changed, 21 insertions, 3 deletions
diff --git a/system/libgcrypt/APKBUILD b/system/libgcrypt/APKBUILD
index 115b6a9f5..18f6c856c 100644
--- a/system/libgcrypt/APKBUILD
+++ b/system/libgcrypt/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libgcrypt
-pkgver=1.8.6
+pkgver=1.10.0
pkgrel=0
pkgdesc="GnuPG cryptography library"
url="https://www.gnupg.org"
@@ -9,9 +9,13 @@ license="LGPL-2.1+"
depends=""
makedepends="libgpg-error-dev texinfo"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.gnupg.org/ftp/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2"
+source="https://www.gnupg.org/ftp/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
+ missing-headers.patch
+ "
# secfixes:
+# 1.10.0-r0:
+# - CVE-2021-40528
# 1.8.5-r0:
# - CVE-2019-13627
@@ -49,4 +53,5 @@ package() {
rm -f ${pkgdir}/usr/share/info/dir
}
-sha512sums="28a26f665b7e327b79815849ee6e84ab384ee9105d81d4d06e4feeea07d986f940cbbb9faaae8712068cace45b4110a62965a93201da0e1ad008b65808b2b29b libgcrypt-1.8.6.tar.bz2"
+sha512sums="785c2e14272308956bb6adcea9567c4097edf103122e18cd3907fb42a110a48a5d59c0057f05a438acd7f221c70c7f7ff87e176bd6d7ed99d16e847f9d7be087 libgcrypt-1.10.0.tar.bz2
+0a4a1466bfb9415a1d1c016eab67872f9165f2f5aa90bbcc72b57fabb4996d54bdb39dbb15f01753395819dabacc536ac0936dc10b1d37b8e22d5db7a39bfed3 missing-headers.patch"
diff --git a/system/libgcrypt/missing-headers.patch b/system/libgcrypt/missing-headers.patch
new file mode 100644
index 000000000..ec0df3985
--- /dev/null
+++ b/system/libgcrypt/missing-headers.patch
@@ -0,0 +1,13 @@
+A similar fix to this is upstream for 1.10.1.
+
+--- libgcrypt-1.10.0/random/jitterentropy-base-user.h.old 2022-01-25 15:55:44.000000000 -0600
++++ libgcrypt-1.10.0/random/jitterentropy-base-user.h 2022-02-06 17:00:02.040000000 -0600
+@@ -54,6 +54,8 @@
+ # error This module needs stdint.h - try ./configure --disable-jent-support
+ #endif
+
++#include <fcntl.h>
++#include <limits.h>
+
+ /* When using the libgcrypt secure memory mechanism, all precautions
+ * are taken to protect our state. If the user disables secmem during