summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/inotify-tools/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/inotify-tools/APKBUILD b/user/inotify-tools/APKBUILD
new file mode 100644
index 000000000..86545ea28
--- /dev/null
+++ b/user/inotify-tools/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=inotify-tools
+pkgver=4.23.9.0
+pkgrel=0
+pkgdesc="C library and a command-line programs to interface with inotify"
+url="https://github.com/inotify-tools/inotify-tools"
+arch="all"
+license="GPL-2.0-only"
+makedepends="automake autoconf libtool"
+subpackages="$pkgname-dev $pkgname-libs $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/inotify-tools/inotify-tools/archive/$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ autoreconf -fiv
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8f44037a482fa39978b845b4989834e8c897ad872913c6cb8c4a987e0d13f9177b05f593332b859d7adde228fdc3512fd45d66cab65368c38926f41d57e22d13 inotify-tools-4.23.9.0.tar.gz"