summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/ant/APKBUILD6
-rw-r--r--user/fontforge/APKBUILD5
-rw-r--r--user/oxygen-fonts/APKBUILD7
-rw-r--r--user/scummvm/APKBUILD9
-rw-r--r--user/scummvm/fluidsynth.patch37
-rw-r--r--user/wine/APKBUILD17
6 files changed, 52 insertions, 29 deletions
diff --git a/user/ant/APKBUILD b/user/ant/APKBUILD
index 8afaf5929..ea5d40f04 100644
--- a/user/ant/APKBUILD
+++ b/user/ant/APKBUILD
@@ -9,12 +9,14 @@ pkgdesc="Java-based build tool"
url="http://ant.apache.org/"
arch="noarch"
license="Apache-2.0"
-makedepends=""
depends="openjdk8"
+makedepends=""
+subpackages=""
source="https://www-eu.apache.org/dist/ant/source/apache-$pkgname-$pkgver-src.tar.gz
ant.sh
imageio_fix_java_test.patch
- imageio_fix_test.patch"
+ imageio_fix_test.patch
+ "
builddir="$srcdir/apache-$pkgname-$pkgver"
_anthome="/usr/lib/java/$pkgname"
diff --git a/user/fontforge/APKBUILD b/user/fontforge/APKBUILD
index 949fb702c..2566d470c 100644
--- a/user/fontforge/APKBUILD
+++ b/user/fontforge/APKBUILD
@@ -8,7 +8,7 @@ url="https://fontforge.github.io/en-US/"
arch="all"
license="GPL-3.0+ AND BSD-3-Clause"
depends="desktop-file-utils shared-mime-info"
-makedepends="freetype-dev giflib-dev glib-dev libjpeg-turbo-dev
+makedepends="freetype-dev giflib-dev glib-dev libjpeg-turbo-dev libtool
libuninameslist-dev libpng-dev libx11-dev libxml2-dev pango-dev
python3-dev tiff-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -17,7 +17,6 @@ source="https://github.com/fontforge/fontforge/releases/download/${pkgver/2.0./}
"
build() {
- cd "$builddir"
PYTHON=python3 ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,13 +28,11 @@ build() {
}
check() {
- cd "$builddir"
# skip test 53; it doesn't work.
make check TESTSUITEFLAGS="1-52 54"
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/oxygen-fonts/APKBUILD b/user/oxygen-fonts/APKBUILD
index 152a0aae4..bf4202efb 100644
--- a/user/oxygen-fonts/APKBUILD
+++ b/user/oxygen-fonts/APKBUILD
@@ -10,10 +10,9 @@ license="OFL-1.1"
depends=""
makedepends="cmake extra-cmake-modules qt5-qtbase-dev fontforge-dev"
subpackages=""
-source="http://download.kde.org/stable/plasma/$pkgver/oxygen-fonts-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/oxygen-fonts-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -24,17 +23,15 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/scummvm/APKBUILD b/user/scummvm/APKBUILD
index 129c202b5..e9b6b2074 100644
--- a/user/scummvm/APKBUILD
+++ b/user/scummvm/APKBUILD
@@ -13,10 +13,11 @@ makedepends="alsa-lib-dev curl-dev flac-dev fluidsynth-dev freetype-dev
libjpeg-turbo-dev libmpeg2-dev libogg-dev libpng-dev libvorbis-dev
sdl-dev zlib-dev"
subpackages="$pkgname-doc"
-source="https://www.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.bz2"
+source="https://www.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.bz2
+ fluidsynth.patch
+ "
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--disable-readline
@@ -24,8 +25,8 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="5f91a65cdde62e6f996ae8a983d212f3d04edcf1ce3ab0e5273f1dfce155724912f386025959f5b2cc6ba566432845d929503f80f0cee513c774d5e04dafde1f scummvm-2.1.0.tar.bz2"
+sha512sums="5f91a65cdde62e6f996ae8a983d212f3d04edcf1ce3ab0e5273f1dfce155724912f386025959f5b2cc6ba566432845d929503f80f0cee513c774d5e04dafde1f scummvm-2.1.0.tar.bz2
+20b20a68263c691efb7db83aa8132ec980f2732af728300a641d30c4035d4aa8fcf6efdcebb8c5b924e68fafb50e39ed1825cd64d1f81145259493e858bd50f4 fluidsynth.patch"
diff --git a/user/scummvm/fluidsynth.patch b/user/scummvm/fluidsynth.patch
new file mode 100644
index 000000000..a815cc705
--- /dev/null
+++ b/user/scummvm/fluidsynth.patch
@@ -0,0 +1,37 @@
+Backport of upstream commits:
+
+* 8593a9e
+* 68758a8
+* 8014f12
+
+--- scummvm-2.1.0/audio/softsynth/fluidsynth.cpp.old 2019-10-04 21:41:29.000000000 +0000
++++ scummvm-2.1.0/audio/softsynth/fluidsynth.cpp 2020-01-13 08:21:46.705102910 +0000
+@@ -20,10 +20,18 @@
+ *
+ */
+
+-#include "common/scummsys.h"
++#if defined(HAVE_CONFIG_H)
++#include "config.h"
++#endif
+
+ #ifdef USE_FLUIDSYNTH
+
++// Fluidsynth v2.1+ uses printf in one of it's headers,
++// include/fluidsynth/log.h around line 82 so need to include this
++// prior scummsys.h inclusion and thus forbidden.h
++#include <fluidsynth.h>
++
++#include "common/scummsys.h"
+ #include "common/config-manager.h"
+ #include "common/error.h"
+ #include "common/system.h"
+@@ -35,8 +43,6 @@
+ #include "backends/platform/ios7/ios7_common.h"
+ #endif
+
+-#include <fluidsynth.h>
+-
+ class MidiDriver_FluidSynth : public MidiDriver_Emulated {
+ private:
+ MidiChannel_MPU401 _midiChannels[16];
diff --git a/user/wine/APKBUILD b/user/wine/APKBUILD
index ea9384603..ef31fa802 100644
--- a/user/wine/APKBUILD
+++ b/user/wine/APKBUILD
@@ -21,22 +21,18 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
cups-dev alsa-lib-dev libxml2-dev dbus-dev libxi-dev
gnutls-dev tiff-dev v4l-utils-dev udisks2-dev autoconf automake
openal-soft-dev pulseaudio-dev sane-dev eudev-dev mpg123-dev
- "
+ autoconf automake libtool"
source="http://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$pkgver.tar.xz
no-pie.patch
winhlp32-flex.patch
"
prepare() {
- cd "$builddir"
-
default_prepare
aclocal && autoheader && autoreconf
}
build() {
- cd "$builddir"
-
case "$CARCH" in
x86_64) _win64=--enable-win64;;
esac
@@ -70,13 +66,10 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- local file
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
case "$CARCH" in
@@ -88,21 +81,18 @@ package() {
"$pkgdir"/usr/bin/wineapploader
for file in msiexec notepad regedit regsvr32 wineboot \
- winecfg wineconsole winefile winemine winepath
- do
+ winecfg wineconsole winefile winemine winepath; do
rm "$pkgdir"/usr/bin/$file
ln -sf /usr/bin/wineapploader "$pkgdir"/usr/bin/$file
done
}
dev() {
- local file
default_dev
install -d "$subpkgdir"/usr/bin
for file in widl wmc wrc winebuild winedump function_grep.pl \
- winedbg winemaker winegcc winecpp wineg++
- do
+ winedbg winemaker winegcc winecpp wineg++; do
mv "$pkgdir"/usr/bin/$file "$subpkgdir"/usr/bin/
done
@@ -116,7 +106,6 @@ doc() {
}
libs() {
- local file ext
default_libs
install -d "$subpkgdir"/usr/lib/wine/fakedlls