summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/toot/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/user/toot/APKBUILD b/user/toot/APKBUILD
new file mode 100644
index 000000000..741afb8c3
--- /dev/null
+++ b/user/toot/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+pkgname=toot
+pkgver=0.26.0
+pkgrel=0
+pkgdesc="Python 3 curses-based client for Mastodon API"
+url="https://toot.readthedocs.io"
+arch="noarch"
+license="GPL-3.0-only"
+depends="python3 py3-beautifulsoup4 py3-requests"
+source="https://github.com/ihabunek/toot/releases/download/$pkgver/toot-$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c90cd81835ea60882d5e7db68ea7d69b5a3fe657b5b5c34c81daf4e5b672d66181cfb724e15e1a3eb12aad167584d82ba782b169ab294046979454de762a914c toot-0.26.0.tar.gz"