summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/doxygen/APKBUILD42
-rw-r--r--user/doxygen/doxygen-1.8.14-install.patch21
2 files changed, 63 insertions, 0 deletions
diff --git a/user/doxygen/APKBUILD b/user/doxygen/APKBUILD
new file mode 100644
index 000000000..382530d4c
--- /dev/null
+++ b/user/doxygen/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer:
+pkgname=doxygen
+pkgver=1.8.14
+pkgrel=0
+pkgdesc="A documentation system for C++, C, Java, IDL, and PHP"
+url="http://www.doxygen.org/"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="bison cmake coreutils flex perl python3"
+checkdepends="libxml2-utils"
+subpackages=""
+source="http://ftp.stack.nl/pub/users/dimitri/doxygen-$pkgver.src.tar.gz
+ doxygen-1.8.14-install.patch
+ "
+
+build() {
+ cd "$builddir"
+ cmake .\
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -Dbuild_xmlparser=ON \
+ -DMAN_INSTALL_DIR=/usr/share/man/man1 \
+ -DDOC_INSTALL_DIR=/usr/share/doc/doxygen
+
+ make
+}
+
+check() {
+ cd "$builddir"
+ # Remove test that use bibtex
+ rm -f ./testing/012_cite.dox
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5fac7e457a51b1f8e39fb65de5e0c07633e573f74e876580e7bcad5693540d6970fde1b2cb799a4df6ab9dfca951ece15b76b3010134d7658db3500183bea85c doxygen-1.8.14.src.tar.gz
+725a29a6f21ffc8ec6ca8ed6d746a69cc78060e97704c7fe909abee603ba0a99f27dc3b80c414afd886d0ee81d9948b13f29c43f7db2e00aae8c0c3a32aa9ec1 doxygen-1.8.14-install.patch"
diff --git a/user/doxygen/doxygen-1.8.14-install.patch b/user/doxygen/doxygen-1.8.14-install.patch
new file mode 100644
index 000000000..71448b8b4
--- /dev/null
+++ b/user/doxygen/doxygen-1.8.14-install.patch
@@ -0,0 +1,21 @@
+--- doxygen-1.8.14/doc/CMakeLists.txt.config 2017-12-31 15:28:32.351163123 +0100
++++ doxygen-1.8.14/doc/CMakeLists.txt 2017-12-31 15:29:11.490119182 +0100
+@@ -168,15 +168,15 @@ install(FILES
+ "${PROJECT_BINARY_DIR}/man/doxywizard.1"
+ "${PROJECT_BINARY_DIR}/man/doxysearch.1"
+ "${PROJECT_BINARY_DIR}/man/doxyindexer.1"
+- DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
++ DESTINATION "${MAN_INSTALL_DIR}"
+ )
+
+ install(FILES
+ "${PROJECT_BINARY_DIR}/latex/doxygen_manual.pdf"
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/${DOC_INSTALL_DIR}"
++ DESTINATION "${DOC_INSTALL_DIR}"
+ )
+
+ install(DIRECTORY
+ "${PROJECT_BINARY_DIR}/html"
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/${DOC_INSTALL_DIR}"
++ DESTINATION "${DOC_INSTALL_DIR}"
+ )