summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/xf86-input-evdev/APKBUILD2
-rw-r--r--user/xf86-input-joystick/APKBUILD3
-rw-r--r--user/xf86-input-keyboard/APKBUILD3
-rw-r--r--user/xf86-input-mouse/APKBUILD3
-rw-r--r--user/xf86-input-void/APKBUILD3
-rw-r--r--user/xf86-video-ast/APKBUILD3
-rw-r--r--user/xf86-video-ati/APKBUILD3
-rw-r--r--user/xf86-video-cirrus/APKBUILD3
-rw-r--r--user/xf86-video-fbdev/APKBUILD5
-rw-r--r--user/xf86-video-geode/APKBUILD3
-rw-r--r--user/xf86-video-intel/APKBUILD5
-rw-r--r--user/xf86-video-mach64/APKBUILD3
-rw-r--r--user/xf86-video-mga/APKBUILD3
-rw-r--r--user/xf86-video-openchrome/APKBUILD4
-rw-r--r--user/xf86-video-qxl/APKBUILD3
-rw-r--r--user/xf86-video-r128/APKBUILD3
-rw-r--r--user/xorg-drivers/APKBUILD12
17 files changed, 10 insertions, 54 deletions
diff --git a/user/xf86-input-evdev/APKBUILD b/user/xf86-input-evdev/APKBUILD
index caa0ae96f..0896f48fa 100644
--- a/user/xf86-input-evdev/APKBUILD
+++ b/user/xf86-input-evdev/APKBUILD
@@ -6,10 +6,10 @@ pkgdesc="X.Org generic input driver"
url="https://www.X.Org/"
arch="all"
license="MIT"
-subpackages="$pkgname-doc $pkgname-dev"
depends=""
makedepends="libxkbfile-dev xorg-server-dev libxi-dev libxrandr-dev
eudev-dev mtdev-dev libevdev-dev"
+subpackages="$pkgname-doc $pkgname-dev"
source="https://www.X.Org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
build() {
diff --git a/user/xf86-input-joystick/APKBUILD b/user/xf86-input-joystick/APKBUILD
index c71441234..d2816b435 100644
--- a/user/xf86-input-joystick/APKBUILD
+++ b/user/xf86-input-joystick/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-input-joystick-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-input-keyboard/APKBUILD b/user/xf86-input-keyboard/APKBUILD
index 600a12ec6..cc6ce0528 100644
--- a/user/xf86-input-keyboard/APKBUILD
+++ b/user/xf86-input-keyboard/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-input-keyboard-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-input-mouse/APKBUILD b/user/xf86-input-mouse/APKBUILD
index eaefa3bb0..8082ce5f2 100644
--- a/user/xf86-input-mouse/APKBUILD
+++ b/user/xf86-input-mouse/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-input-mouse-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-input-void/APKBUILD b/user/xf86-input-void/APKBUILD
index 9ce25b0f7..8f559b25f 100644
--- a/user/xf86-input-void/APKBUILD
+++ b/user/xf86-input-void/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-input-void-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-ast/APKBUILD b/user/xf86-video-ast/APKBUILD
index 0d90f631b..2ba078de0 100644
--- a/user/xf86-video-ast/APKBUILD
+++ b/user/xf86-video-ast/APKBUILD
@@ -13,7 +13,6 @@ subpackages=""
source="https://www.x.org/releases/individual/driver/xf86-video-ast-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-ati/APKBUILD b/user/xf86-video-ati/APKBUILD
index 3f867c166..e73509e18 100644
--- a/user/xf86-video-ati/APKBUILD
+++ b/user/xf86-video-ati/APKBUILD
@@ -7,15 +7,14 @@ url="https://www.X.Org/"
arch="all"
options="!check" # No test suite.
license="MIT"
-subpackages="$pkgname-doc"
depends="mesa-dri-ati"
makedepends="eudev-dev libdrm-dev libxi-dev mesa-dev pixman-dev util-macros
xorg-server-dev"
+subpackages="$pkgname-doc"
source="https://www.X.Org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
build() {
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
diff --git a/user/xf86-video-cirrus/APKBUILD b/user/xf86-video-cirrus/APKBUILD
index 1c26532ea..56cdf55fa 100644
--- a/user/xf86-video-cirrus/APKBUILD
+++ b/user/xf86-video-cirrus/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-video-cirrus-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-fbdev/APKBUILD b/user/xf86-video-fbdev/APKBUILD
index d514f987d..b78739650 100644
--- a/user/xf86-video-fbdev/APKBUILD
+++ b/user/xf86-video-fbdev/APKBUILD
@@ -6,13 +6,12 @@ pkgdesc="Framebuffer video driver for X11"
url="https://www.X.Org/"
arch="all"
license="MIT"
-subpackages="$pkgname-doc"
depends=""
makedepends="libxi-dev util-macros xorgproto-dev xorg-server-dev"
+subpackages="$pkgname-doc"
source="https://www.X.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -22,12 +21,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
diff --git a/user/xf86-video-geode/APKBUILD b/user/xf86-video-geode/APKBUILD
index 0ba4f2954..71749e608 100644
--- a/user/xf86-video-geode/APKBUILD
+++ b/user/xf86-video-geode/APKBUILD
@@ -16,7 +16,6 @@ source="https://www.x.org/releases/individual/driver/xf86-video-geode-$pkgver.ta
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +27,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-intel/APKBUILD b/user/xf86-video-intel/APKBUILD
index 6727ce394..7ffb832b9 100644
--- a/user/xf86-video-intel/APKBUILD
+++ b/user/xf86-video-intel/APKBUILD
@@ -9,11 +9,11 @@ url="https://xorg.freedesktop.org"
arch="pmmx x86_64"
options="!check" # No test suite.
license="MIT"
-subpackages="$pkgname-doc"
depends="mesa-dri-intel"
makedepends="xorg-server-dev libxi-dev libdrm-dev mesa-dev libxvmc-dev
xcb-util-dev eudev-dev util-macros autoconf automake libtool xorgproto
"
+subpackages="$pkgname-doc"
source="https://dev.sick.bike/$pkgname-$pkgver.tar.gz
pmmx.patch
"
@@ -21,13 +21,11 @@ giturl="https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel.git"
reporev="3d395062ce73f85e8340218df01c2ebf4bc25023"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -40,7 +38,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
rm "$pkgdir"/usr/libexec/xf86-video-intel-backlight-helper
diff --git a/user/xf86-video-mach64/APKBUILD b/user/xf86-video-mach64/APKBUILD
index 2fdbb93c7..0ab4416af 100644
--- a/user/xf86-video-mach64/APKBUILD
+++ b/user/xf86-video-mach64/APKBUILD
@@ -13,7 +13,6 @@ subpackages=""
source="https://www.x.org/releases/individual/driver/xf86-video-mach64-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-mga/APKBUILD b/user/xf86-video-mga/APKBUILD
index adfbc5b31..14b891e37 100644
--- a/user/xf86-video-mga/APKBUILD
+++ b/user/xf86-video-mga/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-video-mga-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-openchrome/APKBUILD b/user/xf86-video-openchrome/APKBUILD
index 10832e4ae..1b71f0b87 100644
--- a/user/xf86-video-openchrome/APKBUILD
+++ b/user/xf86-video-openchrome/APKBUILD
@@ -13,13 +13,11 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/driver/xf86-video-openchrome-$pkgver.tar.bz2"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-qxl/APKBUILD b/user/xf86-video-qxl/APKBUILD
index 3106debc5..57c54f403 100644
--- a/user/xf86-video-qxl/APKBUILD
+++ b/user/xf86-video-qxl/APKBUILD
@@ -14,7 +14,6 @@ subpackages=""
source="https://www.x.org/releases/individual/driver/xf86-video-qxl-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xf86-video-r128/APKBUILD b/user/xf86-video-r128/APKBUILD
index 094b11633..0e6702994 100644
--- a/user/xf86-video-r128/APKBUILD
+++ b/user/xf86-video-r128/APKBUILD
@@ -15,7 +15,6 @@ source="https://www.x.org/releases/individual/driver/xf86-video-r128-$pkgver.tar
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +26,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xorg-drivers/APKBUILD b/user/xorg-drivers/APKBUILD
index 18bd7e6cf..c39fce3ba 100644
--- a/user/xorg-drivers/APKBUILD
+++ b/user/xorg-drivers/APKBUILD
@@ -13,11 +13,11 @@ depends="xf86-input-evdev xf86-input-joystick xf86-input-keyboard
xf86-input-void xf86-input-wacom
xf86-video-amdgpu xf86-video-ast xf86-video-ati xf86-video-cirrus
- xf86-video-dummy xf86-video-fbdev xf86-video-freedreno xf86-video-glint
- xf86-video-mach64 xf86-video-mga xf86-video-nouveau
- xf86-video-openchrome xf86-video-qxl xf86-video-r128
- xf86-video-rendition xf86-video-sis xf86-video-sisusb xf86-video-tdfx
- xf86-video-trident xf86-video-v4l xf86-video-vboxvideo xf86-video-vesa"
+ xf86-video-dummy xf86-video-fbdev xf86-video-glint xf86-video-mach64
+ xf86-video-mga xf86-video-nouveau xf86-video-openchrome xf86-video-qxl
+ xf86-video-r128 xf86-video-rendition xf86-video-sis xf86-video-sisusb
+ xf86-video-tdfx xf86-video-trident xf86-video-v4l xf86-video-vboxvideo
+ xf86-video-vesa"
case $CTARGET_ARCH in
pmmx)
depends="$depends xf86-video-geode xf86-video-intel" ;;
@@ -28,7 +28,7 @@ case $CTARGET_ARCH in
esac
case $CTARGET_ARCH in
aarch64*|arm*)
- ;;
+ depends="$depends xf86-video-freedreno";;
*)
depends="$depends xf86-video-siliconmotion xf86-video-vmware";;
esac