summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--system/coreutils/APKBUILD42
-rw-r--r--system/coreutils/coreutils.post-deinstall2
-rw-r--r--system/coreutils/localename-test-fix.patch4
3 files changed, 27 insertions, 21 deletions
diff --git a/system/coreutils/APKBUILD b/system/coreutils/APKBUILD
index c92568720..7356dabf9 100644
--- a/system/coreutils/APKBUILD
+++ b/system/coreutils/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=coreutils
-pkgver=8.28
+pkgver=8.29
pkgrel=0
-pkgdesc="The basic file, shell and text manipulation utilities"
+pkgdesc="Basic file, shell, and text manipulation utilities"
url="http://www.gnu.org/software/coreutils/"
arch="all"
-license="GPL3+"
+license="GPL-3.0+"
options="!checkroot"
-makedepends="bash acl-dev attr-dev gettext-dev"
-[ ${CBUILD} == ${CHOST} ] && makedepends="$makedepends perl"
+makedepends="bash acl-dev attr-dev"
+[ ${CBUILD} == ${CHOST} ] && makedepends="$makedepends perl gettext-tiny
+ gettext-tiny-dev utmps-dev"
subpackages="$pkgname-doc"
[ ${CBUILD} == ${CHOST} ] && subpackages="$subpackages $pkgname-lang"
install="$pkgname.post-deinstall"
@@ -22,11 +23,9 @@ source="http://ftp.gnu.org/gnu/coreutils/$pkgname-$pkgver.tar.xz
051_all_coreutils-mangen.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
-
build() {
cd "$builddir"
- LIBS="-lrt" ./configure \
+ LIBS="-lutmps -lskarnet" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -37,7 +36,9 @@ build() {
--without-gmp \
--enable-no-install-program=hostname,su,kill,uptime \
--with-packager="Adélie" \
- --with-packager-bug-reports="https://bts.adelielinux.org/"
+ --with-packager-bug-reports="https://bts.adelielinux.org/" \
+ --enable-single-binary=symlinks
+
if [ ${CBUILD} != ${CHOST} ]; then
set -- man/*.x
touch ${@/%x/1}
@@ -60,18 +61,23 @@ package() {
install -d "$pkgdir"/bin "$pkgdir"/usr/sbin
cd "$pkgdir"/usr/bin/
- # binaries that busybox puts in /bin
- mv base64 cat chgrp chmod chown cp date dd df 'echo' false ln ls \
- mkdir mknod mktemp mv nice printenv pwd rm rmdir sleep stat \
- stty sync touch true uname \
- "$pkgdir"/bin
+ # We want to put these in /bin to match busybox (?)
+ local busybox_bin="base64 cat chgrp chmod chown cp date dd df echo
+ false ln ls mkdir mknod mktemp mv nice printenv pwd rm rmdir
+ sleep stat stty sync touch true uname"
+
+ for i in $busybox_bin; do
+ rm "$pkgdir"/usr/bin/$i
+ ln -s ../usr/bin/coreutils "$pkgdir"/bin/$i
+ done
- mv chroot "$pkgdir"/usr/sbin/
+ rm "$pkgdir"/usr/bin/chroot
+ ln -s ../bin/coreutils "$pkgdir"/usr/sbin/chroot
}
-sha512sums="1e592d0dd03b9227bf92af9a82bed6dc3bcbee46e984c7fb09833dea0962e86b309aa34d5e43823b73d4522c066bfa5cdc8ec694aa190910fb246ff32ceb63a1 coreutils-8.28.tar.xz
+sha512sums="546bbcd5741beae7a68e7c4ca14d6d634f7c8be87feecdeddd00e226f4865bb89d503437c3a95622ba7bb0cb70addbb5bdf3767fa18d0b7410ab90ee53b29dfd coreutils-8.29.tar.xz
532ef8210261437855ba3e2fc72ec57b0e0252b2b0f7817990c9629613ece2cdd86cf30aa049f3cff6fbda12ed3bb9a0db3a3642475378ae44ce319bdf005d9b disable-mbrtowc-test.patch
-00a517c7e3e2206ba7a60f9126d28ae1d549e86da62b48f32250d49c2caf896c53fc3d803729b544a1cfb1609dd8cb7cb4b3473defef5d1e2c154ed1de6bc5de localename-test-fix.patch"
+a6cbe77d2fd3655e59ead9ec5cfcc80ae8c1a688f779219910d9370a0e5f86195e2d3a1ca427a374d8457c5ca04ebb72f8bac0b7a7415337bac3545a85d22e3d localename-test-fix.patch"
[ ${CBUILD} != ${CHOST} ] && sha512sums="$sha512sums
bae804f057252c25452ac178c545dc2c4b4775cbfbdcfd4775edd1a4ed6507882bfac39e2b11ad01b74230ca48d761bf62f11bde5bcbc35a6e5a61cbe4a46e36 051_all_coreutils-mangen.patch
diff --git a/system/coreutils/coreutils.post-deinstall b/system/coreutils/coreutils.post-deinstall
index 24e0bdf25..d327f541d 100644
--- a/system/coreutils/coreutils.post-deinstall
+++ b/system/coreutils/coreutils.post-deinstall
@@ -1,4 +1,4 @@
#!/bin/sh
# other post scripts might need rm so we don't wait for the trigger
-exec /bin/busybox --install -s
+[ ! -f /bin/busybox ] || exec /bin/busybox --install -s
diff --git a/system/coreutils/localename-test-fix.patch b/system/coreutils/localename-test-fix.patch
index f90d11866..9907eb67a 100644
--- a/system/coreutils/localename-test-fix.patch
+++ b/system/coreutils/localename-test-fix.patch
@@ -19,7 +19,7 @@
+# if __GLIBC__ >= 2 && !defined __UCLIBC__
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
+ See <https://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
- const char *name =
- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
+ if (name[0] == '\0')
@@ -30,5 +30,5 @@
name = thread_locale->__names[category];
+# endif
return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
+ # elif (defined __FreeBSD__ || defined __DragonFly__) || (defined __APPLE__ && defined __MACH__)
/* FreeBSD, Mac OS X */