summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/libmtp/APKBUILD3
-rw-r--r--user/libxaw/APKBUILD3
-rw-r--r--user/xbitmaps/APKBUILD4
-rw-r--r--user/xmessage/APKBUILD4
-rw-r--r--user/xset/APKBUILD5
-rw-r--r--user/xsetroot/APKBUILD5
6 files changed, 4 insertions, 20 deletions
diff --git a/user/libmtp/APKBUILD b/user/libmtp/APKBUILD
index 3f8e07b45..e6187c747 100644
--- a/user/libmtp/APKBUILD
+++ b/user/libmtp/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/libmtp/libmtp-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libxaw/APKBUILD b/user/libxaw/APKBUILD
index a817b0bb1..3dd598556 100644
--- a/user/libxaw/APKBUILD
+++ b/user/libxaw/APKBUILD
@@ -14,7 +14,6 @@ source="https://www.X.Org/releases/individual/lib/libXaw-$pkgver.tar.bz2"
builddir="$srcdir"/libXaw-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xbitmaps/APKBUILD b/user/xbitmaps/APKBUILD
index 47ca8efca..3052984ef 100644
--- a/user/xbitmaps/APKBUILD
+++ b/user/xbitmaps/APKBUILD
@@ -8,10 +8,10 @@ arch="noarch"
license="X11"
depends="util-macros"
makedepends=""
+subpackages=""
source="https://www.X.Org/releases/individual/data/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -20,12 +20,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xmessage/APKBUILD b/user/xmessage/APKBUILD
index 145daeec0..21c5cf84a 100644
--- a/user/xmessage/APKBUILD
+++ b/user/xmessage/APKBUILD
@@ -6,12 +6,12 @@ pkgdesc="Display a message or query in a window"
url="https://www.X.Org/"
arch="all"
license="X11"
+depends=""
makedepends="libx11-dev libxaw-dev util-macros"
subpackages="$pkgname-doc"
source="https://www.X.Org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xset/APKBUILD b/user/xset/APKBUILD
index 9abfb3d46..e751862c2 100644
--- a/user/xset/APKBUILD
+++ b/user/xset/APKBUILD
@@ -7,13 +7,12 @@ pkgdesc="User preference utility for X11"
url="https://www.X.Org/"
arch="all"
license="X11"
-subpackages="$pkgname-doc"
depends=""
makedepends="libx11-dev libxext-dev libxmu-dev util-macros"
+subpackages="$pkgname-doc"
source="https://www.X.Org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/xsetroot/APKBUILD b/user/xsetroot/APKBUILD
index d5d6d4d9a..e4ad05a2d 100644
--- a/user/xsetroot/APKBUILD
+++ b/user/xsetroot/APKBUILD
@@ -6,13 +6,12 @@ pkgdesc="Set the root window (desktop background) of an X11 session"
url="https://www.X.Org/"
arch="all"
license="MIT"
-subpackages="$pkgname-doc"
depends=""
makedepends="libx11-dev libxcursor-dev libxmu-dev util-macros xbitmaps"
+subpackages="$pkgname-doc"
source="https://www.X.Org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}