summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/perl-pod-constants/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-pod-constants/APKBUILD b/user/perl-pod-constants/APKBUILD
new file mode 100644
index 000000000..bfb2802d7
--- /dev/null
+++ b/user/perl-pod-constants/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-pod-constants
+pkgver=0.19
+pkgrel=0
+pkgdesc="Perl module for pulling constants from POD text"
+url="https://metacpan.org/pod/Pod::Constants"
+arch="noarch"
+license="Artistic-2.0"
+depends="perl"
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/M/MG/MGV/Pod-Constants-$pkgver.tar.gz"
+builddir="$srcdir/Pod-Constants-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="4c7b7ccdede87f0069bf100406de5b2320b5f9cb0363d413e90b419e512d4322114851d78fdd7a1bce63347ee5986ecd397b11579b91eee6e46d9b0a82b0b64a Pod-Constants-0.19.tar.gz"