summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/convertlit/APKBUILD2
-rw-r--r--user/ebook-tools/APKBUILD7
-rw-r--r--user/freecell-solver/APKBUILD9
-rw-r--r--user/gnu-ghostscript/APKBUILD3
-rw-r--r--user/gsl/APKBUILD3
-rw-r--r--user/libexif/APKBUILD5
-rw-r--r--user/libgphoto2/APKBUILD6
-rw-r--r--user/libieee1284/APKBUILD7
-rw-r--r--user/libspectre/APKBUILD3
-rw-r--r--user/libtap/APKBUILD2
-rw-r--r--user/libzip/APKBUILD3
-rw-r--r--user/net-snmp/APKBUILD8
-rw-r--r--user/openal-soft/APKBUILD19
-rw-r--r--user/perl-crypt-rijndael/APKBUILD2
-rw-r--r--user/perl-net-snmp/APKBUILD2
-rw-r--r--user/perl-test-manifest/APKBUILD4
-rw-r--r--user/py3-pycotap/APKBUILD3
-rw-r--r--user/py3-random2/APKBUILD4
-rw-r--r--user/qca/APKBUILD4
-rw-r--r--user/quazip/APKBUILD2
-rw-r--r--user/valgrind/APKBUILD9
21 files changed, 28 insertions, 79 deletions
diff --git a/user/convertlit/APKBUILD b/user/convertlit/APKBUILD
index 49cce0d46..d7b886afb 100644
--- a/user/convertlit/APKBUILD
+++ b/user/convertlit/APKBUILD
@@ -17,13 +17,11 @@ source="http://www.convertlit.com/${pkgname}${pkgver/./}src.zip
builddir="$srcdir/"
build() {
- cd "$builddir"
make -C lib
make -C clit18
}
package() {
- cd "$builddir"
install -D -m755 clit18/clit "$pkgdir"/usr/bin/clit
}
diff --git a/user/ebook-tools/APKBUILD b/user/ebook-tools/APKBUILD
index 6c33ad3d5..6eeeb3cdb 100644
--- a/user/ebook-tools/APKBUILD
+++ b/user/ebook-tools/APKBUILD
@@ -8,12 +8,11 @@ url="https://sourceforge.net/projects/ebook-tools/"
arch="all"
license="MIT"
depends="convertlit cmd:which"
-makedepends="libxml2-dev libzip-dev"
+makedepends="cmake libxml2-dev libzip-dev"
subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/ebook-tools/ebook-tools-$pkgver.tar.gz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -22,17 +21,15 @@ build() {
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/freecell-solver/APKBUILD b/user/freecell-solver/APKBUILD
index 78c1eadb5..57ebc05a2 100644
--- a/user/freecell-solver/APKBUILD
+++ b/user/freecell-solver/APKBUILD
@@ -8,15 +8,14 @@ url="https://fc-solve.shlomifish.org/"
arch="all"
license="MIT"
depends="python3"
-makedepends="gperf perl perl-task-freecellsolver-testing python3 py3-random2
- py3-six"
checkdepends="gmp-dev libtap-dev perl-dev py3-cffi py3-pycotap the_silver_searcher
valgrind"
+makedepends="cmake gperf perl perl-task-freecellsolver-testing python3
+ py3-random2 py3-six"
subpackages="$pkgname-dev $pkgname-doc"
source="https://fc-solve.shlomifish.org/downloads/fc-solve/freecell-solver-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -26,19 +25,17 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
# The build system generates header files; jobs >1 may cause failures
# because .h don't exist yet.
make -j1
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/gnu-ghostscript/APKBUILD b/user/gnu-ghostscript/APKBUILD
index 0c09a5aa9..583194c4b 100644
--- a/user/gnu-ghostscript/APKBUILD
+++ b/user/gnu-ghostscript/APKBUILD
@@ -18,7 +18,6 @@ source="ftp://ftp.gnu.org/gnu/ghostscript/gnu-ghostscript-$pkgver.tar.xz
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,12 +32,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" soinstall
install -D -m644 base/*.h "$pkgdir"/usr/include/ghostscript
diff --git a/user/gsl/APKBUILD b/user/gsl/APKBUILD
index 4d2a5d929..a16ec413e 100644
--- a/user/gsl/APKBUILD
+++ b/user/gsl/APKBUILD
@@ -20,7 +20,6 @@ source="https://ftp.gnu.org/gnu/gsl/gsl-$pkgver.tar.gz
# https://github.com/SciRuby/rb-gsl/issues/40
build() {
- cd "$builddir"
[ $CTARGET_ARCH != "ppc" ] || export ac_cv_c_ieee_interface=unknown
./configure \
--build=$CBUILD \
@@ -30,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libexif/APKBUILD b/user/libexif/APKBUILD
index 71c9f7d06..de51ae7b0 100644
--- a/user/libexif/APKBUILD
+++ b/user/libexif/APKBUILD
@@ -11,7 +11,8 @@ depends=""
makedepends=""
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
CVE-2017-7544.patch
- CVE-2018-20030.patch"
+ CVE-2018-20030.patch
+ "
# secfixes:
# 0.6.21-r3:
@@ -19,8 +20,8 @@ source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
# - CVE-2018-20030
prepare() {
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
diff --git a/user/libgphoto2/APKBUILD b/user/libgphoto2/APKBUILD
index c1250aabb..aee8693b1 100644
--- a/user/libgphoto2/APKBUILD
+++ b/user/libgphoto2/APKBUILD
@@ -10,13 +10,11 @@ license="LGPL-2.1+"
depends=""
depends_dev="libexif-dev libusb-dev"
makedepends="$depends_dev libjpeg-turbo-dev libtool"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-replaces="libgphoto2-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://downloads.sourceforge.net/gphoto/libgphoto2-$pkgver.tar.bz2"
build() {
- cd "$builddir"
udevscriptdir=/lib/udev ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +26,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/lib/libgphoto2/*/*.a \
"$pkgdir"/usr/lib/*.a
diff --git a/user/libieee1284/APKBUILD b/user/libieee1284/APKBUILD
index 44996cee3..7bf7633a7 100644
--- a/user/libieee1284/APKBUILD
+++ b/user/libieee1284/APKBUILD
@@ -8,10 +8,12 @@ url="http://cyberelk.net/tim/software/libieee1284/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
+depends=""
makedepends="file"
subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
- include.patch"
+ include.patch
+ "
prepare() {
default_prepare
@@ -19,8 +21,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -30,7 +30,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libspectre/APKBUILD b/user/libspectre/APKBUILD
index 2e43f6abc..0caa4b284 100644
--- a/user/libspectre/APKBUILD
+++ b/user/libspectre/APKBUILD
@@ -13,7 +13,6 @@ subpackages="$pkgname-dev"
source="https://libspectre.freedesktop.org/releases/libspectre-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libtap/APKBUILD b/user/libtap/APKBUILD
index b8a992768..e2e8aa026 100644
--- a/user/libtap/APKBUILD
+++ b/user/libtap/APKBUILD
@@ -22,7 +22,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
diff --git a/user/libzip/APKBUILD b/user/libzip/APKBUILD
index 9c1836e60..379075ae7 100644
--- a/user/libzip/APKBUILD
+++ b/user/libzip/APKBUILD
@@ -9,6 +9,7 @@ pkgdesc="C library for manipulating ZIP archives"
url="https://libzip.org/"
arch="all"
license="BSD-3-Clause"
+depends=""
depends_dev="zlib-dev"
makedepends="$depends_dev cmake openssl-dev perl"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
@@ -25,7 +26,7 @@ build() {
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS"
+ -DCMAKE_C_FLAGS="$CFLAGS" .
make
}
diff --git a/user/net-snmp/APKBUILD b/user/net-snmp/APKBUILD
index 9f083a732..3fc1bceb4 100644
--- a/user/net-snmp/APKBUILD
+++ b/user/net-snmp/APKBUILD
@@ -26,18 +26,13 @@ source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
"
prepare() {
- update_config_sub
default_prepare
- # Allow tmpfs volume size monitoring
- # Ref #932
+ update_config_sub
sed -e 's#"tmpfs",#/* "tmpfs", */#g' -i agent/mibgroup/host/hr_filesys.c
}
build() {
- cd "$builddir"
-
export lt_cv_sys_max_cmd_len=8192
-
LIBS="-ltinfow" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -64,7 +59,6 @@ build() {
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
# remove things we dont want distribute
rm "$pkgdir"/usr/lib/libsnmp* \
diff --git a/user/openal-soft/APKBUILD b/user/openal-soft/APKBUILD
index d5d32afe3..3f5f9c29d 100644
--- a/user/openal-soft/APKBUILD
+++ b/user/openal-soft/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="Software implementation of OpenAL API"
url="https://kcat.strangesoft.net/openal.html"
arch="all"
+options="!check" # No test suite.
license="LGPL-2.0+"
depends=""
depends_dev="alsa-lib-dev"
@@ -13,14 +14,8 @@ makedepends="$depends_dev cmake linux-headers pulseaudio-dev"
subpackages="$pkgname-dev"
source="https://kcat.strangesoft.net/openal-releases/${pkgname}-${pkgver}.tar.bz2"
-prepare() {
- default_prepare
- mkdir -p "$builddir"/build
-}
-
build() {
local _cpuext_neon=""
- cd "$builddir"/build
case "$CARCH" in
armhf) _cpuext_neon="-DALSOFT_CPUEXT_NEON=OFF" ;;
esac
@@ -28,18 +23,12 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
$_cpuext_neon \
- "$builddir"
- make
-}
-
-check() {
- cd "$builddir"/build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ -Bbuild
+ make -C build
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C build install
}
sha512sums="356a3f12bbe284bfac71f4f2a9f83d084083a832012222e73743042ac27812cf051c12b0ddcf53c010ff77e44ae2e9033cea9b9324d316a22a59a154307a64a4 openal-soft-1.19.1.tar.bz2"
diff --git a/user/perl-crypt-rijndael/APKBUILD b/user/perl-crypt-rijndael/APKBUILD
index 6f5678cc2..8f7c3cf1c 100644
--- a/user/perl-crypt-rijndael/APKBUILD
+++ b/user/perl-crypt-rijndael/APKBUILD
@@ -10,7 +10,7 @@ pkgdesc="Crypt::CBC compliant Rijndael encryption module"
url="https://metacpan.org/release/Crypt-Rijndael"
arch="all"
license="LGPL-3.0+"
-depends="perl-test-manifest"
+depends="perl perl-test-manifest"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://search.cpan.org/CPAN/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz
diff --git a/user/perl-net-snmp/APKBUILD b/user/perl-net-snmp/APKBUILD
index 1fe4d5df9..6bf970c7a 100644
--- a/user/perl-net-snmp/APKBUILD
+++ b/user/perl-net-snmp/APKBUILD
@@ -12,7 +12,7 @@ pkgdesc="Object oriented interface to SNMP"
url="https://metacpan.org/release/Net-SNMP"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-depends="perl-crypt-des perl-crypt-rijndael perl-digest-hmac perl-digest-sha1"
+depends="perl perl-crypt-des perl-crypt-rijndael perl-digest-hmac perl-digest-sha1"
makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
source="https://search.cpan.org/CPAN/authors/id/$_a/$_au/$_author/$_pkgreal-v$pkgver.tar.gz"
diff --git a/user/perl-test-manifest/APKBUILD b/user/perl-test-manifest/APKBUILD
index 30e610f1d..a329fa2f2 100644
--- a/user/perl-test-manifest/APKBUILD
+++ b/user/perl-test-manifest/APKBUILD
@@ -1,5 +1,3 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-manifest
_pkgreal=Test-Manifest
@@ -13,7 +11,7 @@ url="https://metacpan.org/release/Test-Manifest"
arch="noarch"
license="Artistic-2.0"
depends="perl"
-makedepends=""
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https:///cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
diff --git a/user/py3-pycotap/APKBUILD b/user/py3-pycotap/APKBUILD
index a2731dc39..1a1ced5c9 100644
--- a/user/py3-pycotap/APKBUILD
+++ b/user/py3-pycotap/APKBUILD
@@ -15,17 +15,14 @@ source="https://files.pythonhosted.org/packages/a1/99/f1dfa70ffe1140f701ba979763
builddir="$srcdir/$_pipname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
diff --git a/user/py3-random2/APKBUILD b/user/py3-random2/APKBUILD
index d8ac44035..da7838e39 100644
--- a/user/py3-random2/APKBUILD
+++ b/user/py3-random2/APKBUILD
@@ -12,22 +12,18 @@ arch="noarch"
license="Python-2.0"
depends="python3"
makedepends="python3-dev"
-install=""
source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONPATH="build/lib" python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
diff --git a/user/qca/APKBUILD b/user/qca/APKBUILD
index cd0210d0b..fd2dc82f1 100644
--- a/user/qca/APKBUILD
+++ b/user/qca/APKBUILD
@@ -13,21 +13,19 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://download.kde.org/stable/qca/$pkgver/qca-${pkgver}.tar.xz"
build() {
- cd "$builddir"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DWITH_cyrus-sasl_PLUGIN=yes \
.
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/quazip/APKBUILD b/user/quazip/APKBUILD
index bae54fd46..f6afd9948 100644
--- a/user/quazip/APKBUILD
+++ b/user/quazip/APKBUILD
@@ -8,7 +8,7 @@ url="https://stachenov.github.io/quazip/"
arch="all"
license="LGPL-2.1-only WITH Static-linking-exception"
depends=""
-makedepends="qt5-qtbase-dev zlib-dev"
+makedepends="cmake qt5-qtbase-dev zlib-dev"
subpackages="$pkgname-dev"
source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/v$pkgver.tar.gz"
diff --git a/user/valgrind/APKBUILD b/user/valgrind/APKBUILD
index f676d18e8..4bcc705b9 100644
--- a/user/valgrind/APKBUILD
+++ b/user/valgrind/APKBUILD
@@ -5,14 +5,15 @@ pkgrel=0
pkgdesc="A tool to help find memory-management problems in programs"
url="http://valgrind.org/"
arch="all"
-license="GPL-2.0+"
-makedepends="autoconf automake libtool bash perl cmd:which"
# from README_PACKAGERS:
# Don't strip the debug info off lib/valgrind/$platform/vgpreload*.so
# in the installation tree. Either Valgrind won't work at all, or it
# will still work if you do, but will generate less helpful error
# messages.
options="!strip !check"
+license="GPL-2.0+"
+depends=""
+makedepends="autoconf automake libtool bash perl cmd:which"
subpackages="$pkgname-dev $pkgname-doc"
source="ftp://sourceware.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2
0001-Ensure-ELFv2-is-supported-on-PPC64.patch
@@ -24,13 +25,11 @@ source="ftp://sourceware.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2
prepare() {
default_prepare
- cd "$builddir"
aclocal && autoconf && automake --add-missing
echo '#include <linux/a.out.h>' > include/a.out.h
}
build() {
- cd "$builddir"
# fails to build with ccache
export CC="gcc"
export CFLAGS="$CFLAGS -fno-stack-protector -no-pie"
@@ -47,12 +46,10 @@ build() {
}
check() {
- cd "$buildir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# we have options=!strip above so we strip the /usr/bin/* manually