summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--user/libmaxminddb/APKBUILD1
-rw-r--r--user/lua-yaml/APKBUILD2
-rw-r--r--user/yaml-cpp/APKBUILD10
3 files changed, 2 insertions, 11 deletions
diff --git a/user/libmaxminddb/APKBUILD b/user/libmaxminddb/APKBUILD
index b7724ffdf..f1762c4ca 100644
--- a/user/libmaxminddb/APKBUILD
+++ b/user/libmaxminddb/APKBUILD
@@ -9,7 +9,6 @@ arch="all"
license="Apache-2.0"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/maxmind/libmaxminddb/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
./configure \
diff --git a/user/lua-yaml/APKBUILD b/user/lua-yaml/APKBUILD
index 6c835554f..f252b3a7b 100644
--- a/user/lua-yaml/APKBUILD
+++ b/user/lua-yaml/APKBUILD
@@ -6,10 +6,10 @@ pkgrel=0
pkgdesc="LibYAML binding for Lua"
url="https://gvvaughan.github.io/lyaml/"
arch="all"
+options="!check" # No tests, sweet.
license="MIT"
depends="lua5.3"
makedepends="lua5.3-dev yaml-dev"
-options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/gvvaughan/lyaml/archive/v$pkgver.tar.gz"
builddir="$srcdir/lyaml-$pkgver"
diff --git a/user/yaml-cpp/APKBUILD b/user/yaml-cpp/APKBUILD
index 4f7e7bfa9..53f41b87b 100644
--- a/user/yaml-cpp/APKBUILD
+++ b/user/yaml-cpp/APKBUILD
@@ -13,7 +13,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/jbeder/yaml-cpp/archive/yaml
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -30,17 +29,10 @@ build() {
}
check() {
- cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-check() {
- cd "$builddir"
- make test
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}